F.lux does not work suddenly



  • I dont know if its due to windows update or connecting my laptop to my tv via hdmi cable. I tried so much but it still is not working, reinstalled drivers, fast startup off, changed registry settings etc. Also i noticed that night light is also not working but i am able to change my color temperature through radeon settings, any solutions to this issue?
    Heres my driver info

    Advanced Micro Devices, Inc. 26.20.11015.5009: Radeon RX 560X Series (20190522)
    Advanced Micro Devices, Inc. 26.20.11015.5009: AMD Radeon(TM) Vega 8 Graphics (20190522)

    Generic PnP Monitor, 344 x 194mm, built 2018
    Chromaticities:
    R=0.583008 0.370117
    G=0.348633 0.559570
    B=0.157227 0.103516
    W=0.313477 0.329102

    sRGB gamut: 54%, AdobeRGB gamut: 35%

    Windows Build: 18362



  • Okay the first thing is to make sure you have 18362.207 (not an earlier version).

    We have heard several issues with the Radeon Vega, so keep us posted if this doesn't help.



  • @herf said in F.lux does not work suddenly:

    18362.207

    Its installed.. I dont know what the issue is



  • Also I found that i cant also calibrate my display through windows calibrator or a third party software that i downloaded.



  • However i found that it runs alright on safe mode probably something is conflicting.



  • I think i found the cause of this issue but I cant seem to find a way to fix the issue. I tried reinstalling the drivers again, but did not install them immediately to check some stuff in device manager, I found that after disabling Generic PnP Monitor under Monitors section f.lux starts working. But there is a problem, if I reinstall the drivers and then disable the device, my screen does not work and i have to start in safe mode to fix. I think someone can help me around this
    Sorry for the bad english



  • Another thing that I found.. So I connected my device to external tv and then what i found that disabling any one of the PnP monitors and restarting my device caused f.lux to start working again even with amd drivers installed. After that I restarted my drivers via cru application to see what will happen next and f.lux still worked. After that I disconnected my pc from tv with my laptop monitor still enabled(tv monitor disappeared under device manager) and then restarted driver this time f.lux disabled, its kinda strange when you think of it. Then i disabled driver and restarted, my screen went off after the action.
    So after all this I guess what I need to do is create a virtual monitor and keep it disabled I guess. Still its not clear.. though



  • AMD lists RX 560X as a laptop GPU - do you know if the second GPU is discrete (or vice-versa)? Maybe you can post what kind of machine this is, if there's any GPU/eGPU, & that might help.

    The Windows color system is shifting around a lot -- HDR and 10-bit color, so I imagine we are seeing one case or another fail, but it is hard to see.

    Also, it's possible that you could try "driver rollback" from the 2019/05/22 driver, and see if an earlier driver version works.



  • @herf said in F.lux does not work suddenly:

    AMD lists RX 560X as a laptop GPU - do you know if the second GPU is discrete (or vice-versa)? Maybe you can post what kind of machine this is, if there's any GPU/eGPU, & that might help.

    The Windows color system is shifting around a lot -- HDR and 10-bit color, so I imagine we are seeing one case or another fail, but it is hard to see.

    Also, it's possible that you could try "driver rollback" from the 2019/05/22 driver, and see if an earlier driver version works.

    This is is laptop with rx560x as dedicated graphics and ryzen 2500u with vega 8 graphics


Log in to reply