FIX for problems with the Windows 10 May update (1903/18362)



  • @rorix Same issue with me, check my thread for some info maybe it can help



  • @abhimahant Here's what's worked for me after all this trying.

    1. Uninstalled the drives.
    2. Uninstalled display monitor from device manager.
    3. Restart graphics driver using custom resolution utility.
    4. Finally installed drivers again but with windows not amd.
    5. Although the version of my drivers is old now. But i will update my drivers and see what happens.
      I cant confirm if 2nd step is important or not, your wish I guess.


  • Thank you so much for the information you have provided.I do admire the effort and consider this as a great help.



  • Help! I've read through both of the threads regarding errors with the recent updates. This program has helped so much with my migraines - I Need it!
    I have uninstalled and reinstalled f.lux after each attempt. I have uninstalled and reinstalled my display adapters. I have disabled fast start up. Tried adjusting display properties.
    Here's my driver info:

    Advanced Micro Devices, Inc. 15.201.1151.1008: AMD Radeon HD 5450 (20151104)
    Intel Corporation 10.18.10.4358: Intel(R) HD Graphics (20151221)

    AOC e2252V , 477 x 268mm, built 2013
    Chromaticities:
    R=0.647461 0.333984
    G=0.284180 0.607422
    B=0.151367 0.071289
    W=0.312500 0.329102

    sRGB gamut: 100%, AdobeRGB gamut: 69%

    Windows Build: 18362


  • f.lux team

    @jh211707 these are older drivers - are you able to try updating them?



  • I have the same problem since updating my CPU to a Ryzen 3 3200g, also updating from windoiw 7 to 10, I hope a solution is found

    Advanced Micro Devices, Inc. 26.20.13001.25001: AMD Radeon (TM) Vega 8 Graphics (20190730)

    Generic PnP Monitor, 410 x 230mm, built 2009
    Chromaticities:
       R = 0.648438 0.338867
       G = 0.291992 0.602539
       B = 0.142578 0.070313
       W = 0.313477 0.329102

    sRGB gamut: 93%, AdobeRGB gamut: 63%

    Windows Build: 18362



  • @herf I've been using the latest Adrenalin 19.7.5 beta drivers from July 30 to no avail. There are no newer drivers than that.

    Advanced Micro Devices, Inc. 26.20.13001.25001: AMD Radeon(TM) Vega 8 Graphics (20190730)

    HP 23xi IPS LED Backlit Monitor, 509 x 286mm, built 2014
    Chromaticities:
    R=0.635742 0.333984
    G=0.308594 0.623047
    B=0.150391 0.067383
    W=0.313477 0.329102

    sRGB gamut: 100%, AdobeRGB gamut: 69%

    Windows Build: 18362



  • @herf In checking for updates, there are none. Updating is what caused my issue. If there is another way to do this, I don't know how other than to manually do it in the Device Manager, but I am new to this. What [drivers] do I need to choose to force an update?



  • @herf I attempted to manually update both display adapters, but both said they had the newest update available. Same with my monitors.



  • UPDATE: The newest windows update has a bug that disables f.lux and all programs like it, including the windows built in Night Light. I recovered to a previous version to wait it out until the bug is fixed.


  • f.lux team

    @jh211707 we think this problem was fixed in 18362.207 and later, so the remaining issues are due to graphics drivers.



  • The issues with the Vega 8 persist on 18362.267



  • Hello

    We are having the exact same problem.

    We have been using F.Lux fine and testing this with a view to purchasing licencing for our organisation. We have a lot of users that would benefit from this using multiple screens. We use a multitude of different devices, graphics cards and drivers. I can tell you clearly that none of them matter as this has stopped working for all users since we patched to 1903. We have troubleshooted extensively so it is either Windows that has disabled it or something needs updating in your code and patching.

    Its disappointing that we have had to stop testing this and maybe hold off purchasing licences for our users because of this bug. Please could you investigate and fix it.

    Christopher

    We are all running Windows 10 1903 Build: 18362.267.



  • Not working for me as well. Since I updated the OS today. Going to try updating my drivers for NVIDIA.
    0_1565462066108_8541a23e-0ab6-4ea5-82d5-3942f9dddcc9-image.png



  • I've tried everything suggested with no luck. Flux only seems to work on my laptop screen but not on either of my external monitors.

    0_1565796312284_Capture.PNG


  • f.lux team

    Our 4.106 beta should partially fix older DisplayLink adapters that were not changing at all.



  • @herf Thanks for the beta version. Flux is now working properly. I'd had the same problem last year (after installing some major Windows update), but installing newer drivers solved the issue, but not this time. Here's some info about my system (2400G):

    Advanced Micro Devices, Inc. 26.20.13001.25001: AMD Radeon(TM) RX Vega 11 Graphics (20190730)
    Windows Build: 18362.239



  • It finally works good for me after all this time(with latest update)
    First i did windows update and then i installed latest drivers from amd
    I have acer nitro 5 ryzen laptop btw.



  • @herf After the May Windows 10 update my flux would not work. I am not particularly computer savvy but I tried a few of the recommended fixes. I finally gave up and began to wear my computer glasses again. Yesterday I got a notification that updates were available. I have an option to wait until I shut down for the day. Sure enough when I went to shut down I got the choice to update and restart later. Low and behold I booted up my computer at 4 am (couldn't sleep) and my flux was working. It had to be the update that fixed it. It went into see what the update was and here it is. It was Update for Microsoft Windows KB4512508. Hope this helps some people.


  • f.lux team

    4.107 rolling out now to beta - is a bit more careful with multiple monitor setups, should fix most cases.



  • @herf The 4.107 beta broke it again for me :( Just like before, instead of red tint I get grayscale. I thought that maybe the latest driver from AMD may fix it. But instead atikmdag.sys was causing blue screens on login screen all the time and I ended up rolling back to previous driver in safe mode.

    How can I go back to 4.106 which works fine for me?


  • f.lux team

    @phantom do you have two monitors on the same GPU? This is a bug we are working around in Windows right now. Does it work if you disable one?


  • f.lux team

    @phantom can you also check if your GPU is running in 8-bit or 10-bit mode on the desktop? https://www.amd.com/en/support/kb/faq/dh-008



  • @herf Yes, I'm using two monitors. I disabled them but nothing changes on either monitor. Both monitors are running in 8-bit mode.
    I've reinstalled flux and I'm back to 4.104 and can't update to beta version, even though the option in about menu is checked. I tried to check and uncheck the option, and to turn flux on/off multiple times but it doesn't seem to work this time.


  • f.lux team

    @phantom I found a note online that older drivers are working, like

    https://www.amd.com/en/support/kb/release-notes/rn-rad-win-18-10-2



  • @herf I tried to install those but it turns out they don't support the 2x00G series. Anyway, I used the 'clean uninstall' option this time and after restart (on whichever GPU driver version Windows provides, I didn't check) flux was working fine, but second monitor was inactive. So I installed the 19.7.5 version again and second monitor and flux work but... then I checked the Driver info and it says: AMD Radeon(TM) RX Vega 11 Graphics (20180730). I guess that's the Windows build-in driver. I don't understand why, there were no errors during installation. I tried to open the AMD app and it says that 'Radeon Settings and versions do not match' and to try to update to the latest version. Well, no thanks. I'm staying on the current version, I don't need the AMD Settings app to work anyway.



  • I tried everything, reg fixes, reinstalling Flux, disabling fast startup, resetting color profiles under Color Management, making sure night light is off, reinstalling Intel graphics drivers, etc.

    Turns out, it was the stupid Lenovo Vantage app on my laptop that was causing the issue. You guys might wanna verify there are no apps controlling the brightness/colour.

    0_1567738333419_2a7d8b26-10c6-4b51-8ded-82a796758956-image.png



  • @chaoscreater Thanks!
    Just found your solution! turned off Lenovo eyes saver and now my screen captures work great,
    but my eyes hurt!



  • @chaoscreater This solved the issue for me as well. I only created this account moments ago to say thanks.



  • I actually have this issue using any screenshot tool.
    It's not related to a specific tool.

    And indeed I also have the Lenovo Vantage app which is part of the issue.
    Disabling it fixes it, however is indeed painful for the eyes.

    So, the question is, why did it only break now. I hope the lenovo and microsoft guys can figure this one out.



  • Hi,
    I have the most interesting issue with f.lux, which in my case runs on Win 10 laptop with an extra monitor.

    The software stops running exactly 9pm. every day and has to be restarted to resume normal state.



  • @chaoscreater I actually have to turn eye care on to get my screen close to normal brightness... Problem is still there with it off, flux disabled/uninstalled, etc. Any other ideas?



  • I have a Lenovo Thinkpad carbon X1 and this has also just started happening in the last week. I thought it was due to the "Night Light" being enabled too, so I turned it off, but it still does it. Even though my screen is obviously white now. Please can someone post the answer to this???



  • @chaoscreater Aha! Thank you. Yes, you're right. I thought it was my Night Light that I enable during the day to save my eyes. However, if I turn up the setting in the Lenovo Vantage App to full 6500, then renable my night light I'm all good :)



  • @romans9 Not sure why you're using Eye Care if you're already using F.Lux...? Also, Eye Care doesn't control the screen's max brightness, at least not for me. Lenovo Vantage isn't even a default system app. If you had to download Lenovo Vantage from Microsoft Store just to make your screen's brightness "normal", then I would say there's an underlying issue with your system. After a fresh install of Windows, the brightness should be as bright as what your system can do. It would look into reinstalling your Intel graphics drivers and any other graphics card drivers, reset them to default factory settings, etc etc.

    Turn off Night Light on Windows 10 if you're using it.



  • @chaoscreater said in FIX for problems with the Windows 10 May update (1903/18362):

    I tried everything, reg fixes, reinstalling Flux, disabling fast startup, resetting color profiles under Color Management, making sure night light is off, reinstalling Intel graphics drivers, etc.

    Turns out, it was the stupid Lenovo Vantage app on my laptop that was causing the issue. You guys might wanna verify there are no apps controlling the brightness/colour.

    0_1567738333419_2a7d8b26-10c6-4b51-8ded-82a796758956-image.png

    Well, looks like Lenovo and MS took my fix and posted it without giving me credit. I posted this on the 6th and Lenovo and MS posted the same fix on the 9th and 10th respectively. Oh well..

    Anyway, this is slightly unrelated but might still help others. An alternative solution is to download Autohotkey, then create a .ahk script file and add the following into it and just run the script:

    #+s::
    {
    Send !{End}
    ;Send #+S
    Run, explorer.exe ms-screenclip:
    ;msgbox, test

    ;if WinActive("ahk_class Windows.UI.Core.CoreWindow")
    ;msgbox, test

    sleep 4000
    Send !{End}

    }
    return



  • @chaoscreater said in FIX for problems with the Windows 10 May update (1903/18362):

    @chaoscreater said in FIX for problems with the Windows 10 May update (1903/18362):

    I tried everything, reg fixes, reinstalling Flux, disabling fast startup, resetting color profiles under Color Management, making sure night light is off, reinstalling Intel graphics drivers, etc.

    Turns out, it was the stupid Lenovo Vantage app on my laptop that was causing the issue. You guys might wanna verify there are no apps controlling the brightness/colour.

    0_1567738333419_2a7d8b26-10c6-4b51-8ded-82a796758956-image.png

    Well, looks like Lenovo and MS took my fix and posted it without giving me credit. I posted this on the 6th and Lenovo and MS posted the same fix on the 9th and 10th respectively. Oh well..

    Anyway, this is slightly unrelated but might still help others. An alternative solution is to download Autohotkey, then create a .ahk script file and add the following into it and just run the script:

    #+s::
    {
    Send !{End}
    ;Send #+S
    Run, explorer.exe ms-screenclip:
    ;msgbox, test

    ;if WinActive("ahk_class Windows.UI.Core.CoreWindow")
    ;msgbox, test

    sleep 4000
    Send !{End}

    }
    return

    Damn it, can't edit anymore. This is the updated script, use this instead. Thanks to @7empest from Autohotkey Discord for the help:

    #+s::
    wintitle := "Screen snipping ahk_class Windows.UI.Core.CoreWindow ahk_exe ShellExperienceHost.exe"
    Send !{End}
    Run, ms-screenclip:
    WinWaitActive, % wintitle
    While WinActive(winTitle)
    sleep 10
    ;MsgBox, test
    Send !{End}
    return



  • I'm trying to use f.lux with my new PC but the colours of the screen doesn't change, even with Windows Night Light turned off (i used that program in the past on a "Windows 8" who transitioned into W10 without major issues).

    0_1572165460716_driver settings.PNG


  • f.lux team

    @user_v1 if updating this driver doesn't help, you can also try downgrading it. see in this thread https://forum.justgetflux.com/topic/7043/fix-for-problems-with-the-windows-10-may-update-1903-18362/47



  • Just wanted to chime in, after the Windows 18362 update I was having the tinted screen issue when using flux with the next driver info:

    Advanced Micro Devices, Inc. 24.20.12028.4004: AMD Radeon(TM) Vega 8 Mobile Graphics (20181102)
    
    Generic PnP Monitor, 527 x 296mm, built 2017
    Chromaticities: 
      R=0.653320 0.334961
      G=0.323242 0.611328
      B=0.153320 0.061523
      W=0.313477 0.329102
      sRGB gamut: 93%, AdobeRGB gamut: 65%
    
    Generic PnP Monitor, 309 x 173mm, built 2016
    Chromaticities: 
      R=0.589844 0.349609
      G=0.330078 0.554688
      B=0.153320 0.119141
      W=0.313477 0.329102
      sRGB gamut: 63%, AdobeRGB gamut: 40%
    
    Monitor 1 on AMD Radeon(TM) Vega 8 Mobile Graphics: VCGT=0 gamma=1
    Monitor 2 on AMD Radeon(TM) Vega 8 Mobile Graphics: VCGT=0 gamma=1
    
    Windows Build: 18362.418
    

    I've removed the OEM provided (Huawei laptop) AMD Radeon drivers and installed the 19.9.2 version and it's working as expected now.

    I hope this info is helpful for anyone in a similar situation.



  • @herf The issue persists even if I install a downgraded version of Readon Graphics (with the 19.7.5 version).
    0_1572267221197_driver settings_28_october_2019.PNG



  • After making some researches in this thread, I found the following advices given by @AbhiMahant :

    1. Uninstalled the drives.
    2. Uninstalled display monitor from device manager.
    3. Restart graphics driver using custom resolution utility.
    4. Finally installed drivers again but with windows not amd.
    5. Although the version of my drivers is old now. But i will update my drivers and see what happens.

    I tried it on my laptop which has a AMD Rysen 5 2500 U graphics in order to see how it would work.
    On step "4." , I checked AMD website and install the driver that matches the setting of the processors (the processor can be found on Device Manager).
    And it seems that it solved the issue of flux "not changing the colours of the screen".
    I hope this will help others who have AMD Radeon Graphics.