F.lux preventing Windows 10 Sleep Mode



  • [Using version: 4.104]

    For the last little while I've noticed my computer still on in the morning, despite being set to go into Sleep mode after 1 hour. Additionally, I have the Power Button action set to enter Sleep mode immediately when pressed. However, pressing the Power Button does not enter Sleep mode, but simply turns the screens off. Wiggling the mouse turns the screens back on and there is obviously nothing happening to enter Sleep mode.

    Last night I decided to finally investigate why this keeps happening...

    I found a helpful article pointing to the windows command powercfg -requests. This command lists Power Requests being made to the system.

    After running this command I saw two entries for f.lux:

    SYSTEM:

    [PROCESS] \Device\HarddiskVolume3\Users\mikes\AppData\Local\FluxSoftware\Flux\flux.exe

    [DRIVER] Legacy Kernel Caller

    AWAYMODE:

    [PROCESS] \Device\HarddiskVolume3\Users\mikes\AppData\Local\FluxSoftware\Flux\flux.exe

    So I exitted f.lux and reran the command, which gave this output:

    SYSTEM:

    [DRIVER] Legacy Kernel Caller

    AWAYMODE:

    None.

    Satisfied, I pressed the power button and my computer immediately entered Sleep mode.

    I have a hunch this is somehow linked to the Phillips Hue integration. I had used it previously, but always found my office too dark at night. Then I noticed in a recent update that this had been fixed and I've been happily using f.lux with my Phillips Hue lights ever since. So, thanks for that! However, it looks like I may need to disable the integration once again if it continues to keep my computer from sleeping.

    I will restart f.lux and keep this post updated with any changes.


  • f.lux team

    Two things:

    1. We keep the device awake for Philips Hue, but there is an Options menu checkbox to turn this off, so it will sleep and stop updating your lights. The default is to stay awake.

    2. Also, if the device is on battery power and charge is below 66% we allow it to sleep, so this mostly applies to plugged-in devices.