Windows 10 always starts with pop-up screen of f.lux.



  • Hello! I do want to run f.lux every time that my laptop starts. However, the f.lux pop-up screen opens every time that f.lux starts with my laptop, and I have to close it every time I start the laptop.

    Is it possible to having f.lux start up without the pop-up when my laptop starts up?

    PS: My laptop runs Windows 10 and I have f.lux version 4.84.



  • It sounds to me like you put it into the Start Menu's Startup folder. Take it out of there. The f.lux installer puts an entry into the Registry to make it start with Windows. You don't have to do anything to make it start with Windows after installing it.



  • @twocables Thank you very much for your reply! Indeed, I did that when F.lux suddenly stopped starting up.

    I'll try that and report back to the forum!
    All the best,
    Daniel



  • @twocables Great! That seems to have fixed it! Thanks a bunch!



  • @hounddogrock said in Windows 10 always starts with pop-up screen of f.lux.:

    @twocables Great! That seems to have fixed it! Thanks a bunch!

    You're welcome. The reason why it fixes it is, having f.lux in the Startup folder is identical to just double-clicking a shortcut to f.lux after Windows starts. That's how the Startup folder works.

    When you install f.lux, it doesn't place a shortcut there because it creates an entry in the Registry for its startup because it uses a special command in the Registry called "NoShow" to keep the f.lux window from opening on Windows startup.

    So, if it stops starting with Windows, then somehow that Registry entry was deleted. Usually, the only way to get it back is by reinstalling f.lux. Putting it in the Startup folder will only run the shortcut. To see what I mean, create a shortcut to f.lux and just double-click it. That's the same thing, only you're running the shortcut manually. The Startup folder runs shortcuts for you automatically, but it's not anywhere near the same thing as the way f.lux gets itself to start up with Windows without its window opening (that is, with the "NoShow" command in the Registry).