"Disable when.." process detection issue when launching from 3rd party file managers

  • Ahoy there fellow Fluxians!,

    Enjoying Flux for a while now, it's far superior to windows' own blue light filter. The way that it disables the filter only on the one monitor that's showing something fullscreen while keeping others monitors nicely filtered is brilliant.

    Alas, one issue still irks me. Flux does not see processes launched from any non explorer process, file managers such as Total Commander for example.

    To reproduce this issue:

    1. Add, for example, a media player such as VLC player to the "disable when using..." list on Flux.
    2. Launch either VLC player directly or any media file associated with VLC player through windows explorer. Flux sees the running process and disables the filter.
    3. Launch the very same media file (or the VLC exe directly for that matter) through Total Commander (or double commander, midnight commander, etc). Flux is blind to the process and does not disable the filter automatically as it should.

    It's the same with any other non explorer launch.

    There must be a good reason for this behavior, security related perhaps, but if there's any possible workaround, I'm sure many users who use 3rd party file managers would have a more consistent experience.

    Just my two cents.

  • Thought I'd bump this since it's been well over two weeks, 37 views and not a single response. I'll keep watching the tumbleweed blow by.

Log in to reply