Grayscale mode in the new Beta is actually cool. I have an unreleated bug to report too.



  • The new Beta version of f.lux was released today, and one of its new features is called Grayscale.

    https://justgetflux.com/news/pages/v4/readme/

    I didn't expect to ever care about having a grayscale mode and I honestly expected that I'd never use it if it were added to f.lux. However, I have to admit that it really does work to help keep my focus on text while reading and/or thinking, exactly as they said. I have always had the ability to easily switch to 100% black & white before this feature was added (NVIDIA Control Panel), but I never did because I didn't know of any good reasons to do so. Now I kinda wish I had understood.

    I'm finding myself enjoying it when I'm trying to read or type something up.

    The bug is that the cursor becomes white whenever it changes to something other than the arrow if I'm using any warm temperature. I don't mean it turns blue, but I mean plain white. So, on a white background, it becomes invisible.

    Edit: I can give more detail. With Grascale mode enabled, anything under 5400K reveals this bug, as well as anything 7850K. With Grayscale mode disabled, it only happens at 1850K and warmer.



  • Edit: anything under 5450K, not 5400K. I also meant to say "above 7850K", not just "anything 7850K". Sorry. I am past the 10-minute limit so I can't edit.

    This has made f.lux almost completely unusable for me. So, I am going back to the most recent stable release. Please let me know when you've uploaded a new beta.



  • Why did you release this as a final version with this bug in it?



  • Did you try the "Software Mouse cursor when needed" setting? It might help.

    I am on Windows 10 and the grayscale mode doesn't work at all for me. Fortunately, Windows 10 has its own Grayscale mode ("Color Filters") and they work perfectly with Flux.

    0_1541628630404_1d935acb-84ac-44f1-a9a9-62d650c13b6e-image.png



  • Oh, yeah, I forgot to mention that I tried f.lux's software mouse cursor setting. I tried everything in the f.lux options. I'm using f.lux 4.78 and I don't plan to get a newer version until this is fixed!

    Note: for me, this has nothing to do with this new Grayscale mode. I experienced this bug without even using that mode.