Can't pair with Philips Hue



  • I recently moved and had to setup my Google Home and Philips Hue again. Before, f.lux and my Hue lights were working together perfectly. Now, f.lux seems not to be able to find my Hue again. I tried it with my PC connected by WiFi and per LAN, but it didn't give me the "beep" for synchronising in either case. I even reinstalled f.lux, but still the same problem. Any idea?


  • f.lux team

    Is there any info at https://www.meethue.com/api/nupnp ? You may not want to post it exactly.

    Looks like we are not cleaning up the pairing information on uninstall/reinstall, think we should do that.

    If you are good with regedit, you can look in HKCU/Software/f.lux Software LLC/hue - it should be safe to delete that whole key and it will pair again.



  • NUPnP gives me three IDs and three internal IP adresses, but I have one bridge and three bulbs. This really confuses me!

    Yesterday, I managed to pair Hue with f.lux by chance (I guess?) just pressing the button on the bridge randomly.
    Now I tried your suggestion anyway. Yet the problem with the missing beep and the pairing only working randomly persists. Once out of five tries though, a minute after trying to pair again, f.lux started beeping and wouldn't stop, even though I had pressed the button on the bridge already.
    I suspect it has something to do with the polling frequency or a delay somewhere, because before I moved, my lamps would update almost perfectly in synch with my screen and now it takes them at least a minute to react to a change from f.lux. I do not have this problem with the Hue app, Google Home or my dimmer, the lights respond instantaneously to them.

    Another issue you might want to look into is f.lux freezing upon unchecking the box for Philips Hue under the connected lights tab.


  • f.lux team

    If you only have one bridge, it should only report one bridge. Hmm, I wonder if we're stuck waiting for one of the "missing" bridges to respond.

    If you hold down "Ctrl" while launching f.lux it will skip the meethue.com check and use UPnP on the LAN instead. (I should put a pref in for that if it's useful - it was just there for my testing.)



  • Launching f.lux with Ctrl did the trick, all lag was eliminated. Thank you!
    It still doesn't beep when trying to pair, but for me, this is a non-issue, since now, the setup works just as I wanted.



  • Okay, I've tested this for a week now. Everytime I reboot my computer, f.lux reverts to checking meethue.com instead of using UPnP. Is there a way I can enable the UPnP check on startup so I don't have to delete the process and start f.lux again with Ctrl held down?

    Btw in case this issue is new: When I exist f.lux using the exit option in the menu, the visible programm terminates, but the the process stays alive somehow.


  • f.lux team

    I think I put up a test build with a registry key for this:
    https://justgetflux.com/flux-setup4-48.exe

    It adds two new prefs, so to turn off meethue, you would go to regedit and add:

    HKCU\Software\Michael Herf\Preferences\meethue = REG_DWORD 0x1