Where are settings stored? ("disabled when using")



  • So for some games, like Fortnite, the game isn't listed under "disable when using Fortnite". Is there a location where the settings file which contains a list of apps where Flux should be disabled, and if so, where is it stored?

    Better yet, can you add a process list in which we can select the application rather than it appearing under the Disable menu


  • f.lux team

    It is in the registry.
    HKCU/Software/Michael Herf/flux/Preferences/disabled



  • @herf Thank you very much, do you have any plans to add a UI to allow us to manually select which programs we want to disable?



  • I added "Fortnite" to the disabled list, but it didn't work. I'm not sure if its because of the game itself (it was fullscreened) and how their window is as its kind of buggy.


  • f.lux team

    It is supposed to show the last two apps, so if you can alt-Tab from the game, it should be in the list.

    There may be cases where f.lux cannot determine the name of the game also, but I thought we fixed most of those.



  • @herf I'm sorry for the late reply, but yes, unfortunately this still happens. As for alt-tabbing, believe me, I have tried, thats why I was asking for the preferences file so I can manually add it, but it didn't work.

    Like I said before, Fortnite is kind of buggy when alt-tabbing, etc. I have to open the Flux UI so I can alt tab back to Flux DIRECTLY, and even then Fortnite doesn't appear. I tried not opening the Flux UI, and alt tabbing from the game, but it doesn't take me to my desktop (hence buggy, and hence opening the Flux UI). After alt-tabbing, I press the windows key to gain access to my task bar, right click flux, disable, and once again Fortnite is missing BUT "Search and Cortana" shows.

    Like I said, Fortnite is very buggy, but the same thing happens with League of Legends, it doesn't appear. Is it possibly because the apps are being launched in 32-bit mode or as admin?



  • Hello,

    I would like a solution for this issue too.
    Some windows are not detected (Blade and Soul game for example).

    I have tried the following with a game that is detected by f.lux to see if I could understand the behaviour so I could manually add games:

    1. Open League of Legends
    2. Open f.lux
    3. Disable when using League of Legends
      => It's working as intended, f.lux gets disabled when I have League of Legends in foreground
    4. HKCU/Software/Michael Herf/flux/Preferences/disabled value is now "League of Legends"
    5. Remove "Disable when using League of Legends" through f.lux
      => Still working as intended, now League of Legends is ignored by f.lux
    6. Refresh HKCU/Software/Michael Herf/flux/Preferences/
    7. HKCU/Software/Michael Herf/flux/Preferences/disabled value is now empty
      => Up untill now, everything is working as expected
    8. Add "League of Legends" to HKCU/Software/Michael Herf/flux/Preferences/disabled
    9. Put League of Legends in foreground
      => It doesn't work

    There is something done besides this HKCU/Software/Michael Herf/flux/Preferences/disabled key so we can't simply add programs in there and expect it to work :(

    Is there any way to add a non detected program to f.lux ?

    Thank you!

    Regards,