"Disable until sunrise" Turning back on at midnight?



  • I've had this issue for a couple of months now, but I'm finally posting here to see if anyone else has it, and if there's a fix....
    I quite often right click the icon in the system tray and click "disable until sunrise" however when the clock turns midnight flux turns back on and I have to re-disable it.

    Does this happen to anyone else? Have you you found a fix?


  • f.lux team

    Hi - which version are you using?



  • Hi there! It's version 4.55


  • f.lux team

    I think we made some changes there since 4.55 - can you try the current build and see if it helps? Just download and install again at https://justgetflux.com/



  • Will do! I'll let you know if it fixes it, thanks for taking the time to answer my issue so promptly!



  • Just to let you know updating sorted my problem right out. However... It has left me with a far more frustrating problem.
    Now somewhat randomly when I disable the f.lux (so "disable until sunrise") and then reduce the brightness of my screen using Alt+PgDn my screen return to full brightness and I can't work out why.

    If I then press Alt+PgDn again it dims to the previous level , rather than one less than normal. So i go from 82% brightness (the setting of my display), down to say 25% using Alt+PgDn, it then jumps back up to 82% and if I press Alt+PgDn it doesn't go to 76% (the setting one below 82%) but rather straight to 25%.

    The interval of the brightness jump seems to be random and it only ever increased brightness not decreases. I've completely uninstalled and re installed f.lux to try and fix it, no help. Honestly I'd rather go back to v4.55 as that issue was far less annoying!