Flickering laptop screen after f.lux installation.

  • Hallo!
    Problem as the topic's title says, my laptop's screen
    (LENOVO IdeaPad 310 Laptop 15.6" i7-7500U 8 GB 1 TB nVidia Geforce 920MX Windows 10)
    is flickering after installed f.lux. The incident is happening at random, with random duration and random intensity.
    Things I tried in order to solve it, but it still persists..:
    1.Uninstalled f.lux
    2.Updated Intel Graphics driver (its the integrated one. NVidia driver was stating that its already up to date)

    1. Reinstalled f.lux/uninstalled again later
    2. Restored system to a point before installation of f.lux.
    3. Calibrated monitor
    4. Installed f.lux again to try the Expand color option
      I've already checked the FAQ section and read the Flickering Screen post, but in this laptop there is no OSD menu to modify.
      So, none of these worked. I still have f.lux on my laptop and Id like to use it if its possible.
      I'm sad because I installed it to help me with my eye strain while using my laptop and in the end it made it even harder to work ...
      I hope for some support here..
      Thanks for reading.

  • f.lux team

    Lenovo had software that would conflict with f.lux last year - do check that from Lenovo settings.

    Also, if you happen to have calibrated with a Spyder, you should disable the profile loader and use f.lux instead for that.

  • Thank you for your fast response. That was awesome!

    So, this laptop does not have Lenovo settings installed and I calibrated my screen from Windows 10 default calibration system. From what it looks, my calibration got canceled from f.lux. I think this is normal (f.lux has its own colors or something like this? I think I read that somewhere).
    I made a NVidia VGA update yesterday and was testing since then if the problem got fixed. Everything was smooth till around half hour ago when monitor started flickering again.
    A point (I don't know if this matters.) it happened around 9pm, around 9 hours before my settled wake up time when the color bar was around 3400K. It seemed like the change of lighting triggered it. Not sure.

    Waiting for your feedback.

  • Ok. Forget about the 9pm thing. The incident is not time related. Its totally random as far as I can tell and its still unsolved.
    I updated Intel VGA driver too, but still no result...

  • f.lux team

  • Downloaded and installed beta version.
    Rebooted, but screen is still flickering.

  • What is going on? F.lux changed something permanently that creates this flickering, because flickering is present even when I uninstall f.lux. Right?
    How am I supposed to fix it? I'm hitting dead end here.
    I tried more things, but the screen still flickers. Laptop became unusable and the frustration is building up..

    I "downdated" Intel Graphics driver.
    "Reupdated" Intel Graphics.
    Changed Intel Graphics Settings and made everything to use driver's settings.
    Updated NVidia GameReady driver and PhysX.
    Screen still flickers.

    These are my drivers:
    Generic PnP Monitor (1920x1080@60Hz)
    Intel HD Graphics 620 (Lenovo)
    2047MB NVIDIA GeForce 920M (Lenovo)
    ForceWare version: 388.59
    SLI Disabled

    and some operating system information:
    Windows 10 Pro 64-bit
    Computer type: Tablet

    What shall I do so my machine will perform like it used to?

  • Totally uninstalled f.lux, Intel Graphics Drivers, NVidia Graphics Drivers and parts like Geforce Experience etc and the screen is still flickering.
    I am considering a format, but I am having thoughts that even this might not work.
    Could the application have messed up the monitor?
    I'm not a pc expert and I am in a panic state after trying to solve this for around 2 weeks with no avail.

  • f.lux team

    f.lux does not have any permanent effects once it's uninstalled.

    There is one thing about updating your Intel driver. Intel drivers frequently add a power-saving feature called "DPST" that causes a visible effect. I always turn it off through the "HD Graphics control panel". If you have that control panel, look in "power" and "battery" and see if you can turn off "Display Power Saving Technology".

    If that's not it and you think it's related to f.lux, please send a video to support at justgetflux.com

Log in to reply

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.