Disable for Fullscreen Apps nonfunctional



  • f.lux isn't properly disabling for full screen apps. Full screen youtube is still affected by flux. Interestingly, f.lux does seem to detect some sort of change when youtube is in full screen as it stops affecting my mouse cursor. Disabling for Google Chrome, on the other hand, does work as expected.

    I thought this might be unique to youtube, so I tried it out with FTL Advanced Edition (launched through steam), with the same results (cursor was not affected, screen was).

    OS: Windows 10.0.16299 build 16299.
    Graphics:

    • DisplayLink USB Device version 8.3.2008.0 (2nd monitor)
    • Intel(R) HD Graphics 530 version 21.20.16.4664
    • NVIDIA GeForce GTX 960M version 23.21.13.8859

    All applications tested so far use Intel(R) HD Graphics. In the case of FTL, I manually set it due to (unrelated) problems with the NVIDIA driver. All applications were tested on my primary monitor, not through DisplayLink. I also temporarily disconnected my secondary monitor during the tests to ensure it did not affect the results (though the dock itself remained connected).

    On a related note, the "disable while using google chrome" feature adjusts both monitors when chrome is active or inactive - regardless of whether or not it is displayed on said monitor. This is rather irritating, as a work-around for this bug I thought up did not work - use one browser to view youtube in full-screen, and another for taking notes on my primary monitor.

    I can provide more system details or do more tests upon request.


  • f.lux team

    Yes the DisplayLink support is emulating the effect in a way that might not work for fullscreen apps, and when we do that we cannot do monitor-specific settings.

    https://forum.justgetflux.com/topic/3629/displaylink has some registry settings that might help f.lux work better with DisplayLink.



  • Thank you! That registry setting has solved both of my problems.

    Now if only I could manually change monitor settings independently... Eg. secondary in "Movie Mode", primary in normal f.lux.

    I appreciate the work you've put into a program which is free to use, along with the helpful and prompt support :)


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.