f.lux disables, then enables after startup



  • Hello,
    Recently, there is a weird occurrence that happens upon logging in. f.lux will initialize and properly set the monitor's color profile ("Reduce Eyestrain") upon startup as it should, but after a few seconds, the color mode is disabled and the regular color is shown. This happens until I hover the cursor over the f.lux icon in the notification area of the taskbar, after which the proper color profile is restored. I am using Windows 10 Pro 1709. I have tried uninstalling and reinstalling to fix, but no luck. Further, not sure if f.lux is the cause, but I am unable to access the "night light" feature of Windows 10. I have used the registry fixes such as "Windows Registry Editor Version 5.00
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\CloudStore\Store\Cache\DefaultAccount$$windows.data.bluelightreduction.bluelightreductionstate]
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\CloudStore\Store\Cache\DefaultAccount$$windows.data.bluelightreduction.bluelightreductionstate\Current]
    "Data"=hex:02,00,00,00,54,83,08,4a,03,ba,d2,01,00,00,00,00,43,42,01,00,10,00,
    d0,0a,02,c6,14,b8,8e,9d,d0,b4,c0,ae,e9,01,00"
    but while this does help ungrey out the options, Windows does not change the color even when I enable the night light feature. Also, when I log out/restart/restart Windows Explorer, the options are greyed out again and the registry keys must be reapplied. I know this isn't specifically f.lux, but both do the same thing and may be causing issues with one another.
    Is there a fix for either/both?
    Thanks!
    Edit: I have also updated/reinstalled the graphics drivers, but this has done nothing either.



  • As an update (less shameful "BUMP!"), this only occurs for f.lux v4. Going back to v3 works just fine. For that matter, this issue didn't show up until one of the later updates to v4. Any thoughts?


  • f.lux team

    Post your driver info? Via f.lux options (button at the bottom).



  • The driver info dialog box displays:
    "NVIDIA 23.21.13.8871: NVIDIA GeForce GTX 970 (20171215)"



  • Hello!

    I am also experiencing this problem: flux appears to start correctly when Windows starts up but then like @deckinghalls said, after a few seconds the colours revert to default as if it has been disabled. I can correct this simply by clicking the tray icon and then all seems well until I next startup Windows.

    In my case this issue began after I updated my video drivers, which are:

    Advanced Micro Devices, Inc. 23.20.15007.1005: Radeon(TM) RX 460 Graphics (20171217)

    Otherwise everything appears fine, great piece of software!



  • Now also happening on a Dell Studio 1535. Driver info:

    "Intel Corporation 8.15.10.2697: Mobile Intel(R) 965 Express Chipset Family (Microsoft Corporation - WDDM 1.1) (20121001)
    Intel Corporation 8.15.10.2697: Mobile Intel(R) 965 Express Chipset Family (Microsoft Corporation - WDDM 1.1) (20121001)"

    (It shows twice)



  • Hi,

    I'm having the similar issues with randomly reverting to default colors. It starts back up again after the tray icon is clicked, just as sharmu1 has described. Going to revert back to v3 to see if that works for me as well.

    Info:
    NVIDIA 22.21.13.8477: NVIDIA GeForce GTX 1050 (20170629)
    Intel Corporation 22.20.16.4836: Intel(R) HD Graphics 630 (20171017).



  • Me too. I get it set up with the colors the way I want them. I close the app, the standard colors come back. I hover over a link on a webpage, the flux colors come back. I move the mouse away, the standard colors come back. I'm going to downgrade to v3 until this gets fixed.

    Intel Corporation 21.20.16.4550: Intel(R) HD Graphics 520 (20161111)
    DisplayLink 8.2.1952.0: DisplayLink USB Device (20170522)
    DisplayLink 8.2.1952.0: DisplayLink USB Device (20170522)

    2 monitors

    Generic PnP Monitor
    Dimensions: 607 x 345
    Year: 2016
    Chroma:
    R=0.633789 0.340820
    G=0.311523 0.635742
    B=0.158203 0.061523
    W=0.312500 0.329102
    sRGB gamut: 91%, AdobeRGB gamut: 64%

    Generic PnP Monitor
    Dimensions: 308 x 173
    Year: 2014
    Chroma:
    R=0.573242 0.334961
    G=0.323242 0.579102
    B=0.158203 0.142578
    W=0.313477 0.329102
    sRGB gamut: 78%, AdobeRGB gamut: 50%