Computer won't sleep with Hue lighting enabled



  • I understand that the program can't run the lights if the computer is asleep, but is there any way to let my computer sleep even when hue lighting is enabled? So far I've just stopped running flux because I have to close it every time I want to put my computer to sleep.


  • f.lux team

    What do you want your Hue lights to do after your laptop is off?

    I think we might be able to change this "stay awake" thing so it only stays on if the computer is plugged in, which would be better.



  • @herf Thank you for getting back to me. It is not a laptop, it is a desktop. I just want to put the computer to sleep without making changes to the lighting. Flux keeps the computer from going to sleep however, presumably so it can continue to control the lighting as the day progresses. As soon as I disable Philips hue lighting control (or exit flux completely) I am able to put my computer to sleep.



  • Hey, I know this topic is a bit old, however I ran into the same issue today and I would like to share this fix I found for anyone who follows.
    To block f.lux from keeping the PC awake, but still allow it to control your Hue lights when the PC is on, you can open a command prompt window in administrator mode by opening the search bar (Windows 10), searching for "command" and right clicking the command prompt and selecting "Run as administrator". Next, in the command window, type these two commands (confirm each by pressing enter):
    powercfg /requestsoverride PROCESS flux.exe SYSTEM
    powercfg /requestsoverride PROCESS flux.exe AWAYMODE

    After that, f.lux should no longer prevent your PC from entering sleep mode.

    Hope this helps!



  • @Qub1995 Great tip, I'll definitely be making use of it. Thanks!



  • @Qub1995 Wow, thanks for this! I had stopped using Flux because of this, but I'm back on the boat now thanks to this tip. Cheers!