"Disable until sunrise" disables until midnight only.



  • My problem is simple. For example, at 22:45, I click on "disable until sunrise" so I can work on my color-sensitive work whole night. At exactly 00:00, it goes back to yellow. My location is correctly set to the city I live, double checked, and the local time is set correctly. "Classic f.lux" is selected.

    I took a sucky video: https://www.youtube.com/watch?v=C05X8e9al7k

    It has about 15 seconds of dead wait in the middle until the clock turns 00:00.

    I didn't mess with my computer time to show you the problem. I actually waited until 23:59, which is about 10 minutes in real life for me before I posted this thread here.


  • f.lux team

    will check it out



  • I am having this same problem Harzem, thank you for highlighting it to the Flux team! At midnight it resets and you have to click it again.



  • I have a similar issue with the Disable Until Sunrise feature.

    It disables until the start of the sunrise cycle, whereas it should really disable until the end. I.e., if f.lux is disabled it will change to yellow when sunrise starts, and then fade back to white as the sun rises.