Colour changed

  • Hi, I have been using f.lux on Win 10 for something like a year now and I had it set to just a mild red effect in the evening and at night which I like, and is similar to what I use on my phone using a different app.

    In the last few days I guess it auto-updated, because now I'm getting a really strong yellowish colour instead of the red I am used to. I have played with the settings and I just cannot get it to give me what I had before.

    There are settings claiming I can set the "color" but I can't find a way of having red instead of this weird yellow which I find really uncomfortable.

    I just cannot use it like this. Is there a way to revert to the old version or to make the new one do red?


  • f.lux team

    The major change in color is

    [x] Options > Use Display Data for better color accuracy

    If you turn that off the colors should match v3 pretty well.

  • Thanks for the reply. That has made it less weird but it is still a yellow hue, no matter what settings I seem to try. All the "color" settings are really "warmth" settings, I cannot set the color at all.

    I can't remember what settings I used before, because f.lux has "just worked" for so long without me touching it until now.

  • Hi, I'm having the same problem only mine looks purple instead of red like I'm used to. The default setting I'm seeing after sunset is Candle but it just doesn't look right. I tried bumping it down to Ember and it just looks more purple. Turning it up to Dim Incandescent is too bright to be useful for blue light reduction at night, though it gets rid of the purple glare. The slider bar just makes it brighter or dimmer, unless I'm using it wrong. The Use Display data option isn't doing anything for me either.

    I'm also having issues with the mouse cursor. It's either a bright white that turns to blue when you move it over a text box (not good for bedtime) or behaving really strangely when I check the box next to "Software mouse cursor when needed". That setting does effectively dim the cursor to the correct level, but when I move it over a text box it completely disappears instead of turning black so I can see it.

    I kind of just want it to go back to normal like the OP but I can't figure it out either. Please help us.

  • f.lux team

    @Rykah84 Can you check this post about NVIDIA to see if it applies?

    Should never be purple unless it's a driver bug.

  • No, it's not like that but thanks for trying. It's more of a faint purple glare if I'm not sitting directly in front of the screen. Even then I get a purple edge near the top of the screen unless I tilt it down to the point of being uncomfortable. I'm almost wondering if it's a backlight setting now. Just to clarify, my laptop screen and backlight were working perfectly day and night with the old version of flux yesterday. It worked fine today after the forced update, and then tonight when the bedtime settings kicked in it just started looking weird. It's hard to describe.

    I was able to fix the mouse cursor just now though. I clicked on something to expand the colors and it rebooted my computer, though I guess a simple reboot probably would have done the same thing. Sorry I didn't try that first. I would still like to get rid of this purple haze situation though.

  • f.lux team

    Did you also try the option to not use the monitor color settings?

    The new version has more extreme colors at night, but otherwise it is very similar, apart from that setting.

    If turning that off helps please let me know.

  • Is that the "Use display data for better color accuracy" setting? It looks exactly the same to me with it off or on. It's currently off.

  • f.lux team

    It may be that there is blue-colored backlight bleed at the edges of your monitor.

    You could try the "eyestrain" or "color fidelity" presets (or even "classic f.lux") - because it sounds like our most extreme setting doesn't look very good on your display.

  • Hi,

    I have updated my nVidia drivers just to make sure, and that didn't seem to help.

    With the box "Use display data for better colour accuracy" ticked, I get a yellow hue that I don't like.

    With it unticked, I think I'm getting no colour or effect at all. F.lux doesn't seem to work without it ticked.

    Is this the expected behaviour? What colour am I meant to be seeing, and is there a way to get red?


  • f.lux team

    There is a very small change to the color transfer function also - we could possibly make a registry option to use the old one instead. So far, we are getting a lot closer to "blackbody" (planckian locus) on every panel we have tested.

    But what you're saying is important - if we have to be "wrong" (and on Windows calibrations often aren't so good) almost everyone prefers "below" the blackbody curve (more red) rather than "above" it (green/yellow, which looks awful).

    Which display (panel model if you can find it) are you using? Does it have any built-in calibration settings?

  • @herf - Why change it? It was perfect! I'm not going to use it like this. This is a mess.

  • f.lux team

    @saritasarita what are you seeing?

    Again, there should not be a visible change for most people if you're using the same kelvin value as before. The change is mostly designed to work better with wide-gamut displays.

    If you're unhappy with the setting, we also changed the preset before bed, and you can move the slider or choose a different preset.

  • Having reverted back to v3, I am not 100% sure any more whether I am seeing a difference between v3 and v4 in "classic" mode.

    Of course in default v4 mode, there is an obvious different during night time, when v4 has a much more intense setting, and I often work very late so I will have noticed that straight away.

    With v4 in classic mode, avoiding the new night time settings, I'm not so sure I'm seeing any difference, although I can't seem to get comfortable with it.

    I will try it a few more days and see if I get used to it.

  • hi
    use display data for better color accuracy introduces a cloying slight greenish tinge on my w520
    (turning it off pushes red even at 5000k - in between would be perfect)
    to be fair the display data and default profile are notoriously bad for the 95% sRGB panel on my computer

    i am using a profile from the same panel type as mine
    (the optional calibrator for this model is bullocks - and this panel only calibrates well with some equipment)
    the default profile has serious red issues (as does this monitor with no profile at all - worse though - think aRGB reds on a sRGB panel)

    i seem to recall being able to tolerate much warmer values with the old transfer function but with v4 i cant stand anything below 4200k

    please allow a reg value for old behavior if possible.


  • f.lux team

    Is it a wide-gamut panel (the FHD model back then was) or are you saying it is 95% sRGB? In the newest version, you can post the "driver info" from the options menu and it will show what the panel is reporting. (Download again from the website.)

    And does f.lux look better without the profile installed? It may just be a bad profile!

  • panel is 95% sRGB (considered wide gamut sorta - reds exceed sRGB colorspace)
    stock profile is trash (i remember reading the display data was also questionable on this panel)

    monitor is useless without a decent icc profile. i am using a user created one from the same model but not my panel. this is a hard to profile tn panel (the lcd backlight temperture being a big factor)

    does unchecking use display data cause the program to ignore the monitor profile?

  • NVIDIA NVIDIA Quadro 1000M (20170217)

    ThinkPad Display 1920x1080
    Dimensions: 344 x 193
    Year: 2009
    R=0.675781 0.314453
    G=0.214844 0.665039
    B=0.140625 0.069336
    W=0.313477 0.329102
    sRGB gamut: 102%, AdobeRGB gamut: 91%

    the profile i am currently using is supposed to be 6500k but is possibly slightly warmer
    (the garbage thinkpad supplied profile is about 7200k - 8200k it is based on native white)

  • f.lux team

    I know this exact panel - have a T510 in the closet!!id=Thinkpad T510 FHD/6500K-ThinkpadT510FHD

    And I can see what you mean.

    The old version of f.lux will make "more saturated" colors here (kind of like the panel does for everything), because it is assuming your display is sRGB, which it isn't. The new version is trying to pull it back to "real" colors. But maybe the chromaticities have moved a little bit since 2009, so that might be where the yellowish effect is coming from. I will try to think of a better solution for this - we should do a little better. We have some other options in the code that might work too.

  • thanks for the reply
    so apparently the 95% refers to 95% ntsc

    regardless my question stands
    "does unchecking use display data cause the program to ignore the monitor profile?"

    i believe use display data may be over compensating the green channel
    (i may go back and whip up an avg of the 2 sets of LUT values and test them but it looks like my issue has to do with the green channel alone)

    i am concerned about a slight green bias when the box is checked.
    fyi this machine has seen very little on time and the panel almost no uv exposure

    lenovo stockpiled this monitor and was still using it in the w530

    the version i used to like on this machine was the old beta from 2012 with the nvidia setting (was icc aware)
    fyi i was looking at the LUT tables and i wonder if the lines could be smoothed (get rid of value duplication) in v4 (the steps seem a bit lazy)

  • @herf
    is your t510 display profiled?
    could you upload or send me the icc file so we can cross compare

    i will upload some text files of LUT values + the profile i am using that you can test on your t510 and a link to necessary tools.

  • @herf
    im not sure what changed but it seems that the green tinge issue i was having is basically resolved or at least acceptable. I am now using checked "use display data for better accuracy" and am back to using 3400k

    currently running 4.66 (beta checked)


Log in to reply

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.