F.lux wasn't working at all. It was stuck at 800K.



  • (Edit: Oh wow, this is a huge post. I apologize for that, but this requires a lot of explaining)

    Hi Michael and Lorna. I want to get a conversation started with you on this just in case you can maybe help me figure out what happened. I'm making this public thread instead of starting a private chat just in case others are having the same issue.

    Before I describe it, just know that this has never happened before. This is with version 4.51, and it may be unique to 4.51.

    I woke up in the middle of the night last night to some mild thunder and decided to turn my computer on to check the radar (I had to know if I could go back to sleep without being interrupted by any loud cracks of thunder). The way that I always do this is, I turn my computer on but I leave my monitor off. When I know my computer is done starting up, I blindly launch f.lux (I have it set up so that it's easy). Due to my settings, it always goes to 800K when I launch f.lux, which I prefer. I have it set to the Very Fast transition as well so that I never have to wait long. That way, I can do something like this and still be able to go back to sleep.

    Anyway, so after I blindly launched f.lux, I turned my monitor on and checked the radar. I ended up needing more color accuracy, which I expected, so as usual, I simply pressed Alt+Shift+Page Up a little bit to increase the color temperature little until I could see the greens, yellows and reds a bit better on the radar. Only, f.lux stayed at 800K this time. It was so strange and unexpected that I thought maybe I was doing it wrong due to having just woke up. I kept at it and verified that f.lux was indeed not allowing me to change the color temperature at all. Even moving the slider resulted in staying at 800K - but the color would change while holding the slider down. Once I let go of it though, the color would immediately fade back to 800K. It would also display "800K" next to the slider.

    When I used Alt+Shift+Page Up, the notification came up telling me I was increasing the color temperature, but the color temperature remained at 800K no matter what I did.

    So, I unchecked/disabled the setting "Use display data for better color accuracy" because I figured perhaps f.lux wasn't working due to starting the computer up and then launching f.lux before turning my monitor on. Sure enough, that made f.lux work, but only marginally better. I don't know how to explain what I mean by "marginally better", but I can tell you that I was able to change the color temperature but it wasn't working smoothly or reliably. The notification was barely even telling me about the changes I was making and the changes I was making weren't smooth or anything. It was just messed up.

    I'm not sure if this following thing is related, but I also hadn't put my Location back to my actual location since the last time I used f.lux. It was set to a place where at ~3am for me, it was in Daytime mode while also in Bedtime mode because I had it set to 11am. I thought maybe that was the culprit somehow, but it wasn't. I then disabled Bedtime mode by changing my wake time and that seemed to work - but I was so groggy that I really don't remember much at this point (all I wanted to do was go back to sleep). I just know that I had a very difficult time getting f.lux to get out of 800K.

    I'll do some testing when I have time to see if I can duplicate this issue, but I felt it was better to get this conversation started first. Right now, f.lux is working perfectly for me. So, I don't know.

    Thank you.


  • f.lux team

    4.52 has some special handling of "bedtime" mode to prevent changes with "classic f.lux" mode - but only the remote desktop code changed in 4.51, which should not do this.
    Will do some debugging on the beta and see what I can find.



  • @herf said in F.lux wasn't working at all. It was stuck at 800K.:

    4.52 has some special handling of "bedtime" mode to prevent changes with "classic f.lux" mode - but only the remote desktop code changed in 4.51, which should not do this.
    Will do some debugging on the beta and see what I can find.

    Could it be that somehow it was acting as though I had classic f.lux mode enabled?


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.