F.lux not supported in macOS high sierra

  • @herf
    Pro. I found this bug happened after display sleep every time and nightshift got this bug too. Must be a bug of high sierra.

  • interesting - old Intel drivers on Windows also "forget" their settings on sleep. We could potentially work around it, but I would guess they will fix it within weeks.

  • Apple now requests a system report, and since I don't have a system with the bug, I cannot easily report this. If anyone has an account, please send one to https://bugreport.apple.com/

    I would expect it's mostly the Intel HD 4000 that we're hearing about in this thread, but there may be other GPUs affected.

  • Same problem here: f.lux stopped working properly since I did my update to High Sierra.
    My configuration is a bit different: MacBook Pro (Retina, 15-inch, Mid 2014) with Intel Iris Pro.

  • I have the same problem. Both flux and Nigh Shift cease working completely at times. I also get the sense that this happens after waking the computer up from sleep. Seems to have started with High Sierra.

    MacBook Pro (Retina, 15-inch, Mid 2015) (11,5)
    Graphics: Intel Iris Pro 1536 MB
    macOS 10.13

  • I am having the same issue.
    13" MacBook Pro 2017


  • Same for me (macOSX, High SIerra, 10.13.1 (17B48)), here is log from Console:


  • I removed F.lux on my MacMini running High Sierra (10.13.1) because I (suspected) it was preventing the screen saver from coming on or the screen to power off after 10 minutes.
    After playing with those System Preference settings, removing those preferences and setting the options up again, I realized the problem actually started when I had start (and re-add F.lux to run at login.) On the High Sierra install, it disabled F.lux?

    I tried quiting F.lux to see if that would work, the only thing that brough back the screen saver to turn on in 5 minutes and the screen to power off after 10 minutes was to uninstall F.lux.

    I have not tried re-installing F.lux to see if it will work correctly now but I miss it. Apple's NIght Shift seems to do virtually nothing.

  • For anyone else with this problem - I found a fix.

    It appears High Sierra has some changes to the start-up items.

    Basically delete "backgrounditems.btm" file under this path, and then restart your mac.

    /Users/$your_user/Library/Application Support/com.apple.backgroundtaskmanagementagent/backgrounditems.btm

    Fix from https://community.spotify.com/t5/Desktop-Mac/Spotify-crashing-at-startup-on-MacOS-High-Sierra/td-p/2260942

  • @bobzippymail Worked like a charm, thank you!!

  • @bobzippymail This fixes the problem! You deserve some beer! :-) Thank you!

    @bobzippymail said in F.lux not supported in macOS high sierra:

    For anyone else with this problem - I found a fix.

    It appears High Sierra has some changes to the start-up items.

    Basically delete "backgrounditems.btm" file under this path, and then restart your mac.

    /Users/$your_user/Library/Application Support/com.apple.backgroundtaskmanagementagent/backgrounditems.btm

    Fix from https://community.spotify.com/t5/Desktop-Mac/Spotify-crashing-at-startup-on-MacOS-High-Sierra/td-p/2260942

  • @bobzippymail Didn't work for me unfortunately, both Flux and Night Shift have stopped giving any kind of response...

    Started a question on Ask Different about it: https://apple.stackexchange.com/q/309683/201104

  • This post is deleted!

  • There does seem to be something wrong with display profiles and colorsync on High Sierra 10.3.2. I'm unable to switch profiles manually, and flux doesn't seem to be able to either.

    From Console:
    Flux (Colorsync)
    Subsystem: com.apple.colorsync Category: org.herf.Flux
    ColorSync: ColorSyncProfileCreateWithDisplayID failed to get profile for kColorSyncDisplayDeviceClass

    When I try to create a new profile with Apple's Display Calibrator Assistant:
    An error occurred.
    The new calibrated display profile could not be created or set to be the current profile for this display.

    I've checked read/write permissions in all the appropriate places, tried the backgrounditems trick, removed various colorsync and display preferences related plists, reset pram and all.

    I think it may be up to Apple to fix this one.

  • If you are having this problem please note if you are using a DCI P3 model mac (newer iMacs and Macbook pros I think) or an older model.

    We have not tested enough on these yet...

  • @herf

    I am running macOS 10.13.2 on a MacBookAir6,2 with a 1,3 GHz Intel Core i5.

    I explained my problem in one of the earlier post: neither Flux nor the build in Night Shift is working..

    I took a look at the console. There are many messages regarding Flux whenever I launch it. Unsure of which messages to post I picked 2 that stood out for me.

    One was: "ColorSync: ColorSyncProfileCreateWithDisplayID failed to get profile for kColorSyncDisplayDeviceClass" which was from the com.apple.colorsync subsystem. - I saw the same error was mentioned here by @mfield earlier.

    The other one that stood out was "Function boringssl_session_errorlog: line 2829 [boringssl_session_read] SSL_ERROR_ZERO_RETURN(6): operation failed because the connection was cleanly shut down with a close_notify alert" of the com.apple.network.boringssl subsystem. This one stood out because there were about 10 exact copies of it in the console.

    Hope any of this helps, would be glad to help to further diagnose the problem but will need some guidance.

    I am however fairly familiar with the command-line and basic programming so not a total noob.

    Hope there's a solution soon as each evening I get more frustrated at not being able to properly dim / color the screen.

    EDIT: I just tried launching Flux with sudo and I got the following output:

    2018-01-25 20:59:13.279 Flux[15999:1232188] Got response 200
    2018-01-25 20:59:13.280 Flux[15999:1232188] Skipping offer 1 because it has expired

    Flux stil does not work..

  • @herf
    I am indeed running a brand new 2017 iMac.

    I found a fix, though!

    I noticed that my monitors were stuck on an sRBG profile I had never switched to in the first place.
    Assuming there was something wrong with that profile (and maybe others,) related to a change in 10.3.2, I went ahead and deleted it. And every other unused profile I could find.
    I did keep my iMac's default profile.

    These were found in:
    /Library/Application support/Adobe/Color/Profiles/

    I can't tell you which was actually causing the problem, and it may be better to go through them one at a time until you find THE profile responsible.

    I'm now able to manually swtich profiles, as well as let F.Lux do its' thing.

    0_1516915836215_Screen Shot 2018-01-25 at 4.30.21 PM.jpg

    I should note that Colorsync utility's profile verify/repair couldn't find anything wrong.

  • I don't recommend deleting profiles in the system, only choosing a different one.

    The sRGB profile is usually used as a reference (target), not for a display profile, and the "iMac" or "Color LCD" one is preferred.

    We will try to borrow a newer Mac and see what we find out about the wider-gamut screens and how they are reading profiles.

  • @herf

    The problem was an inability to choose a different profile. It was full on stuck on the sRGB profile.
    I could not manually switch, and both f.lux and night shift were having the same issue.

    I do agree that this isn't even close to ideal. It would be better to figure out what was causing it to stick.

  • @mfield very interesting...thanks.

  • This post is deleted!

  • @KneelMan
    Deleting anything in /System isn't possible without first turning off System Integrity Protection. You can google how to disable it, but know that it opens up your computer to a number of risks.
    If anything, do what you need to with the profiles, then re-enable it.

  • @mfield Strange, I just noticed when I check out my screen color profiles via System Settings, I haven't even got a f.lux profile though I've been using F.lux for years, is this strange?

    I also haven't got the "~/Library/Colorsync/" directory, instead I have "~/Library/ColorPickers" which holds a number of .icc files..

  • f.lux profile is only for dual-GPU macs. We do it only when we have to in order to keep the screen from flashing - the normal one is restored during the day.

    I am guessing the system is somehow failing to load the sRGB profile and then not letting anyone change the setting. Wonder if a Mac in this state would load a fake sRGB profile from ~/Library/Colorsync/ (but probably not).

  • I have this issue on a Mid-2015 15" MacBook Pro (11,5). It still happens on macOS 10.13.3.

    The issue seems to happen to me when the Intel Iris Pro GPU is used. When I launch Photos.app, the computer switches to the AMD GPU (Radeon R9 M370X 2 GB), and I suddenly get the f.lux tint. I then quit Photos.app, and I go back to see un-tinted content.

    I use iStat Menus, and the CPU component also shows the currently used GPU. Launching Photos.app does switch to the AMD GPU, and quitting it goes back to Intel. Additionally, if I disconnect the laptop charger while Photo.app is running, I again go back to no f.lux tinting, and iStat Menus shows that the computer went back to Intel Iris Pro.

    It seems this bug happens only while using the Intel Iris Pro GPU.

  • This post is deleted!

  • 10.13.3 does seem to fix things on Apple's end!

    I've moved all my various profiles back into place, and it's all behaving the way it should.

    Definitely good news :)

  • I am on 10.13.3 and the issue persists just like in previous versions.

  • I'm on 10.13.3 and observed this issue, but fixed after a reboot.

  • How is this performing on 10.13.4?

  • macOS 10.13.4 seems to have finally fixed this for me! It's the first time it consistently works since upgrading to High Sierra.

  • @Eugenio-Padilla

    Makes me jealous. It still doesn't work for me. No response whatsoever.. not from flux, nor from the built-in Night-Shift

  • @bobzippymail
    I'm somewhat of a neophyte, Bob. How do I do this? Step by step 😜

  • Still not working for me either, even after the last system update (10.13.5).

  • Have this same problem. Have a blue tint, F.lux isn't working, and can't change the display colour profile at all. It's locked on the sRGB profile. And disabling System Protection Integrity and deleting the file didn't work either.

    Seemed to happen after I deleted the cache in order to solve another problem with the calendar agent using 100% of the cpu and running hot. Recently upgraded from El Capitan to High Sierra. Running 10.13.5 too.

    I take it no one has found a solution if the most recent High Sierra updates didn't solve the problem?

  • I ultimately fixed the issue by doing a simple installation of MacOS via the Disk Utility. Simply restart your computer by pressing Cmd+R and reinstall the system. A simple installation will not make your data disappear, and there's no need in making a clean install (i.e., from scratch). I would strongly advise to save all your files and/or make a copy of your drive first; especially if you aren't familiar with such practice. As a result, all my Color Profiles were reset and both F.lux and Night Shift are perfectly working now.

  • On my brand new machine 2018 Macbook Pro 15" - running the latest OS - the latest version of flux is still showing the error. @herf , is there a fix close to complete?

  • There is a thread about the newest Macbook Pro over here:

    The drivers are really screwed up on 10.13.6, and it needs a fix from Apple, but we've posted a workaround for now.

  • I am using macOS High Sierra 10.13.6 and it works just fine.

    My laptop is

    • Macbook Pro 15" Late 2011

    Hope this helps you or anyone else.

    Thanks f.lux, keep it up!

Log in to reply