Please add disable by .exe



  • Hi,

    Please would you add this feature.
    I use f.lux all the time, but for games I want it disabled.

    The problem is that "disable when" does not working properly. For example, with Battlefield 1 open, it does not show it under the disable when menu.
    Furthermore, the option "disable for fullscreen apps" does not work properly either. In some games, it does not detect that it is fullscreen even though it's set to fullscreen mode (not borderless windowed). Even if it did work, there are some fullscreen applications where I still want to use f.lux.

    A simple solution would be to add the option to "disable when program is running", where you can simply blacklist .exe's like in many programs.
    As an IT person, from a coding perspective this can't be overly complicated.

    Thanks.



  • I second this!! not only does it nor work every-time, but having to alt+tab out of the game to do it is a bit of a pain.



  • @hvcrios said in Please add disable by .exe:

    I second this!! not only does it nor work every-time, but having to alt+tab out of the game to do it is a bit of a pain.

    Yes, for me it works sometimes in-game with alt+end but there's a chance that it minimizes the game. Either way is annoying.



  • I third this. The fullscreen option doesn't work for me, since I have 3 monitors and while a game takes an entire screen, I don't have it in "full-screen" mode, rather, it is a window with no borders.

    Would be really great if one or more exe files can be specified to watch for and disable itself when they are running



  • @linuxgurugamer I'll add that if this feature is added, I'd gladly make another donation.



  • I have a similar issue, where Flux doesn't detect that it should remain disabled when I change videos in MPC-HC. Possibly because I've set it up to change framerate of the monitor to match the video.


  • f.lux team

    f.lux should use the EXE name or the main resource name if it can find it. None of these should depend on what file is open/movie is playing.

    We'd certainly like to fix bugs that keep our list of apps to disable from not showing up. We tried to show the "last two" apps so alt-Tab would always work. I guess we could make a longer list (like last 5 minutes?) if it is necessary....



  • Same to me.
    The exclusion list should use the whole process name including the .exe extension - perhaps the complete file path.

    Also I suggest that the list is not comma separated but of the type REG_MULTI_SZ so one line represents the executable or full path.

    Under some circumstances f.lux is toggling when other processes are run which are not in the list - yesterday I recognized that tor.exe triggered it.

    I use tor as a proxy for a software that has several lists to update daily, but that software still has a bug that it crashes when many lists are updated - I think it can't handle that amount of connections. tor makes it slow ;) when updating so it doesn't crash.

    So in the middle of nowhere the desktop notification popped up about tor triggering it and it was clearly visible that f.lux was triggered off for a while.

    I think this could be because of the actual way the list of exclusions is created somehow.



  • @herf said in Please add disable by .exe:

    f.lux should use the EXE name or the main resource name if it can find it. None of these should depend on what file is open/movie is playing.

    We'd certainly like to fix bugs that keep our list of apps to disable from not showing up. We tried to show the "last two" apps so alt-Tab would always work. I guess we could make a longer list (like last 5 minutes?) if it is necessary....

    Well, as mentioned in my post, it doesn't work for many apps, like battlefield 1. Also how many apps will it remember? What if I want to remove it? I'd first have to start the program etc.

    That's why I suggested to simply add an option menu where you can add & remove .exes to a (black)list. This solves all problems.

    Thanks


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.