PC can't sleep while f.lux is running [philips hue only]



  • Greetings,

    I am on Windows 10 1703 build 15063 and I am running the current f.lux beta 4.39. I noticed that whenever I try to put my computer to sleep (suspend to RAM) it just shuts off the monitors but keeps running. Moving the mouse or typing a key immediately brings me back to the desktop without even having to unlock the screen.
    The only way to put the device into sleep is to exit f.lux before. This issue seems to appear around a week ago.

    According to 'powercfg -requests' flux.exe is listed in 'SYSTEM' and in 'AWAYMODE'.


  • f.lux team

    This should only happen if f.lux is running as Philips Hue controller (in the Options menu).

    Otherwise it should not prevent sleep.



  • I can confirm this! If I disable the Hue controller before, the PC can go into sleep without any issue.


  • f.lux team

    Maybe we will need to add a note that this will prevent your PC from sleeping.



  • Hey, I know this topic is a bit old but I ran into the same issue today and I would like to share this "fix" I found for anyone who follows.
    To block f.lux from keeping the PC awake, but still allow it to control your Hue lights when the PC is on, open a command prompt window in administrator mode by opening the search bar (Windows 10), searching for "command" and right clicking the command prompt and selecting "Run as administrator". Next, in the command window, type these two commands (confirm each by pressing enter):
    powercfg /requestsoverride PROCESS flux.exe SYSTEM
    powercfg /requestsoverride PROCESS flux.exe AWAYMODE

    After that, f.lux should no longer prevent your PC from entering sleep mode.

    Hope this helps!