f.lux changes gamma curve (lifts shadows) regardless of colour temperature [fixed]



  • Dear f.lux team,

    I am an avid user of f.lux for Windows for some years now, and I am very excited about the new features introduced with f.lux 4. After installing the beta today and playing around with it, I noticed a strange change in shadow brightness when starting f.lux. I conducted some experiments, the findings are as follows:

    Whenever f.lux starts, it modifies the gamma curve of my monitor to brighten up the shadows.

    • This change does not reflect in the gamma curve that can be read from the GPU with the Displaycal Curve Viewer tool, so I suppose it happens at a somewhat higher level.
    • The change is easily visible when looking at an image with dark grey structures (i.e. dark rocks) while f.lux starts.
    • It happens independently of the set color temperature. If f.lux is set to 6500K, so that there should theoretically be no visible change at all upon startup, it still happens.
    • If f.lux is running and I select "disable for one hour", or letting it disable automatically due to a currently running app, of course the temperature changes to 6500K, but the shadows remain lifted.
    • If I shut down f.lux, the shadows remain lifted until the GPU LUT is modified, in my case by the Displaycal loader.
    • This does not seem to be a problem of f.lux loading a wrong ICC profile itself: the colours of the loaded profile (or, in case of an uncalibrated monitor, the raw colours) remain. Only the shadow brightness changes.
    • This behaviour does not appear in f.lux 3.

    I do think shadow lifting might be a sensible thing to do for the warmer/dimmed colour temperature settings (after all, I think you implemented it for a reason :slight_smile: ). However, it should not happen in 6500K respectively OFF mode. Also, the shadows part of the curve might not be the only part that gets modified; however, it is the shadows that appear the most changed to me.

    My system is a Dell XPS 13 9360 with QHD+ (CABC off), Intel HD 620, running Windows 10 x64 Build 14393.1358. If I can be of any help by offering more information or testing, please let me know.


  • f.lux team

    Yes this should only happen at extreme dimming settings or extreme color temperature settings.

    So I guess it thinks your display is very very dim, which apparently it's not?

    If it happens on a fully-bright monitor at 6500K (or at exit) that's a bug.



  • Possibly related to my issue here: https://forum.justgetflux.com/post/14167 ?



  • @herf You are right, I did not test for different monitor brightness: at 100% brightness, the effect can not be observed. It appears for a dimmed screen at every color temperature setting, also at 6500K, also for disabled f.lux (where, at least in my opinion, it should not appear, as one of the main purposes of disabling f.lux is colour accuracy; this includes brightness accuracy on a calibrated monitor, also for monitors calibrated at a brightness below 100%).
    If this should thus be treated as a bug or as a feature request might be debatable. However, I think a significant amount of people deactivating f.lux for a specific purpose do this for doing colour sensitive work, where a deactivation should be a true deactivation.

    A definite bug remains: upon exit, the modified brightness curve remains active. If I quit f.lux at a monitor brightness below 100%, I am still confronted with the raised shadows, which from that moment on are persisting though any brightness changes.

    @K4m1k4z3 looks like what you are experiencing is f.lux changing the brightness curve for all monitors, instead of only the adjusted one, yes... not directly related to my issue, but the underlying brightness curve seems to be the culprit in both of our cases. This remains however for @herf to be judged.


  • f.lux team

    Yes we designed it to only happen when the screen is dimmed very far, but maybe the dimming curves on the Dell are quite different than the machines we used. We should probably make the threshold much lower.

    Disable and exit are clear bugs. We will fix and try to adjust this so you don't notice it except when it helps. :)



  • Okay, cool! Glad I could help, and looking forward to seeing this fixed.


  • f.lux team

    Ok next build (4.36 updating now) will disable this behavior for backlight dimming, so the effects should be off at exit.

    So, it will only happen for more extreme f.lux settings (and our "soft dimming"), where we're sure what's going on, and when it's the same on all monitors.



  • Installed 4.37 and did a quick test: all issues seem to be fixed, thanks for the quick update.

    If I stumble across anything else, I will report back. Keep up the good work!


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.