Screen blinks when Alt+Tabbing from a game

  • TEST 1

    Set f.lux to 3000K (example)
    Launch a game
    Do Alt+Tab
    See that the screen blinks for 1/2 seconds to daylight colors
    Colors are back to 3000K (example)

    TEST 2

    Set f.lux to 3000K (example)
    Launch a game
    Do Tab+Alt (opposite of the above)
    See that the screen remains with daylight colors until you do a click with the mouse/keyboard
    Colors are back to 3000K (example)

    This issue was present since version 4.15, when it became public. It didn't happen with version 3.

    Running a GTX 1070, Windows 10 Version 1703 build 15063.447 with nVidia drivers 384.76
    Games tested: Rocket League, CSGO, Limbo, Mad Max.

  • @disqQ If the colors go back to 3000K, then 1/2 is probably the f.lux program checking current colors / fullscreen programs etc, and making sure it's refreshed. Many Direct X 9 games (if not all) in fullscreen, do not support custom color / gamma changes outside of what that program or game uses, so it's good for f.lux to refresh when switching programs like this.

  • Not sure about that. This is a similar issue with this one: which also blinked/didn't restored until switching windows.

    In this case, it blinks/doesn't restore until a click is done either on mouse or keyboard.

  • I had this issue as well. For me, it was fixed by deselecting "Disable>for fullscreen apps." With that setting on, f.lux would be at daylight on an alt-tab out of a game, and it would transition (at whatever transition speed had been set in the preferences) back to my nighttime color. With that setting off, colors would still be normal in the game (i.e., f.lux was disabled in the fullscreen game anyway), but the transition back to nighttime color would be instant on an alt-tab. Hope that helps.

    And for the developers, you may want to make that transition (when leaving full-screen if the "Disable>for fullscreen" mode is on) instant, though perhaps you have your reasons for making it slow.

Log in to reply