Monitor comes back from standby without f.lux colors [fixed in new beta]



  • As reported here: https://forum.justgetflux.com/post/13522 & https://forum.justgetflux.com/post/13544 & https://forum.justgetflux.com/post/14232

    Since then 4 nVidia drivers came out - 381.89; 382.05; 382.33; 382.53 - and the result is always the same.
    Windows 10 Creators Update - since then, 4 builds came out - 15063.250; 15063.296; 15063.332; 15063.414. Result is always the same.

    Probably, the problem was already there before but can't confirm. From that post on, it happened with every version posted above.
    Using DisplayPort.



  • I cannot believe i'm the only one facing this issue.


  • f.lux team

    My Windows 10 machine does not exhibit this issue. It has:

    GTX 650 (older than yours)
    Windows 15063.447
    NVIDIA 382.05
    f.lux 4.34

    With gamma locked and unlocked, have tested "monitor sleep" and "system sleep" and f.lux comes back every time.

    Can you post any more information?



  • @herf said in Monitor comes back from standby without f.lux colors:

    Can you post any more information?

    Such as what?


  • f.lux team

    i.e. does it happen always, or just some of the time? Are there any steps you can write down to explain it?



  • @herf said in Monitor comes back from standby without f.lux colors:

    i.e. does it happen always, or just some of the time? Are there any steps you can write down to explain it?

    It happens everytime.

    Have f.lux installed;
    Go away from your computer for a few minutes;
    Come back and make sure that the monitor is in standby;
    Move the mouse;
    See that the screen color temperature is reset to daylight;

    It's exactly the same as @korg250 wrote on this thread: https://forum.justgetflux.com/topic/3857/f-lux-resets-color-temperature-when-laptop-lid-is-closed

    If, after opening the lid, I stay in the same window, the color stays as daylight. It is only back to normal (as set by the schedule) after I change to another window. Changing between tabs in a browser does not trigger f.lux to fix the color. The color is fixed at once, not slowly.

    With the only difference that this is a desktop and doesn't have lid's.



  • @disqQ I have the same issue, when display goes to sleep/standby and you wake it with mouse at night time, my screen comes back with daytime settings.
    If I go to tray and bring flux up it changes to proper values.

    I am on desktop 3570k/GTX 970 it happens on last few drivers (it has never worked correctly with new 4.x beta. the old 3.0v worked w/o issues.
    I am on Win10 1703 and 384.76 drivers if that maters.


  • f.lux team

    So as far as I can tell, the only difference here is: it works on Kepler (GTX650), but fails on Maxwell (GTX970) and Pascal (GTX1070).

    The latter two are capable of 10-bit color, while the Kepler appears only to do 8 bit (a clue?)

    Or alternately, there is some way these machines are sleeping that is different than mine. (Using the normal Windows power saving).

    f.lux is watching for wake from sleep and power saving modes to work around "most" of the issues here, but maybe there is one more case we are missing.


  • f.lux team

    I found a cheap GTX 1050Ti card and will test later this week when it arrives.



  • @Edkiefer said in Monitor comes back from standby without f.lux colors:

    @disqQ I have the same issue, when display goes to sleep/standby and you wake it with mouse at night time, my screen comes back with daytime settings.
    If I go to tray and bring flux up it changes to proper values.

    I am on desktop 3570k/GTX 970 it happens on last few drivers (it has never worked correctly with new 4.x beta. the old 3.0v worked w/o issues.
    I am on Win10 1703 and 384.76 drivers if that maters.

    Thanks for your feedback @Edkiefer
    I also have an i5 3570K but i doubt the CPU is at fault here. Installed the 384.76 drivers as well and the problem is still here.

    @herf Well, i would like to have the problem fixed but if that takes buying a new GPU just for the case, don't bother and save your money.


  • f.lux team

    GTX 1050Ti does not show the bug either (but at least I can run some machine learning on the GPU now). So I need help with steps to reproduce this bug.

    My configuration:

    1. Running f.lux 4.34 (with fix for monitor sleep)
    2. NVIDIA Driver 384.76
    3. GTX 1050Ti

    What I'm doing to test this:

    Test 1

    Under Power & sleep, set "when plugged in, turn off after [1 minute]
    Set f.lux to CCT like 3000K
    Wait for monitor to sleep
    Wake up a few seconds later
    => Colors are preserved

    Test 2

    Set f.lux to CCT (3000K)
    Start > Sleep
    Wait for monitor to sleep
    Wake up a few seconds later
    => Colors are preserved

    What case are you seeing that I'm missing?



  • Yea, those are the steps i'm doing with the same software/drivers.

    On test 1 If I stay in the same window, the color stays as daylight. It is only back to normal (as set by the schedule) after I change to another window. Changing between tabs in a browser does not trigger f.lux to fix the color. The color is fixed at once, not slowly.

    On test 2 when i wake it up the colors are preserved on the login screen but as soon as i click sign-in it blinks to daylight colors and back to the previous one.



  • If I do same thing on my end, I can open flux so I see flux window and slider at 3K value.
    Let it sleep for 1 min, move mouse so it wakes.
    Slider is at 3K and says 3000 value but screen is daylight and then if I click taskbar or flux icon it then goes to 3000

    That is with nothing running, but if i do have browser open, same thing.

    Edit I can't do sleep/hibernation from start as I have them disabled with powercfg.exe, so I can't run test 2, all my comments are with monitor/display sleeping.

    Edit2: are you using a color profile for display? , or you have all defaults.
    Win10 >all settings>display>display adapter properties> click color management and I use a ICC profile (dell2007FP) for my Dell monitor.
    In that window I have enabled checkmark "use my settings for this device"


  • f.lux team

    Thanks,
    I have it failing now - turns out I had to turn off the login screen on wake, or it would hide the problem.



  • @Edkiefer I have a custom .icc profile for my Dell as well but i already tried with the default one and the problem persists.

    @herf So you finally reproduced the issue on your end?



  • Good, At first I thought it maybe one of settings, but tried all , on/off with same results.

    I login with admin, so i never see that screen (except for sec on boot)


  • f.lux team

    Apparently finding out that a monitor has slept is one of the unsolved problems in Windows. I made a workaround for this case here:

    https://justgetflux.com/flux-setup4-35.exe

    See if it works?



  • Need more testing, but after reboot it seems so far to work (2 times so far pass).



  • Yep, it's fixed! In both Tests, all good now.

    Thanks



  • This post is deleted!


  • @herf

    I updated to 4.35 and the issue was fixed only if my monitor turns off as a result of power option being triggered (ex: "turn off the display" after 1 minute idle).

    If the display turns off when I close and open my laptop lid, the issue remains, exactly like @disqQ 's description on test 1:

    On test 1 If I stay in the same window, the color stays as daylight. It is only back to normal (as set by the schedule) after I change to another window. Changing between tabs in a browser does not trigger f.lux to fix the color. The color is fixed at once, not slowly.

    Thanks.

    I am using Win10 Pro with Intel HD Graphics 4400.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.