f.lux beta turns off while playing mass effect andromeda



  • Hello,

    i7 4790k stock
    noctua d15
    gkill 2x8 2400 ddr3
    evga 1080ti sc2 hyrbid
    evga supernova p2 650w
    1tb samsung evo 850
    windows 10 pro
    acer xb271hu bmpriz

    Been having problems with fps since the creator update. After googling around and trying different things I found that the non beta version of flux was the culprit which I find odd since I never experience any problems flux before. I installed the new beta version and this seemed to solve the problem. With the previous version my fps was locked at 134 while playing League of Legends. When things got chaotic I experienced lag and stuttering like I was playing on a crappy mac book. With beta it goes back to normal which is in the 200-300 range. With performance back to normal I opened up Mass Effect Andromeda. The game looked better but I figured this was because of the new 1080ti I just installed. But after 10 minutes I could feel the pressure in my eyes building and a headache coming on. I alt tab to see flux is still on but realized flux beta was turning off when I went back into game. Full screen or windowed borderless, it didnt matter it still turned off.

    The only fix at the time was to switch between each version for each game which isn't all that bad since its done within 30 seconds.

    Anyways keep up the good work!



  • @abcdeer Could you explain what you are doing when you switch between different versions, and are you referring to f.lux?

    Also, are you absolutely SURE it is in windowed mode, or borderless windowed? You look like you know what you're doing, but it wouldn't hurt to double check. If the screen doesn't lose picture when opening the game then you're definitely using borderless windowed mode, but maybe there is a gamma setting in this game that is overriding f.lux's color settings. Please check for such color settings, and report back.



  • Hello

    @Tungsten_smooth Yeah, sorry if misunderstood your question but I was referring to f.lux. Say I have beta running. Ill exit the program then run the installer for the previous/non beta version and it will install and run with no problem. I did the same thing when I switch from non beta back to beta. The reason is league of legends runs fine with flux beta while mass effect works fine with the non beta version.

    Mass effect: I normally play in borderless window mode cause every time i alt tab in full screen mode the game switches to window mode and reduces the size of the window to about half the size of my screen but that a problem unrelated to flux.. i think (more info cant hurt right). Last night was the first time I tried beta out and encountered this issue. I tired beta with both borderless window mode and full screen mode but it didn't matter as each mode seemed to suffer to from flux being overridden.

    I think you might be right since I ran ddu (Display Driver Uninstaller) and all my setting were probably reset. I quickly went through nvidia control panel and I use the ultra pre-settings for mass effect but didn't check each setting. Ill go back and double check everything and report back to you.

    Thank you.



  • It seems to me the f.lux beta release has the setting enabled by default called "disable for fullscreen apps". I found it to be enabled when I installed it. It's in the submenu for "Disable".



  • Update: Went back and checked each setting in nvidia control panel and the settings for each game. Didnt see anything out of the ordinary. I have been running f.lux beta without much trouble. As @TwoCables mentioned the setting called "disable for full screen apps" was disabled but I went ahead and enabled then disabled it. This might have done the trick but I did notice that when I launch mass effect or league of legends, flux will sometimes turn off (full screen and windowed borderless), I'll alt-tab and flux will turn back on, sometimes theres a few seconds delay but once I get back into game it will still be on. On rare occasion I'll have to alt-tab a couple of times.

    Only issue I have is league of legends is still capped at 134fps. Not a big deal and I dont think this is a flux issue.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.