F.lux now applies twice with Remote Desktop



  • Re: f.lux beta (another thread for 4.21)

    I've had f.lux installed on all my computers for years. I keep it around 3800 to 4000k max on every machine.
    I frequently remote between computers. In the past everything worked fine- the remote f.lux had no effect and the local one controlled my local monitor. But with this beta, the colorization gets applied on both sides and it's pretty hard to look at.

    I'd appreciate a setting that detects that I'm remote and doesn't apply anything so that I don't have to keep turning it off and on all the time.

    Other than that, looking great so far! (Btw, a different wake time per day of week would be much more actually useful. I think someone else mentioned this.)


  • f.lux team

    Thanks for the report. Good to know this kind of works, and now we just have to make it easier to turn off. :)



  • @herf Wow, this is interesting. Could you let me know what you changed to get f.lux to be applied in a remote display, or more specifically, a remote display driver software perhaps?



  • @herf This still affects version 4.47, is there an option that needs to be toggled to restore the old behavior?


  • f.lux team

    You can disable the Rdp app on the local side for now but we will disable on the remote side in the future.

    There are some cool applications for leaving it enabled remotely but usually disabling on the remote side is the right thing to do. I think!



  • @herf said in F.lux now applies twice with Remote Desktop:

    You can disable the Rdp app on the local side for now but we will disable on the remote side in the future.

    There are some cool applications for leaving it enabled remotely but usually disabling on the remote side is the right thing to do. I think!

    Don't I know it– I've manually disabled it somewhere around 200 times since I first asked for this to be fixed. Not once have I ever remoted to a f.lux computer from a non-f.lux computer.

    It should be set to do the most frequently-needed thing by default. Disabling automatically, and having to opt back in if hypothetically I needed it on the remote side, would be perfect.
    (If you want to be fancy, sure, allow the opt-in to be remembered on a per-connecting-computer basis, but I don't need that yet. I just need a opt-in rather than an opt-out situation.)


  • f.lux team

    beta v4.51 has this fix I think.



  • @herf said in F.lux now applies twice with Remote Desktop:

    beta v4.51 has this fix I think.

    Cool! I'm not finding a download link for it but I'd like to try it.


  • f.lux team

    It is the beta (about box and relaunch), or https://justgetflux.com/flux-setup4.exe



  • @herf said in F.lux now applies twice with Remote Desktop:

    It is the beta (about box and relaunch), or https://justgetflux.com/flux-setup4.exe

    Yow, I always forget to look away when the installer runs and instantly cuts back from 3500k =D

    Alright, so this is what happens: I installed the latest beta on two of my computers. Remoted into the other one and saw the remote side disable which is cool. Then I exited remote desktop and logged into the other computer physically. Even though there are no remote sessions open, Flux is still disabled there. If I drag a slider, it jumps to being back on, but when I let go it stays off.


  • f.lux team

    Are the screens the same resolution? There is an "optimization" there that might break this case. Not true for me so I didn't test it.



  • @herf Remoting, the screen size is 2560x1440 at 100% DPI. Physically at the other computer, the screen sizes are 2560x1440 at 125% DPI and 1600x900 at 100% DPI.



  • On the last beta, I can't get flux to enable on a computer which I have not remoted to. It doesn't say disabled anywhere. Dragging the slider makes it jump back on till I let go. I'm going to have to roll back.


  • f.lux team

    I have fixed this and it will be in the next beta build (likely 4.52)
    It says when it is disabled, and re-enables when you are local.



  • Cool, I'll keep an eye out for it!



  • 4.52 is already released as a beta.



  • This post is deleted!


  • I'm sorry I forgot to reply! Everything seems to be working smoothly and I'm on 4.54.



  • I just have to tell you this is super nice. Thank you so much!


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.