Flashing Screen 10.11 El Capitan



  • @f-lux-team FWIW, I didn't have any of these issues until I just recently upgraded from 35.4 to 35.6. Once I upgraded I had all the issues described in this thread and came looking for answers. I restored my 35.4 version from a Time Machine backup and things are back to normal. I have 'automatically adjust brightness' enabled on both screens. I'm using a mid 2014 rMBP (Intel Iris Pro Graphics + NVIDIA GeForce GT 750M w/ 2GB) connected to a 27" TBD. The flickering seemed to be an issue if I was using the Intel or NVIDIA graphics (aka using just the laptop's display or 2 displays). Currently running OS X 10.11.2



  • @jocamero Hi - this is interesting. We will test some more because our setup is very similar.

    Is there any chance you restored any other files other than f.lux? Did you reboot after the restore?

    Automatic brightness seems to be a little random with the Thunderbolt display, so the new El Capitan brightness feature may be "off" for some reason or another. We'll check it out.



  • @herf AFAIK I only restored the Flux app located in Applications. I didn't reboot. To clarify, I don't recall ever having any flickering issues with the TBD, only the rMBP's display. Both displays definitely have auto brightness enabled (very sunny in my office during the day and also work at night).

    It also only seems to happen a few hours after sunset. Sunset is ~5pm, flickering started around 9pm-10pm the past couple of nights. I think this is when flux is fully enabled as apposed to partially changing the color temp around sunset.



  • Also, you can shine your phone's flashlight at the screen and it should happen. More noticeable with f.lux at a night-time setting.

    What happens is that any change in ambient light causes the system to generate a new color profile (largely ignoring what is there). In my testing, even a custom profile (from an x-rite device) is overwritten, so it's not just a f.lux bug.



  • @herf Still working without any issues. Just now tested with a flashlight on the TBD and the rMBP, both displays got bright and dimmed without issue. I'm currently in the nighttime mode.

    *Was I automatically updated to v36.3? Apparently this is the version I tested with. I didn't do a manual update. Still no issues either way.



  • @jocamero yes it looks like Apple has fixed the issue and our workaround may be causing the problem. I'm going to post a beta right away to test.



  • The main build on https://justgetflux.com/ is 36.6 and has the (old) fix.
    A reboot may be required to turn off the broken behavior!



  • @justgetflux running 36.6 on OSX beta 10.11.3. No issues at all with automatic brightness. Seems to be resolved! woohoo



  • @justgetflux Just updated and v36.6 also appears to be working correctly for me. I did the flashlight test without any issues.



  • Nevemind. I guess I spoke too soon... Flux disables when brightness changes with automatic brightness enabled. It was working fine before not sure what happened. Still on 36.6

    Edit: rebooting seems to have resolved the issue. Why is this happening haha



  • Yea I've uninstalled flux until this issue is resolved. Doesn't help that I use an external monitor frequently too.



  • The only solution I've found so far is to downgrade to version 36.0, as @fluxydude said. The latest version doesn't fix the flashing, I also installed gfxCardStatus only to solve this, but nothing. Every time I went into Movie Mode, it started flashing and never stopped, only downgrading helped.



  • I'm using a Mac Mini 2012 2.5 Ghz, Core I-5. I'm wondering if perhaps a mac mini may not have a light sensor? Any other mac mini folks experiencing this flashing screen?



  • I started getting this problem. I have been finding that closing flux and then restarting it tends to make it go away for a few days.

    The interesting thing is that it's worked great on El Cap till quite recently.

    What gives? :P



  • Everyone experiencing this needs to 1. Make sure that 36.6 is installed (you might need to reinstall). If it doesn't fix your problem right away 2. Restart. If that still doesn't fix the problem, please 3. Let us know what your system is like and 4. disable autobrightness.



  • Strangely, I've never had any problems with f.lux and El Capitán, even with "adjust brightness automatically" turned on. However, last night I let OSX upgrade to 10,11,3 and this morning I'm flickering like a good 'un. So, it seems the latest OSX update has finally broken things for me too!

    I see I'm on f.lux 36,5 at the mo. So I'll upgrade and see if that fixes it. I've also disabled "adjust brightness automatically" for now, which does seem to have helped.



  • I just upgraded to El Capitan 10.11.13 and I am now having screen flashing issues. Installing Flux 36.4 did not fix the issue.



  • @lowi0008 what is your machine, have you rebooted? @madra too - have you rebooted? We cannot repeat this here after installing v36.6 and rebooting.



  • @lorna I thought I had rebooted but apparently had not. The reboot cleared things up. Thanks.



  • @lorna said:

    @lowi0008 what is your machine, have you rebooted? @madra too - have you rebooted? We cannot repeat this here after installing v36.6 and rebooting.

    I hadn't rebooted yet either. Seems to be working fine now, after rebooting –even with "adjust brightness automatically" turned on



  • @madra great to hear thank you!



  • @lorna i just uprade to v36.6 and rebooted like hour ago and no flickering so far!

    Thank you, guys for great work!!!



  • I reverted back to v36.5 which works fine without flashing on my old 15" MacBook Pro late 2008 Nvidia graphics. v36.6 starts flashing when setting f.lux in Movie mode only. Tried a reboot, but not disable "automatic brightness" and reboot together.



  • I have this problem too, but only when I enable dark room mode
    My macbook is mid-2010, so it doesn't have auto-brightness feature
    10.11.3 version is installed on it

    And I've found something interesting: it stops flashing when I open flux menu (screenshot)



  • I had / have this problem also. I installed the 36.6, turned on again auto brightness and rebooted (like two days ago).
    I've noticed some flashes from time to time, like for example at booting and if I change the light really really suddenly (i.e. I point my desk light directly to my mac screen, or if I'm in a room and I tilt my computer so the screen looks now somehow to the ceiling lights). Then, it occurs a flashing (just one), so it's is now really unnoticeable.

    I can live with it guys! Thanks for the update!

    PS/ It's also true that movie and dark room mode don't work properly. They flash or beats all the time, but I don't use those modes. I don't use my computer in a dark room (at the moment) and if I have to use the movie mode I use "disable for this app". Anyhow I encourage you to continue working on a solution for those problems and developing this wonderful app. It's great!



  • I confirm what @stek29 says. It stops beating when one opens the flux menu.

    It's incredible how weir sometimes software behaves.



  • @lpuerto can you tell me what Mac applications you're running when this happens to you?



  • @lorna puffffff....

    Mail, Safari, Evernote, Preview, Word, Pages, iTunes... for the movie mode Movist.

    I can try without any app if you want, and just after restart. (if you want) :)



  • @lorna I did it just without any app running after I reboot and the same result.



  • @Noway said:

    I reverted back to v36.5 which works fine without flashing on my old 15" MacBook Pro late 2008 Nvidia graphics. v36.6 starts flashing when setting f.lux in Movie mode only. Tried a reboot, but not disable "automatic brightness" and reboot together.

    Same problem for me: https://justgetflux.com/forum/topic/1967/manual-movie-mode

    Reverting back to 36.5 solved the issue



  • hi guys,
    I've experienced same issues on my macbook pro retina late 2013. It only happened once i updated from mavericks to el capitan.
    For me is only flashing white at rapid changes of light ( like 10 seconds sunlight bewteen clouds in Amsterdam :P ) . Also i've experienced flashing when switching (apple+tab) to Photoshop as i have flux disabled for white balance reasons. I'm with my auto brightness on and I didn't experience those flashes for a while. Only today i've updated my flux to last version so I'm looking forward for a fluxy time! :)



  • Hello everyone!
    I have experience flashing screen problem on my MacBook Air with 10.11 El Captain. I tried to downgrade to f.lux version 36.4 and still no luck. I love f.lux but the flashing problem really annoying me!



  • For me it happens when switching gpus on 10.11.3.



  • In Dark mode, it flashes every second.
    In Movie mode, it flashes every four seconds.
    When it auto dims at night, it very occasionally flashes.

    Flux 36.6
    OS X 10.11.3
    MacBook Pro (Retina, 15-inch, Early 2013)



  • My belief is that the issue is due to the os switching between the integrated and discrete GPU.

    One way to confirm this is to download gfxCardStatus - https://gfx.io/ and see if the flickering coincides with the switching of the GPU. This usually happens when the current process(es) increase GPU load dramatically, so you can sometimes see this when visiting a site with heavy flash adverts (usually newspapers) or when viewing Google maps as it uses OpenGL.



  • @neilb I have this problem on macbook which has only one GPU, so I don't think so



  • If you are getting flashing on any system, you should first update to the most recent version of f.lux. Next, turn off auto brightness in system preferences. A reboot is a good idea.



  • I just want to chime in that I am on OSX 10.11.4 on a Mid 2012 Retina. I was getting flashing every second in Darkroom mode with auto brightness on or off, in a room with almost zero ambient light (baby sleeping) on Flux version 36.6.

    Downgrading to Flux 36.0 as suggested above has resolved my issue for now.

    I'm a programmer, and I'm happy to run nightlies, bisect code, install and uninstall things if you guys need help reproducing and figuring this out.



  • @meckanical Where did you download it? Could you give me a link?



  • @stek29 it's the link that @fluxydude added above: https://justgetflux.com/mac/Flux36.0.zip



  • If you want to downgrade, please try version 36.5 rather than 36.0 - the link is https://justgetflux.com/mac/Flux36.5.zip - there are many bug fixes that you don't want to lose by going back to 36.0.... Please let me know how it goes.



  • @lorna Thanks for that! 36.5 seems to be working just fine in Darkroom mode.



  • For me 36.6 worked fine after upgrading to 11.11.4! (1 discrete GPU, auto backlight unavailable)
    MacBook A1342 (mid-2010, "the white one")



  • @stek29 Nah, stopped working after reboot



  • @stek29 Oh no, can you tell me what happened after reboot? And does 36.5 work after reboot?



  • @lorna 36.5 is ok
    I'm not sure reboot is problem, 36.6 worked just after update, and in a few days I tried Darkroom -- same problem. So I just reverted to 36.5.



  • @stek29 said:

    My macbook is mid-2010, so it doesn't have auto-brightness feature

    And this is still the same machine right?



  • Just to chime in I am having issues with flashing on 36.6. Autobrightness off latest 10.11.4 update. Retina Macbook Pro 13" Late 2012. Downgrading to 36.5 to see if it fixes.



  • @bleedblue12345 Just updating, no luck with 36.6 or 36.5. Had to uninstall.



  • @bleedblue12345 said:

    Just to chime in I am having issues with flashing on 36.6. Autobrightness off latest 10.11.4 update. Retina Macbook Pro 13" Late 2012. Downgrading to 36.5 to see if it fixes.

    reply

    Thanks for your post - if you want to try one more test of f.lux, a reboot may fix your trouble.


Log in to reply