Flashing Screen 10.11 El Capitan



  • flux is flashing/pulsating the screen about every 3 seconds, fading between yellow mode to disabled. It's as if a gamma setting is being enforced and flux can't keep control. You can reproduce this quickly by manually enabling movie mode.

    flux is unusable on 10.11 until this is fixed.



  • It's been like that during all the beta period of El Capitan: it's a bit frustrating along the youtube video light colors bug (that maybe is an Apple graphic card driver fault I think). And there's another: in the evening, if I quit Flux app the screen goes back to the normal 6500K just to slowly get back to 2700K overtime (with the app still closed). Let's hope in a quick update for this fantastic app



  • I just upgraded to el capitan and I am facing the same issue. I am on a RMBP early 2013. When I choose the color effects -> Movie Mode i f.lux I am getting the flashing behaviour. It renders f.lux impossible to use .



  • I am on an MBP early 2011 and just upgraded to El Capitan. I am having the same issue, but only when I try to use Movie Mode. Every few seconds it pulsates between Movie Mode and disabled. Certainly not as jarring as the issue everyone else is having, but jarring all the same; and it's a bit irritating that when I want to watch a video, I have to disable flux entirely instead of just using Movie Mode.



  • Downgrading flux to version 36.0 seems to fix the issue for now. Best to use it until the devs put in a fix in a future update.

    Give it a try.



  • Yes, downgrading worked like a charm for me too. Thank you and let's wait for a working update.


  • f.lux team

    This post is deleted!


  • Thanks for the new build. Here's what I noticed so far trying it: "Darkroom", when selected, stays on for a few second then gets back to normal (but it's still selected in the menu). "Movie mode", as well, stays on for a second or two then gets back to normal (still selected in menu).

    MBP 13" Mid 2012 (no Retina)
    Intel HD Graphics 4000



  • 36.4 seems to be working so far. Flashes once on movie mode before settling as it should. I'll update if I notice any other odd behavior.

    Thanks for the quick turnaround herf!


  • f.lux team

    We made this the live build on the site, so it is easier to find now.



  • I just tested with 36.4 and works great. Thanks.



  • Hi, version 36.4 does not fix the issue for me. At least not in Safari. Watching a video embedded in a web page (for instance a Youtube video) causes the flashing issue. However, only when watching the video full screen. Turning off flux does not help.

    Additionally, white fields are deformed or pixelated. The problem with the white fields is less when enabling movie mode and goes away when Flux is turned off.


  • f.lux team

    Yes this is a different issue related to Intel video cards, and there's another thread about it.



  • FYI, the flicker was still happening for me on OSX 10.11.1 (Mid 2012 rMBP) flux 36.5 when the XRite agent was running. Auto brightness made no difference. XRite agent is the software component of XRite's screen color calibrator tool (ColorMunkiDisplay). Worked fine on older OSX.

    I had to disable it from /Library/LaunchAgents and /Library/LaunchDaemons and reboot. Now I'll have to find another color calibration software.



  • @Adam-Lugowski said:

    FYI, the flicker was still happening for me on OSX 10.11.1 (Mid 2012 rMBP) flux 36.5 when the XRite agent was running. Auto brightness made no difference. XRite agent is the software component of XRite's screen color calibrator tool (ColorMunkiDisplay). Worked fine on older OSX.

    I had to disable it from /Library/LaunchAgents and /Library/LaunchDaemons and reboot. Now I'll have to find another color calibration software.

    I am also experiencing same issues. Also using iProfiler for xRite and ambient monitoring turned on


  • f.lux team

    @stryke If you're loading a static profile then f.lux will do that for you. If you're monitoring ambient light with a colorimeter, that's a different thing.



  • @herf said:

    @stryke If you're loading a static profile then f.lux will do that for you. If you're monitoring ambient light with a colorimeter, that's a different thing.

    Hi, even if my ambient monitoring is not turned on (when the colorieter is unplugged), I still getting flashes. In fact, I set flux to be disabled for certain apps like, lightroom. Flux disable the color adjustments for a quick flash, then back to the warm mode (assuming i'm working late at night), to cite an example.



  • For me disabling the automatic brightness adjustment solved the issue.

    System Preferences > Displays > uncheck "Automatically adjust brightness".



  • For me disabling the automatic brightness adjustment solved the issue.

    System Preferences > Displays > uncheck "Automatically adjust brightness".

    This doesn't work for me. Despite the auto-adjust for brightness being disabled, it will still flicker an an ambient light change, e.g., when I hold my hand in front of the camera. Flux will also flicker when I adjust brightness manually by using system keys.



  • @jpalmieri said:

    For me disabling the automatic brightness adjustment solved the issue.

    System Preferences > Displays > uncheck "Automatically adjust brightness".

    This doesn't work for me. Despite the auto-adjust for brightness being disabled, it will still flicker an an ambient light change, e.g., when I hold my hand in front of the camera. Flux will also flicker when I adjust brightness manually by using system keys.

    Having the same issue, mid-2012 13-inch MacBook Pro, Intel HD Graphics 4000 1536 MB, Flux V36.5. Disabled auto brightness, also checked whether computer thinks I'm plugged into my dual-screen setup because that has caused issues in the past—no dice. If I'd known this would be an issue, I wouldn't have installed El Capitan; haven't been without Flux for years.


  • f.lux team

    This issue is always fixed by turning off the automatic brightness setting, but sometimes it takes a while.

    For some people (especially dual-monitor users), a reboot may be required after turning off automatic brightness.



  • This issue is always fixed by turning off the automatic brightness setting, but sometimes it takes a while.

    For some people (especially dual-monitor users), a reboot may be required after turning off automatic brightness.

    Thanks. It's working again without auto-brightness.

    I kinda liked auto-brightness but I guess I like flux more. :)



  • I have followed the instructions but I'm still having this issue even after turning "Automatically adjust brightness" off. Rebooting doesn't seem to help either.
    I'v noticed that it only occurs when I navigate to finder, with Cmd+Tab or by clicking it on the dock. This happens even if no finder windows are open as long as the finder app is in focus.

    The screen never goes back to "sunset" mode while the finder window or application is in focus only once i move over to another application.

    Im running OSX 10.11.2 and f.lux 36.5



  • Still having the issue - I'm not disabling automatic brightness. Fairly important feature for people who also care about the things that f.lux does. Are we pinning this on an Intel graphics card driver update (and saying that it's out of the hands of the f.lux folks)? I'd sure like to make this work the way it used to!


  • f.lux team

    @Ari-Brown There is no fix with automatic brightness enabled. Apple made changes that directly conflict with f.lux, and we have no way around it. For now you do have to pick one or the other.



  • @f-lux-team FWIW, I didn't have any of these issues until I just recently upgraded from 35.4 to 35.6. Once I upgraded I had all the issues described in this thread and came looking for answers. I restored my 35.4 version from a Time Machine backup and things are back to normal. I have 'automatically adjust brightness' enabled on both screens. I'm using a mid 2014 rMBP (Intel Iris Pro Graphics + NVIDIA GeForce GT 750M w/ 2GB) connected to a 27" TBD. The flickering seemed to be an issue if I was using the Intel or NVIDIA graphics (aka using just the laptop's display or 2 displays). Currently running OS X 10.11.2


  • f.lux team

    @jocamero Hi - this is interesting. We will test some more because our setup is very similar.

    Is there any chance you restored any other files other than f.lux? Did you reboot after the restore?

    Automatic brightness seems to be a little random with the Thunderbolt display, so the new El Capitan brightness feature may be "off" for some reason or another. We'll check it out.



  • @herf AFAIK I only restored the Flux app located in Applications. I didn't reboot. To clarify, I don't recall ever having any flickering issues with the TBD, only the rMBP's display. Both displays definitely have auto brightness enabled (very sunny in my office during the day and also work at night).

    It also only seems to happen a few hours after sunset. Sunset is ~5pm, flickering started around 9pm-10pm the past couple of nights. I think this is when flux is fully enabled as apposed to partially changing the color temp around sunset.


  • f.lux team

    Also, you can shine your phone's flashlight at the screen and it should happen. More noticeable with f.lux at a night-time setting.

    What happens is that any change in ambient light causes the system to generate a new color profile (largely ignoring what is there). In my testing, even a custom profile (from an x-rite device) is overwritten, so it's not just a f.lux bug.



  • @herf Still working without any issues. Just now tested with a flashlight on the TBD and the rMBP, both displays got bright and dimmed without issue. I'm currently in the nighttime mode.

    *Was I automatically updated to v36.3? Apparently this is the version I tested with. I didn't do a manual update. Still no issues either way.



  • @jocamero yes it looks like Apple has fixed the issue and our workaround may be causing the problem. I'm going to post a beta right away to test.



  • The main build on https://justgetflux.com/ is 36.6 and has the (old) fix.
    A reboot may be required to turn off the broken behavior!



  • @justgetflux running 36.6 on OSX beta 10.11.3. No issues at all with automatic brightness. Seems to be resolved! woohoo



  • @justgetflux Just updated and v36.6 also appears to be working correctly for me. I did the flashlight test without any issues.



  • Nevemind. I guess I spoke too soon... Flux disables when brightness changes with automatic brightness enabled. It was working fine before not sure what happened. Still on 36.6

    Edit: rebooting seems to have resolved the issue. Why is this happening haha



  • Yea I've uninstalled flux until this issue is resolved. Doesn't help that I use an external monitor frequently too.



  • The only solution I've found so far is to downgrade to version 36.0, as @fluxydude said. The latest version doesn't fix the flashing, I also installed gfxCardStatus only to solve this, but nothing. Every time I went into Movie Mode, it started flashing and never stopped, only downgrading helped.



  • I'm using a Mac Mini 2012 2.5 Ghz, Core I-5. I'm wondering if perhaps a mac mini may not have a light sensor? Any other mac mini folks experiencing this flashing screen?



  • I started getting this problem. I have been finding that closing flux and then restarting it tends to make it go away for a few days.

    The interesting thing is that it's worked great on El Cap till quite recently.

    What gives? :P


  • f.lux team

    Everyone experiencing this needs to 1. Make sure that 36.6 is installed (you might need to reinstall). If it doesn't fix your problem right away 2. Restart. If that still doesn't fix the problem, please 3. Let us know what your system is like and 4. disable autobrightness.



  • Strangely, I've never had any problems with f.lux and El Capitán, even with "adjust brightness automatically" turned on. However, last night I let OSX upgrade to 10,11,3 and this morning I'm flickering like a good 'un. So, it seems the latest OSX update has finally broken things for me too!

    I see I'm on f.lux 36,5 at the mo. So I'll upgrade and see if that fixes it. I've also disabled "adjust brightness automatically" for now, which does seem to have helped.



  • I just upgraded to El Capitan 10.11.13 and I am now having screen flashing issues. Installing Flux 36.4 did not fix the issue.


  • f.lux team

    @lowi0008 what is your machine, have you rebooted? @madra too - have you rebooted? We cannot repeat this here after installing v36.6 and rebooting.



  • @lorna I thought I had rebooted but apparently had not. The reboot cleared things up. Thanks.



  • @lorna said:

    @lowi0008 what is your machine, have you rebooted? @madra too - have you rebooted? We cannot repeat this here after installing v36.6 and rebooting.

    I hadn't rebooted yet either. Seems to be working fine now, after rebooting –even with "adjust brightness automatically" turned on


  • f.lux team

    @madra great to hear thank you!



  • @lorna i just uprade to v36.6 and rebooted like hour ago and no flickering so far!

    Thank you, guys for great work!!!



  • I reverted back to v36.5 which works fine without flashing on my old 15" MacBook Pro late 2008 Nvidia graphics. v36.6 starts flashing when setting f.lux in Movie mode only. Tried a reboot, but not disable "automatic brightness" and reboot together.



  • I have this problem too, but only when I enable dark room mode
    My macbook is mid-2010, so it doesn't have auto-brightness feature
    10.11.3 version is installed on it

    And I've found something interesting: it stops flashing when I open flux menu (screenshot)



  • I had / have this problem also. I installed the 36.6, turned on again auto brightness and rebooted (like two days ago).
    I've noticed some flashes from time to time, like for example at booting and if I change the light really really suddenly (i.e. I point my desk light directly to my mac screen, or if I'm in a room and I tilt my computer so the screen looks now somehow to the ceiling lights). Then, it occurs a flashing (just one), so it's is now really unnoticeable.

    I can live with it guys! Thanks for the update!

    PS/ It's also true that movie and dark room mode don't work properly. They flash or beats all the time, but I don't use those modes. I don't use my computer in a dark room (at the moment) and if I have to use the movie mode I use "disable for this app". Anyhow I encourage you to continue working on a solution for those problems and developing this wonderful app. It's great!



  • I confirm what @stek29 says. It stops beating when one opens the flux menu.

    It's incredible how weir sometimes software behaves.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.