Program starts continuously by daytime



  • The last days flux starting suddenly while it's daytime.

    Than I will go to preference and set it again on daytime or shutdown by Quit f.lux. But after a time (10 or 20 minutes) it just jump back on sunset or bedtime colors by day.



  • Same on my machine.

    MacBook Pro (Retina, Mid 2012)
    OSX El Capitan - 10.11.5 (15F34



  • iMac (21.5-inch, medio 2011)
    OSX El Capitan - 10.11.5 (15F34)

    I got so mush trouble yesterday. I reinstalled, but this didn't help. So now I removed the compleet program.



  • I just started having this same problem today. I plan on uninstalling but would love to be informed when this glitch is fixed as I otherwise LOVE f.lux



  • Same on my mid 2011 iMac with latest version of El Capitano. I think it has only happened since the update to 37.2



  • And same here... OSX El Capitan 10.11.5
    Driving me nuts... Even after 'quit' it stil does it.
    As soon as I touch the 'brightness' settings it gets activated, even after quit.

    Kkeus.

    P.S. Otherwise works beautifully, love it!!!


  • f.lux team

    Is everyone with this problem using a Radeon?

    Apple > About this Mac > System Report... > Graphics/Displays

    thanks!



  • @herf I went to the graphics displays and didnt see radeon listed anywhere...



  • I don't see reference to Radion on the display settings either.

    Intel HD Graphics 4000 1536 MB
    MacBook Pro (Retina, Mid 2012)
    OSX El Capitan - 10.11.5 (15F34


  • f.lux team

    thanks - we are looking some more to see if there's a way to get it to happen here.



  • If it helps in any way, I have noticed that flux resets to daytime after my screensaver has been activated.

    MacBookPro8,1
    Intel HD Graphics 3000
    OS X 10.11.5



  • My machine details below:
    iMac (27-inch, Mid 2011)
    2.7 GHz Intel Core i5
    4 GB 1333 MHz DDR3
    AMD Radeon HD 6770M 512 MB

    Yesterday I turned auto brightness off and today have not had problems so far.



  • My system:
    iMac (21.5-inch, Mid 2011)'
    Processor: 2.7 GHz Intel Core i5
    12 GB 1333 MHz DDR3
    AMD Radeon HD 6770M 512 MB

    It keeps reverting to nighttime settings, even after I've tried disabling and even quitting Flux. I tried deleting the Flux color profile but that didn't seem to help.



  • I just saw this message - I've posted about the same issue on my 2012 MacBookPro. It kicks in again just before 8am when it should be on from 9pm (which it also is) to 6am. I'm now convinced it's a bug as I've been using Flux for a year now without trouble.



  • I think this is connected to auto brightness. Daytime, raise the blinds to let in a ton more light and f.lux immediately reacts to turn the screen orange. Going to Sysprefs Displays Color and selecting colorlcd disables it



  • @fergusm I don't think so. I have used Flux for more than a year without problems. When I travel from Europe to Canada (6 time zones) it would remain on European time, because that was the setting. I could then reset it to local time and all was fine. For the past couple of weeks, it's been turning itself on DESPITE the settings being the same. Auto brightness is a separate function, and does not affect the settings on Flux, which are based on clock time.



  • @Susan fair enough I spoke too soon, disabling auto brightness did nothing. But it definitely seems to react to a sudden change in brightness.



  • Same here. I deleted the app and it still happens? Can someone explain how is it that the application still functions even after I delete it? I mean an uninstall should uninstall the program right? Why isn't f.lux being uninstalled? I go to the application folder I find the f.lux app and I move it to the Trash, then I empty the Trash, yet somehow f.lux is still functioning on my Mac?

    Maybe fix that before fixing why the app randomly turns on during daytime, because now I am stuck with the app unless I want a yellow screen 24/7.


  • f.lux team

    I posted here:
    https://justgetflux.com/faq.html?q=10.11.5

    Please make sure you're running 37.3 also (main download from the website). We actually delete our profile files from disk in this one, instead of only asking to switch back to the monitor default profile.



  • When I go to displays - colour - display profiles it fixes the screen for 5 min and then its back on (with the app deleted) and yes I did have the latest version when I uninstalled it. Also there isn't an f.lux display profile (at least none named as such), don't know why it turns on then? I will try restarting, see if that fixes it.

    Edit: Restart seems to have fixed it.



  • This has just started happening on my iMac today as well!! If I go into the f.lux preferences and click on the Sunset and Bedtime buttons (in any order) then the screen goes back to it's normal colour for a few minutes...then back to orange.

    If the screen saver kicks in the that also makes the screen go orange at any time of the day. I also tried uninstalling f.lux but the problem persists so I reinstalled the latest version. Problem still persists.

    I am playing around with the "Energy Saver" settings and increasing those (computer/display sleep) seems to have stopped it for the moment. Will wait and see if it starts again.

    As I typed that it did it again! :-(

    I have been using this for some months now so don't know what caused the problem to start today. Please provide some method to fully uninstall this app and all of it's settings.



  • This problem can be reproduced fairly reliably:

    During the daytime, cover the ambient light sensor (next to the webcam) with your hand. The screen dims. Remove your hand. The screen brightens back up. As it brightens, it tints orange.

    Definitely seems related to the automatic brightness function. Please fix this!


  • f.lux team

    You will probably need to disable automatic brightness for the time being if you want to continue using f.lux. We wish we could fix this but I believe it is in El Cap.



  • Same problem - 9400M late 2008 MacBook.

    Glad I'm not the only one.



  • same issue here. 2012 Retina, El Capitan 10.11.6

    Even when I quit f.lux, after a minute or two the screen turns yellow again (it's daytime). This don't happens all the times but quite frequently. Nothing seem to fix this issue once it starts.


  • f.lux team

    This post is deleted!


  • @herf It's weird to me perhaps because I haven' t figured it out yet - right now I'm running f.lux with auto brightness on and it's fine. I'm at 6500k. It seem to be after a day or so is when it goes haywire and even after quitting, it adjusts to nighttime scheme during the day. That's what it did this morning, then I rebooted and all is well.

    Not doubting your answer at all - clearly you know how this works better than I. Just providing some feedback that it seems to be ok after a fresh reboot for some reason.


  • f.lux team

    This post is deleted!


  • @herf i was wondering the same. I'll pay more attention and report back findings.


  • f.lux team

    I posted a new build (37.5) that is more aggressive again (but shouldn't eat CPU like 36.6).

    Main download at https://justgetflux.com/



  • @herf I'll try the new version.

    Yesterday my Mac came out of sleep during the day and it was in nighttime mode. It would revert via preferences and then go back to nighttime mode after about 10 minutes. I didn't use it until later in the evening and all was well.

    Today, my Mac came out of sleep this AM and the color temp is correct. I went to preferences and clicked 'sunset' and 'daytime' again to verify. Still haven't found a pattern.



  • @herf Hi -

    I haven't had the problem reappear using this version so far. Will report back if I do.


  • f.lux team

    We are pushing 37.5 as an update to 33% of people now.



  • @Become1 said:

    I removed the compleet program

    I removed the compleet program


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.