Quitting fl.ux leaves screen orange



  • Love fl.ux! It's great software. Started noticing a problem recently.

    This is on OSX El Capitan 10.11.5, using my Late-2011 Mackbook Pro.

    Sometimes (not 100% of the time), when I quit fl.ux, the screen will revert to normal colors but only for a few minutes. Then, it switches back to being my reddest setting, even though the fl.ux application is not running. The period of time it takes to switch varies from about 1-4 minutes.

    Seems like a issue- I don't think the color should be altered at all if fl.ux is not running. I exited the application by clicking its icon in the top-right system tray and selecting Quit fl.ux.

    Also, in order to fix the lingering orange-ness, I have to reopen fl.ux. Sometimes, that is enough to kick it back to normal color behavior, but this most recent time, my screen stayed at my reddest setting, even though f.lux thought it was at the bluest. Screenshots attached. When I took these, the screen was very red.

    http://imgur.com/a/dHHxN



  • Update: I realized that this is happening regardless of whether f.lux is open. If I reopen it, open Preferences, click on the slider to the rightmost position, the screen is no longer orange, but only for a few minutes, and I have to do it again.



  • @echoes1313 hmm maybe your color profiles are confused. Go to settings and color and delete your color profiles if you don't have any you'd like to save.



  • @echoes1313 turn off automatic brightness and reboot. That should help as well.



  • I am using Flux 37.2 on OS X 10.11.5 and I have a related if not the same problem, only it's not always when I quit the app. Right now it's just after 9am and as I type this, my screen is acting like it is night. It does work at night as expected, but half an hour after turning the computer on in the morning, it switches to night mode. Turning the computer off and restarting the next day isn't fixing the problem as this has been ongoing for days. Perhaps there should be a "Disable > until sunset" option.

    I quit the app now and brightness has returned normal, but obviously the app won't work now until I restart it or restart the computer. I've now restarted Flux, but who knows how long the sun will be up according to Flux, perhaps an hour?!



  • @Tungsten_smooth I don't know where settings and color profiles are or an automatic brightness setting. I've looked in the Preferences, in the menu bar at the submenus "Options" and "Color effects", and in the OS X system settings. Thanks for your help.



  • I have the same problem since upgrading to f.lux 37.2. I threw away prefs and profiles, disabled 'Automatically adjust brightness' as a workaround, upgraded to 37.3, disabled f.lux itself, rebooted multiple times, but nothing seems to help. Every few minutes or sometimes even seconds my screen turns red/orange :-(((. Only way to solve it is to keep the f.lux prefs open and choose daytime manually. Each and every time it happens....
    Any bright ideas?



  • @Tungsten_smooth
    Tryed this I'll let you know how it goes. But my screen was more Red then orange.



  • @ianonline Go to the Mac system settings and the color section. There you should find a section for color profiles in a tab.



  • @Danny-E Do you know if you have a dual GPU: Intel and Nvidia graphics devices? If so then you can use gfx status. io to lock the machine to use only one device.


  • f.lux team

    Please post the exact kind of Mac you have (Apple menu -> About this Mac)

    Also if you can install https://gfx.io/ and report which video card is exhibiting the issue, that would be a big help.



  • @herf Ive quit the Flux but not Deleted it.Also did what @Tungsten advised .Knocked the automatic brightness off and its worked.
    When I call myself Amateur its because I am an Amateur.
    I've taken a screenshot but dont know how to copy and paste the this .
    Macbook Pro
    ( 15 inch,Mid 2010)
    PROCESSOR 2.4 GHZ CORE i5
    Memory 8GB 1067MHz DDR3
    GRAPHICS INTEL HD GRAPHICS 288MB
    Then the serial Number



  • This is getting really annoying now.
    Here's what I've tried:

    1. Deleted Flux colour profile.
    2. Disabled automatic brightness.
    3. Quit the Flux app.

    None of these actions have stopped the colours switching back and forth between night and day in the middle of the day. I think next I'll do all of the above again, and remove Flux from my login/startups apps before restarting.


  • f.lux team

    @ianonline which machine do you use?

    We are still trying to get this to happen in-house, and it seems to happen mostly on older machines. Most of the time, it is connected to automatic brightness (can get better after a reboot), and occasionally to Radeon GPUs. So any information to help us debug (machine you're using etc.) would help.



  • @herf All appears fine for now after preventing start at login and restarting, and the other three things stated above. I think the night colours in the day time usually seems to only be for the first 30 minutes or so after switching on the computer and this is regardless of the time of day I turn on the computer. At this time of year, the sun is always up when I turn the computer on.

    My computer is a 2012 Macbook Pro running OS X 10.11.5 (El Capitan)
    The display is a 15.4-inch (1440 x 900) screen using Intel HD Graphics 4000 1536 MB
    These are the tech specs of my machine: https://support.apple.com/kb/SP694



  • Hello!

    @herf: I have the exact same problem. When I close the lid of my MacBook for a few minutes and open it again (during daylight time) then the display turns orange even when f.lux is not opened. When I manually change the settings in system preferences in a few minutes the display gets orange again (and f.lux is not running).

    My System:
    MacBook Pro (Retina, 15-inch, Early 2013)
    2,7 GHz Intel Core i7
    Intel HD Graphics 4000 1536 MB

    Eneas



  • @herf Sorry for not replying sooner. My recent extremely annoying f.lux problems were on older machines: an iMac [Radeon HD 6770M 512 MB] and a MacBook Pro [GeForce 9400M 256 MB]. After a day or three of frequent disabling, always having the f.lux prefs open and rebooting the problems have completely gone away however .... Bit hard to say now what did the final trick.
    I'll re-enable the 'automatically adjust brightness' system setting today. I'll let you know if that brings back the problem.


  • f.lux team

    We attempted to fix part of this in 37.3, which is the main download on the site. (If you updated automatically you have 37.2).

    Now, we are actually removing our profile from disk, so there is less chance of the system reloading it. I believe this is not even enough in some cases, and we are still trying to convince 10.11.5 to let us reset the profile to normal.



  • @herf I've just had a system update and am up to 10.11.6. But am loath to start using Flux again .In case it re-starts the redness again. What do you advise. In laymans terms ?
    I'm thinking if its working dont fix it ? as it is now.
    I found it useful as I have Iritis. But am using the manual dimmer now.


  • f.lux team

    As far as I know, turning off automatic brightness (and rebooting) still fixes most problems with f.lux.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.