f.lux darkroom mode flickers?



  • Huge fan of f.lux. Like working in darkroom mode, but it flickers like a slow strobe light. Please advise. Thank you



  • I'm having the same problem. Any solutions?


  • f.lux team

    El Capitain? Which version of f.lux? Does turning off Automatic Brightness Detection help?



  • Same problem here.
    Flux v36.6 on OSX 10.11.3
    Problem appears with Automatic Brightness Detection on or off.
    BTW it stops flickering when i open flux tray icon dialog.



  • Running El Cap 10.11.3, will try turning off automatic brightness this evening.



  • Also running El Capitan 10.11.3 and experiencing this issue. Stops flickering when flux tray is down.



  • Has anyone found a fix for this yet? Using f.lux 36.6 and El Capitan 10.11.3 and have the same issue. Consistent slow flickering in Darkroom mode unless the f.lux tray is open.



  • Have you all rebooted the computer? I keep mine on a lot, but it seems it's common for apple laptops to stay in sleep mode and not reboot. They must have some really great batteries I guess.



  • @Tungsten_smooth Hmm I'll give that a try. I do usually keep my macbook plugged in or in sleep mode--but I had restarted hours before noticing the darkroom issue. I'll give it a try after my class today and report back.



  • @Ben-Adamski @Tungsten_smooth I tried a reboot just now and it almost seemed like it lasted just a few seconds longer without issue but then went right back to the flickering. Any ideas? When I open the f.lux tray it looks like the whole screen a drops a bit in brightness and has no flicker. But the second I don't have tray open it jumps right back to flickering non stop :(



  • I'm running f.lux on a 13" 2015 MBP Retina and after reading these posts I thought I would try Darkroom Mode myself. Wow! I can see why some people would like this. I started using Dark Mode on my Mac as soon as it was available and admit I like dark themes as well.
    Problem is I can't duplicate your problem. I do have "Auotomatically adjust brightness" turned off as I always have preferring to use the keyboard to adjust as required. I have just installed f.lux version 36.6 and no flickering at all?



  • @rodneysprague Ah how I envy you! I have a mid 2012 MBP retina. Automatically adjust brightness turned off. My only thought is that it's in conflict with something else I can't think of--the flickering looks like it's fighting between states, I just don't know with what :/ I hope somebody figures this out. I'm early into my programming boot camp, but I'm tabling this is a side project to come back to whenever i learn something that might be of use to try and debug this issue. I miss my darkroom.



  • Hi Ben, I'm a long term contributor on Mac Forums so I do a lot of troubleshooting and I have found that most problems are eventually solved by a process of elimination.
    If you are convinced that everything else is running as it should then I would suggest that you quit all background applications until only native apps are running and see if the problem continues. If not then you can reintroduce the other apps one at a time until it does. This is a slow process I know but unless you have a system or hardware issue there really is no other way. You are welcome to post your problem on http://www.mac-forums.com/forum.php as well and let the team have a look at your problem



  • Astonishingly, I have only just discovered the wonder that is 'Darkroom Mode,' however I too am experiencing the nearly mind-altering nature of the 30Hz flickering on my 2010 unibody MacBook screen.

    It also ceases when I click on the f.lux icon, so I'm guessing this is a bug in the system.

    Please add me to the list of users very much in search of a solution!

    Thank you so much :)



  • @Aron-Levy Though I will say the 'working late' option picks up a little bit of the slack. Not quite as easy on the eyes however (it is currently 3:09am, and I can't bloody sleep).



  • Seems like I am the only one not experiencing this problem on this forum? Of course we could take the opposite view that nobody else is commenting because you guys are the only ones experiencing the problem. Either way it's something that needs to be fixed.
    Can everyone confirm we are all using the same version and the same platform at least.
    I'm running Mac OS 10.11.4 and version 36.6 of f.lux. on a MacBook Pro Retina 2015 but my wife who has a 2011 MBP IS EXPERIENCING your problem however she does not use Darkroom.



  • @rodneysprague Running 10.11.4 and f.lux v36.6 on a much older machine than yours ;)



  • Yes, same with my wife's machine and after playing with it for a while with no success I think it is a bug. Lets hope the developers are reading this. This is a great app and I hope it will be fully functional soon for all you night owls and dark theme affectionado's.



  • Hi all,

    I just got Dark Room mode working without flicker following instructions in this Sticky Thread, disabling automatic brightness and then rebooting the computer. As a side note, I'm using a three screen setup with integrated retina display and two external monitors.

    I'm running a MBP retina Mid-2012 with El Capitan 10.11.2 and f.lux 36.6.

    I did a test before with gfxCardStatus, for which i've had to disconnect the monitors, and just switching the graphics card mode (with automatic brightness still on) fixed the issue, so if anyone with no external monitors wants to give it a try may solve the problem.

    Hope this helps!



  • @cantax Unfortunately, since my lappy doesn't have automatic brightness control, I don't think this fix will work for me.

    Boo!

    But I'm glad you were able to find a solution! :)



  • @Aron-Levy Mine's working! No guarantees it will work for everybody but here's an as accurate as I can think of recollection of everything I did.

    TL;DR: try PRAM reset and at least a couple reboots.

    I did try turning off the auto brightness off already but just for the lulz I turned it on again, turned it off, rebooted. Still flickering.

    I took @rodneysprague 's advice and tried to debug the issue by just systematically killing processes. I got through almost everything non-essential and was still seeing the issue.

    -rebooted and got everything running back to my normal state of apps and what not.

    -I can't imagine how PRAM would be tied into this at all but figured, what the hell right?

    -Full reboot, pram reset, then tried it and voila!

    I have no idea if PRAM reset worked the magic, or maybe just going through a couple reboots shook the dust out. Either way it's up and running just fine now :)

    Now I just need to switch my dark themes for terminal, atom and the menu bar and dock to light when i turn on the Darkroom mode or they're all a pretty bright white. Whenever I'm capable of such a thing, I'd love to make an Alfred workflow (or something along those lines) that can activate Darkroom, switch my atom to a light theme, my terminal to a light theme, and my OSX menu bar and dock to the light theme so they mesh better with darkroom. I prefer to use darker themes all day, but only the more standard light themes translate well to darkroom. I'm a student developer at the moment but I'd love that to be an outside of work/class project whenever I've attained the knowledge to work on it.



  • please fix this soon! i'm need it alot! thanks!



  • @Ben-Adamski how do i PRAM reset?





  • Disabled Automatically adjust brightness and did a restart and it works great!!
    10.11.4 Beta (15E64a)
    MacBook Pro (13-inch, Mid 2012)
    2.9 GHz Intel Core i7
    8 GB 1600 MHz DDR3
    Intel HD Graphics 4000 1536 MB



  • @Ben-Adamski I was hoping to be able to try both the sticky notes method and the PRAM reset on my wifes MBP but i have not had an opportunity as she always has some app running that cant be quit or in the middle of some project. So asap I will try both and get back with results. Perhaps it's a graphics card issue after all?



  • Just tried above method on my wife's 2011 MBP and it works for hers as well.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.