Fullscreen youtube colour artefacting.



  • The update doesn't seem to have fixed the problem for me. Just tested fullscreen quicktime and fullscreen Netflix in Safari after updating to 36.5. Restarted my computer in hopes it would work, but no luck yet.



  • I have the same issue. The pixelated maxed-out bright spots occur only in fullscreen videos in Safari with no HUD. Evidence here.

    MacBook Pro (Retina, Mid 2012)
    Intel HD Graphics 4000 1536 MB
    OS X El Capitan 10.11.1
    Safari 9.0.1
    f.lux 36.5



  • No fix with the newest version.
    As an addition the problem appears with videos on Kickstarter too.



  • Same issue here:

    MacBook (Retina, 12-inch, Early 2015)
    Intel HD Graphics 5300
    OS X El Capitan 10.11.1
    Safari 9.0.1
    f.lux 36.5

    PS: Specifically, exactly as Logica Ens above described it, i.e.: "The pixelated maxed-out bright spots occur only in fullscreen videos in Safari with no HUD."



  • Same issue as above.
    MacBook Pro (Retina, 13-inch, Late 2013)
    OS X El Capital 10.11.1 (15B42)
    Graphics Intel Iris 1536 MB
    Happens in Safari Version 9.0.1 (11601.2.7.2)
    f.lux 36.5

    Happens in fullscreen videos at bright spots. If I wiggle the mouse and the youtube overlay reappears, the problem then disappears. (So the HUD rendering fixes it)



  • As countless others have said, the bright spots appear only in Safari fullscreen with no HUD rendered. I use Safari's default video player and it happens in that.

    MacBook Pro Retina (13 inch, Early 2015)
    OS X El Capitan 10.11.1
    Intel Iris Graphics 6100
    Using Safari 9.0.1 and f.lux 36.5

    The artefacting happens only when the scaled resolution setting is enabled in System Preferences (the thing that makes the menus etc smaller/bigger)



  • @Michael-Fisher The artefacting happens when the default for display resolution setting is enabled in System Preferences too.



  • Having the exact same problem with;

    • f.lux version 36.6
    • OS X 10.11.2
    • MacBook Pro (13-inch, Mid 2012).

    Problem started right away after installing f.lux. I've only tested it on Safari while playing fullscreen YouTube videos with no HUD rendered, it disappears with mouse movement (and as the HUD appears) and re-appears shortly after. It can't be captured with a screenshot (Command-Shift-3), and it looks exactly as Logica Ens captured above.

    Also, I can't understand why lorna thinks this could be a problem either with the GPU, Intel video drivers or the Intel hardware. I've never seen this happening before f.lux was installed.

    As it seems to happen at different GPUs, OS versions and applications - and only when f.lux is installed; then the only suspect here seems to be f.lux in my humble opinion, and not the opposite. It could be f.lux having a compatibility issue with these suspects, but then shouldn't f.lux be the one trying to solve it...?

    Down below are some additional details about my system if it would help.

    Hardware Overview:

    Model Name: MacBook Pro
    Model Identifier: MacBookPro9,2
    Processor Name: Intel Core i5
    Processor Speed: 2.5 GHz
    Number of Processors: 1
    Total Number of Cores: 2
    L2 Cache (per Core): 256 KB
    L3 Cache: 3 MB
    Memory: 8 GB
    Boot ROM Version: MBP91.00D3.B0C
    SMC Version (system): 2.2f44

    System Software Overview:

    System Version: OS X 10.11.2 (15C50)
    Kernel Version: Darwin 15.2.0
    Boot Volume: Macintosh HD
    Boot Mode: Normal

    Thank you!



  • I believe lorna thinks the problem was already there before f.lux was installed, and that f.lux only exposes the artifacting more.

    I can also confirm that this occurs on Safari, Fullscreen Video, no huds on El Capitan with F.lux version 36.6.

    Graphics Card : Single Intel Iris Pro 1536 MB



  • I have something to add.

    This problem also happens when using a custom calibration preset, in the same conditions (fullscreen, no controls)



  • Guys, I have Macbook Pro Retina 13 bought in November and I have the same problem but I've spotted it only in Safari in Youtube fullscreen when menu bar hides. Videos from other website seems to be okay. I've downloaded youtube app and in this app everything is okay. I think it is the easiest and quickest solution :)



  • I experience this issue on my 2013 MacBook Air, but not on my 2010 MacBook. Both have the same configuration (the 2010 MacBook runs off a clone of the Air's SSD).



  • I see this is a very old issue and I'm still seeing it, El Capitan 10.11.4, Iris Pro 5200. 7 months out, any word on a resolution?




  • There is 1 easy hack to avoid this issue.

    Put the mouse curser onto the youtube / netflix video scroll bar at the bottom of the screen.
    The issue seems to arise due to refresh rate at full screen video in safari.
    Possibly to save battery, safari technology doesnt refresh areas of the screen that have pixels the dont change or similar.
    But when you put the curser over this area, , it does seem to solve the issue .



  • I'm still having the same issue in OS X El Capitan Version 10.11.3



  • @David-Schlachter It seems related to Intel integrated GPUs. Intel/Apple never got around to fixing it on the Intel Mac driver.



  • What @benfowler said works. Which is mystifying... Anyone has any idea why showing the controls would affect the refresh rate or any other aspect of rendering?

    Also @f-lux-team: have you considered open-sourcing this project? Someone who's affected and with some coding chops might be able to give more debug info and maybe even submit a patch?

    Thanks for the great work and for looking into this issue.



  • @shariffy The bug is not in f.lux, it's in the OS video driver. Open-sourcing would do nothing.



  • This is correct. Thanks for the offer though.

    @innerbat said:

    @shariffy The bug is not in f.lux, it's in the OS video driver. Open-sourcing would do nothing.



  • @lorna Fair enough. Just a wild thought as this is both a long-standing issue and affecting quite a few users.

    @innerbat I am aware. That said, I doubt Intel and Apple are falling over themselves to fix the issue. My thought was to research how f.lux could detect when the glitch will happen and (offer to) disable itself in those problematic cases. Research which could be easier with access to the code. But thanks for shooting down a benign suggestion within a minute of posting. :) Here's your sticker.



  • just to give an update: I still have the same problem with OSX 10.11.4, Safari 9.1 and flux 36.6. Btw moving the mouse does prevent the artefacts from happening, but who wants to do that all the time in fullscreen right? ;)



  • @lorna any word from the intel guys on this? thanks!



  • This post is deleted!


  • Hello! I'm having the same problem with artefacting, but in quicktime. If a spot in the video is pure white, and the video is playing with the cursor hidden, then white spots are not tinted, rather pure white. You can see when I start playing the video that the colors brighter on the GIF here.

    MacBook Pro late 2013



  • is anything being done about this or should i just uninstall f.lux?



  • This used to be a deal breaker for me too but the workaround suggested by @benfowler is perfect and currently the most convenient way to avoid the issue.


    There is 1 easy hack to avoid this issue.

    Put the mouse curser onto the youtube / netflix video scroll bar at the bottom of the screen.
    The issue seems to arise due to refresh rate at full screen video in safari.
    Possibly to save battery, safari technology doesnt refresh areas of the screen that have pixels the dont change or similar.
    But when you put the curser over this area, , it does seem to solve the issue .



  • @jonsnow When you do that, you are not really in full screen any more, because the video title appears so does the video timeline scroll bar, taking up 10% of the top and 10% of the bottom and adding distractions.



  • I'm experiencing the same issues with fullscreen YouTube videos, I found if you zoom in (cmd, +) it removes/stops the artifacting so you don't need to keep your curser on the timeline blocking some of the video, it doesn't effect the video just makes the playback elements larger. No idea why this works or if it helps with netflix.



  • I'm on MacBook Air 2015 and have the exact same issue, and I found a simple solution:

    Use Firefox at night.



  • Hi all, it has to be issue in Safari. It appears in videos from various web pages. I can't believe Apple is doing nothing with this....



  • Hey all,
    Definitely not just a Safari issue. Having the same problem and can replicate the results in both Safari and Chrome. Admittedly, I have not tried Firefox.

    Running MBP 13" (Early 2015) with the Intel Iris 6100 chipset.
    Chrome ver. 53.0.2785.46 beta (64-bit)
    Safari ver. 9.1.2 (11601.7.7)
    f.lux ver. 37.3

    I've found that, for some reason, this issue doesn't occur when you crank the display scaling in System Preferences to the highest it will go. (1680x1050 on my set up).



  • AAAAH I'm getting MAD!

    I've never had this problem before on my 15" retina MBP mid 2012, but it got stolen (in a fucking brutal home invasion robbery) and now I have a 13" mid 2015 retina MBP that I got from work and these artifacts are KILLING me.

    Those fucking bastards that stole my computer are now also responsible for all GPU problems in the world and I hope they die. Good news for everyone, they're both in custody so send all your fucking lawyers because these guys are gonna get some software engineering training, and hopefully when they get out they will FIX IT.



  • The problem persists! I am using Safari as well. Maybe I'll just get Firefox and see what happens...

    Safari 9.0.1
    El Capitan 10.11.1
    f.lux 37.2



  • Guys! The problem is not with Safari, it's the f.lux app itself! I don't mean to be rude or anything or like that, but it has to be f.lux's fault for this color artefacting because when I disabled it, YouTube videos in fullscreen mode weren't having that issue anymore. All videos ran fine as they're supposed to.



  • @Joegenius98 FYI, I have the latest 2016 MacBook, but that doesn't matter because I tried out the Macbook Air and Pro at the Apple Store and even played 4k videos on Safari without any problem.



  • I'm experiencing this on Netflix also. OSX 10.11.6. I wonder why it's taking the flux team so long to fix this?



  • @mixolyd I'm assuming they don't see the point in patching until OS Sierra gets its public launch. It is getting ridiculous though. Very annoying



  • To everyone: Apple keeps managing color settings and modifying how something as simple as auto brightness adjusts BRIGHTNESS and starts having it also adjust gamma.

    F.lux uses gamma ramps so that's one part of it. Now Mac OS Sierra reads color profiles differently.

    It's almost as if apple is doing the most annoying shit possible to stop the f.lux team... because they want their own version.

    Night Shift for Mac OS will happen. That's Apple for you.



  • @Tungsten_smooth Thanks for letting us know!



  • @Tungsten_smooth well, that sucks because Night Shift doesn't actually take blue all the way out. I find it unuseable on my iPhone without an attachable blue light filter.



  • @thedouglas How do you know?



  • I discovered a workaround. just download this menu-bar app:

    https://gfx.io

    And set your graphics card to the discrete one when you are doing things in fullscreen - it uses a little more battery, but fixes the artefacting.



  • @Plasma_000 yes that will sometimes help but maybe not for everyone. There is already iOS night shift and they basically told them f.lux team to stop--haven't heard anything else about it after that. Just my 2 cents.



  • @thedouglas I don't think you're right about that. Night Shift works the same way as f.lux. It intercepts colors before they're displayed and removes a certain amount of the blue light from it. Neither app is a simple filter, there are algorithms that determine how much blue to remove from each pixel. If you want Night Shift to take out more blue light, turn its intensity up.



  • @evansimk Yes it works but the default is HORRIBLE and many people will just leave it on default or not use it because it doesn't look right and the settings say nothing about the lighting environment.

    Apple doesn't care and the interface is lazy.



  • @evansimk Night Shift is an extremely gentle copy of a version of f.lux from 2008. It does not remove as much blue light and the default just doesn't do much to help sleep.

    https://fluxometer.com/rainbow/#!id=iPad Pro Night Shift/default
    compared with
    https://fluxometer.com/rainbow/#!id=iPad Pro/1900K-iPad Pro



  • @lorna Is there still no solution to this issue?



  • seems to now be happening with chrome as well.



  • Registered here just because of this phenomenon. It happens to me in Safari and Chrome (haven't tried any other browser). I love flux and would love to be able to use it again.



  • Also registered here to bump up the thread. It's a really annoying issue and needs to be solved ASAP. Or at least give us one straight answer: Are you going to fix this or not? Is anyone working on it or not?


Log in to reply