Fullscreen youtube colour artefacting.



  • @yadrummer It's happening to me as well but I have a macbook pro mid 2012. Intel HD 4000


  • f.lux team

    36.1 doesn't change any of the code - so it is exactly the same. :( We are hopeful to find a good fix or workaround in the future, I know it's annoying.

    Here is a question, can anyone get this to happen on videos that are not HD 1020p?



  • @lorna It still happens for me on videos that aren't HD.


  • f.lux team

    OK thanks everyone, we've been researching this week and the word is that it's almost certainly a problem with the Intel video drivers. We'll file a bug report with the usual suspects. I wish I had better news to report but thank you for all your help with tracking it down.



  • btw it doesn't occur in google chrome fullscreen videos.
    Thank you guys for your great software i use every night..


  • f.lux team

    @yadrummer that's good to know, thank you very much for the info.



  • Same problem here:

    Artefacts in bright places and around the mouse curser when viewing YouTube videos in fullscreen.
    (for the mouse curser problem refer here)

    MacBook Pro (13-inch, Mid 2012): Intel HD Graphics 4000 1024 MB
    OS X Yosemite 10.10.5
    Safari 8.0.8
    f.lux 36.3



  • MacBook Pro (Retina, 13-inch, Late 2013) 10.10.5 Flux 36.3

    Same issue... Just wanted to point out something I found interesting:

    During fullscreen video play, at least on Youtube, If I move the cursor to bring up the interface/HUD (the progress bar, the play/pause button, the title of the video, etc.) the color issues disappear until the HUD goes away, even though I'm still in fullscreen video mode.

    Also, changing the resolution to 1680x1050 as fluxxor suggested seems to work. Thanks!



  • "During fullscreen video play, at least on Youtube, If I move the cursor to bring up the interface/HUD (the progress bar, the play/pause button, the title of the video, etc.) the color issues disappear until the HUD goes away, even though I'm still in fullscreen video mode."

    Yes, I can confirm that.


  • f.lux team

    Thanks all - we've reported the bug to the right people and they're trying to repro now.



  • @lorna any updates to this issue?



  • Also experiencing this issue with Intel Graphics at all resolutions on Retina MBP. Looks like you filed your bug report 3 weeks ago. Any promising leads?


  • f.lux team

    No updates yet, I wish I had better news, I know this is frustrating.



  • I was just watching a video in full screen on Netflix (using Safari) where pure whites become blue as soon as the playback controls disappear. I have the same problem in Quicktime (which has prompted me to stop using it) but not in VLC.

    When I turned off f.lux, the issue disappeared. The thing is, I don't experience the problem until f.lux reaches a certain "temperature".

    I'm using an early 2015 13" MacBook Pro (Intel Iris Graphics 6100) with Flux 36.3. The most recent example is in Safari 9 in OS X 10.11 El Capitan.



  • Just checking in with the same problem I'm afraid. Understand you are working on a fix.

    13" MacBook Pro early 2015
    OSX 10.10.5 Yosemite
    Safari 8.0.8
    f.lux 36.3

    Thanks!



  • I've been having this problem since I've had this laptop as well. Same symptoms as everybody else-only fullscreen, doesn't happen when hud is visible, safari but not chrome.

    I wonder if it's a quicktime thing--this issue happens in standalone quicktime as well, but not other programs like vlc or mplayerx, and also only in fullscreen and when the hud is not visible.

    MacBook Air 2015
    OS X El Capitan
    f.lux 36.3



  • Would like to give a heads-up and also looking forward to hear an update (especially back from Intel!). Just noticed this bug a few days ago. Exactly the same experience as above. Reproducible with white videos on Safari, but not on Chrome.

    Macbook Pro mid 2014
    OS X 10.10.5
    Safari 9.0
    Flux 36.3



  • Same problem here.

    When playing fullscreen video in iTunes I can make the artefacts disappear by moving the cursor, this will make the video controls appear (still fullscreen), when I stop moving the cursor, as soon as the video controls disappear the artefacts are back.

    Flux 36.4
    OSX 10.11 (15A284)
    MacBook Pro (Retina, 13-inch, Late 2013)
    Intel Iris 1536 MB



  • @lorna It's been two months now since you guys reported this issue. Any kind of update yet? It's not just youtube. It's all fullscreen video.



  • Made this post some days ago https://justgetflux.com/forum/topic/416/f-lux-glitching-youtube-in-safari ,didn't found the current post earlier.

    Been experiencing it since OSX 10.11 too.

    Just with Safari, Chrome works fine.



  • Happened with Netflix too last night. :( Please fix this.



  • Seems it has been fixed since the new update. Thank you!



  • The update doesn't seem to have fixed the problem for me. Just tested fullscreen quicktime and fullscreen Netflix in Safari after updating to 36.5. Restarted my computer in hopes it would work, but no luck yet.



  • I have the same issue. The pixelated maxed-out bright spots occur only in fullscreen videos in Safari with no HUD. Evidence here.

    MacBook Pro (Retina, Mid 2012)
    Intel HD Graphics 4000 1536 MB
    OS X El Capitan 10.11.1
    Safari 9.0.1
    f.lux 36.5



  • No fix with the newest version.
    As an addition the problem appears with videos on Kickstarter too.



  • Same issue here:

    MacBook (Retina, 12-inch, Early 2015)
    Intel HD Graphics 5300
    OS X El Capitan 10.11.1
    Safari 9.0.1
    f.lux 36.5

    PS: Specifically, exactly as Logica Ens above described it, i.e.: "The pixelated maxed-out bright spots occur only in fullscreen videos in Safari with no HUD."



  • Same issue as above.
    MacBook Pro (Retina, 13-inch, Late 2013)
    OS X El Capital 10.11.1 (15B42)
    Graphics Intel Iris 1536 MB
    Happens in Safari Version 9.0.1 (11601.2.7.2)
    f.lux 36.5

    Happens in fullscreen videos at bright spots. If I wiggle the mouse and the youtube overlay reappears, the problem then disappears. (So the HUD rendering fixes it)



  • As countless others have said, the bright spots appear only in Safari fullscreen with no HUD rendered. I use Safari's default video player and it happens in that.

    MacBook Pro Retina (13 inch, Early 2015)
    OS X El Capitan 10.11.1
    Intel Iris Graphics 6100
    Using Safari 9.0.1 and f.lux 36.5

    The artefacting happens only when the scaled resolution setting is enabled in System Preferences (the thing that makes the menus etc smaller/bigger)



  • @Michael-Fisher The artefacting happens when the default for display resolution setting is enabled in System Preferences too.



  • Having the exact same problem with;

    • f.lux version 36.6
    • OS X 10.11.2
    • MacBook Pro (13-inch, Mid 2012).

    Problem started right away after installing f.lux. I've only tested it on Safari while playing fullscreen YouTube videos with no HUD rendered, it disappears with mouse movement (and as the HUD appears) and re-appears shortly after. It can't be captured with a screenshot (Command-Shift-3), and it looks exactly as Logica Ens captured above.

    Also, I can't understand why lorna thinks this could be a problem either with the GPU, Intel video drivers or the Intel hardware. I've never seen this happening before f.lux was installed.

    As it seems to happen at different GPUs, OS versions and applications - and only when f.lux is installed; then the only suspect here seems to be f.lux in my humble opinion, and not the opposite. It could be f.lux having a compatibility issue with these suspects, but then shouldn't f.lux be the one trying to solve it...?

    Down below are some additional details about my system if it would help.

    Hardware Overview:

    Model Name: MacBook Pro
    Model Identifier: MacBookPro9,2
    Processor Name: Intel Core i5
    Processor Speed: 2.5 GHz
    Number of Processors: 1
    Total Number of Cores: 2
    L2 Cache (per Core): 256 KB
    L3 Cache: 3 MB
    Memory: 8 GB
    Boot ROM Version: MBP91.00D3.B0C
    SMC Version (system): 2.2f44

    System Software Overview:

    System Version: OS X 10.11.2 (15C50)
    Kernel Version: Darwin 15.2.0
    Boot Volume: Macintosh HD
    Boot Mode: Normal

    Thank you!



  • I believe lorna thinks the problem was already there before f.lux was installed, and that f.lux only exposes the artifacting more.

    I can also confirm that this occurs on Safari, Fullscreen Video, no huds on El Capitan with F.lux version 36.6.

    Graphics Card : Single Intel Iris Pro 1536 MB



  • I have something to add.

    This problem also happens when using a custom calibration preset, in the same conditions (fullscreen, no controls)



  • Guys, I have Macbook Pro Retina 13 bought in November and I have the same problem but I've spotted it only in Safari in Youtube fullscreen when menu bar hides. Videos from other website seems to be okay. I've downloaded youtube app and in this app everything is okay. I think it is the easiest and quickest solution :)



  • I experience this issue on my 2013 MacBook Air, but not on my 2010 MacBook. Both have the same configuration (the 2010 MacBook runs off a clone of the Air's SSD).



  • I see this is a very old issue and I'm still seeing it, El Capitan 10.11.4, Iris Pro 5200. 7 months out, any word on a resolution?




  • There is 1 easy hack to avoid this issue.

    Put the mouse curser onto the youtube / netflix video scroll bar at the bottom of the screen.
    The issue seems to arise due to refresh rate at full screen video in safari.
    Possibly to save battery, safari technology doesnt refresh areas of the screen that have pixels the dont change or similar.
    But when you put the curser over this area, , it does seem to solve the issue .



  • I'm still having the same issue in OS X El Capitan Version 10.11.3



  • @David-Schlachter It seems related to Intel integrated GPUs. Intel/Apple never got around to fixing it on the Intel Mac driver.



  • What @benfowler said works. Which is mystifying... Anyone has any idea why showing the controls would affect the refresh rate or any other aspect of rendering?

    Also @f-lux-team: have you considered open-sourcing this project? Someone who's affected and with some coding chops might be able to give more debug info and maybe even submit a patch?

    Thanks for the great work and for looking into this issue.



  • @shariffy The bug is not in f.lux, it's in the OS video driver. Open-sourcing would do nothing.


  • f.lux team

    This is correct. Thanks for the offer though.

    @innerbat said:

    @shariffy The bug is not in f.lux, it's in the OS video driver. Open-sourcing would do nothing.



  • @lorna Fair enough. Just a wild thought as this is both a long-standing issue and affecting quite a few users.

    @innerbat I am aware. That said, I doubt Intel and Apple are falling over themselves to fix the issue. My thought was to research how f.lux could detect when the glitch will happen and (offer to) disable itself in those problematic cases. Research which could be easier with access to the code. But thanks for shooting down a benign suggestion within a minute of posting. :) Here's your sticker.



  • just to give an update: I still have the same problem with OSX 10.11.4, Safari 9.1 and flux 36.6. Btw moving the mouse does prevent the artefacts from happening, but who wants to do that all the time in fullscreen right? ;)



  • @lorna any word from the intel guys on this? thanks!



  • This post is deleted!


  • Hello! I'm having the same problem with artefacting, but in quicktime. If a spot in the video is pure white, and the video is playing with the cursor hidden, then white spots are not tinted, rather pure white. You can see when I start playing the video that the colors brighter on the GIF here.

    MacBook Pro late 2013



  • is anything being done about this or should i just uninstall f.lux?



  • This used to be a deal breaker for me too but the workaround suggested by @benfowler is perfect and currently the most convenient way to avoid the issue.


    There is 1 easy hack to avoid this issue.

    Put the mouse curser onto the youtube / netflix video scroll bar at the bottom of the screen.
    The issue seems to arise due to refresh rate at full screen video in safari.
    Possibly to save battery, safari technology doesnt refresh areas of the screen that have pixels the dont change or similar.
    But when you put the curser over this area, , it does seem to solve the issue .



  • @jonsnow When you do that, you are not really in full screen any more, because the video title appears so does the video timeline scroll bar, taking up 10% of the top and 10% of the bottom and adding distractions.



  • I'm experiencing the same issues with fullscreen YouTube videos, I found if you zoom in (cmd, +) it removes/stops the artifacting so you don't need to keep your curser on the timeline blocking some of the video, it doesn't effect the video just makes the playback elements larger. No idea why this works or if it helps with netflix.