UI f.lux won't hide



  • Hi guys,

    I love f.lux, but every time my pc starts up, the f.lux program pops up in the lower right corner and only goes away when I click the X. I have set my location and checked all the other settings but I can't get it to not pop up every time windows (8.1) boots up.

    Does anyone knows how I can solve this?

    Best regards,

    Danny



  • Hi, Danny!

    Yeah, it's definitely not supposed to be doing that. I only used Windows 8.1 for a couple of weeks, and I only used the Desktop side that entire time and I heavily customized it to be exactly like Windows 7. So, the first thing that I'm going to ask about may or may not apply.

    Is f.lux in the Startup folder in the Start Menu? If so, then delete it from that Start Menu folder and that should solve it.

    If that wasn't the problem, then we need to make a small change in the Registry. Never fear, this is easy and harmless because I know what needs to be done and all you have to do is follow the instructions. ;)

    First, open Registry Editor. The easiest way to open it is by just pressing the Windows Key on your keyboard and typing either registry editor or regedit and then pressing Enter.

    Once Registry Editor is open, navigate to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run (you'll be drilling down more and more and more in the tree structure until you get to the key named "Run")

    Once you're at this Run key, doubly make sure it is selected. Then, look over on the right side for "f.lux". A little bit to the right of where it says "f.lux" (in the "Data" column), you should see something similar to this:

    "C:\Users\Dynamix\AppData\Local\FluxSoftware\Flux\flux.exe" /noshow (where I put "Dynamix", you will see your Windows user name)

    The quotes need to be there as well. The most important part here though is "/noshow". If that's not there, then that explains why the UI isn't hiding. However, if it IS there, then stop reading right here and let me know now (I mean, just disregard the rest of this post and post a reply now). Tell me exactly what you see too. Otherwise, if it's not there, then continue with the rest of my post.

    Ok, so if it's not there, then you just need to add it and then the problem will be fixed. To do that, double-click "f.lux" and then put your cursor at the END of "C:\Users\Dynamix\AppData\Local\FluxSoftware\Flux\flux.exe". Add a space at the end after the quotation mark and then type /noshow and press Enter. When you're done, it should then match this perfectly:

    "C:\Users\Dynamix\AppData\Local\FluxSoftware\Flux\flux.exe" /noshow (with the possible exception of "Dynamix" hehe)

    That's all there is to it! So now close Registry Editor and restart Windows.

    If we fixed it, then disregard the rest of this post and post a reply now to let me know! :)

    However, if this didn't work, then the next thing that I would recommend is uninstalling f.lux and then reinstalling it. If you need any help with that, then I will provide that help right now just to save time: to uninstall it, open the Programs and Features control panel (you can just press the Windows Key and type programs and features and press Enter), and then double-click "f.lux" in the list of installed programs. The rest should be self-explanatory from there. You won't need to exit f.lux first.

    Then to install it, you can either find the downloaded installer from when you last downloaded it ("flux-setup.exe"), or just download a new one. If you still have the installer but it has been several months or more since you downloaded it, then download a new one because perhaps the problem was that your version was outdated. I don't know if that would cause this problem, but you never know.

    Once it is installed and you've configured it exactly the way you like it and you've set your location, restart Windows and see what happens.

    If after all of this the UI still doesn't hide, then we will keep at this until we figure it out.



  • Huh. Well, that's strange! I know it may seem a bit odd, but try setting your location again. Maybe it will know you have set it this time, and go away. I just can't really understand why it wouldn't hide, maybe it's a one off thing.



  • @TwoCables

    Thx for the reply.

    I got to "C:\Users\Danny\AppData\Local\FluxSoftware\Flux\flux.exe" /noshow

    So that doesn't seem to be the problem. Any other idea what might cause it?


  • f.lux team

    A few ideas:

    1. If f.lux thinks your location is not set, it will flash a tiny triangle on the main screen. I learned that nobody ever sees this, but it might provide a clue if you look for it. (This is just in case setting your location didn't work.)

    2. Check if you have software that manages which programs start on reboot - we have noticed Samsung doing this on some laptops. I imagine any programs like this could remove the /noshow flag and give what you're seeing. You could run procmon (https://technet.microsoft.com/en-us/library/bb896645.aspx) and see which app was responsible for starting f.lux on reboot.

    3. Uninstall + Reinstall and see if the /noshow fixes itself.



  • @herf

    I reinstalled it, but nothing has changed about the situation. The triangle stopped flashing after I put in my location again (after reinstalling), but still it pops up.

    I installed procmon, but I don't really know what to look for. The only thing I can see regarding flux is that explorer.exe opened flux at startup. Any suggestions?


  • f.lux team

    Sorry I appear to have flubbed that - meant to say Process Explorer not ProcMon:
    https://technet.microsoft.com/en-us/sysinternals/bb896653.aspx

    If you double-click on flux.exe in ProcExp what does it say the "Command line" was? And the Autostart location?



  • @herf

    Command line:
    "C:\Users\Danny\AppData\Local\FluxSoftware\Flux\flux.exe" /noshow

    Autostart:
    n/a


  • f.lux team

    One more idea: the other way this could happen is if the app is launched twice on startup.

    We made it so when you run f.lux from the Start menu, it would show the app. This way, users who were confused about where the icon was wouldn't have so much trouble.

    But, if it was somehow set to start twice (say in "Startup" group for All Users and "Startup" for a particular one, or the registry), something like this might happen.

    But there isn't a good reason why flux.exe /noshow with location set properly should show the window otherwise.



  • @herf

    That solved it, finally!

    I 'deleted' flux from the start up menu and now the UI is gone after rebooting, but flux is running.

    Merci bien.



  • I guess my post was too long. At the very beginning of it, I recommended that you do exactly this. I apologize for not making it clearer. I guess I have to work on my quality of service on here.



  • @TwoCables

    That's fine. I assumed that I could follow your advice to do so, but then again flux wouldn't start up at all, which would create even more of a hassle. Thanks anyway.



  • @Dynamix said:

    @TwoCables

    That's fine. I assumed that I could follow your advice to do so, but then again flux wouldn't start up at all, which would create even more of a hassle. Thanks anyway.

    But I said that deleting it from there should solve it (which it did). You're welcome though. I'm glad that you're no longer having to deal with this irritating problem.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.