High battery drain on Windows 11



  • Hi!

    I was using my laptop yesterday, with Windows 11 installed on it, and I've noticed that the battery was going down really fast. As per the screenshot attached.

    Did someone experience similar issues with the app? And if yes, is there a known fix to that issue?![0_1631119793634_Screenshot 2021-09-08 184939.png](Uploading 100%)





  • Since I'm allowed to edit only for 10 minutes after posting, one additional piece of information - f.lux is constantly eating 6% of the CPU load.



  • hmmmm....

    can you post f.lux options > driver info?

    Also do you have "disable by app" or "disable for fullscreen apps" enabled?



  • Intel Corporation 30.0.100.9686: Intel(R) UHD Graphics 630 (20210811)
    NVIDIA 30.0.14.7196: NVIDIA GeForce GTX 1650 (20210827)

    Unlimited gamma ramp=1, Internal ramp=0
    Monitor 1 on Intel(R) UHD Graphics 630
    Has VCGT profile=0, Gamma Ramp works=1
    Monitor 2 on Intel(R) UHD Graphics 630
    Has VCGT profile=0, Gamma Ramp works=1

    Windows Build: 22000.176


    I don't have any "disable" rules. For a moment I thought that it might be connected with the Philips Hue integration that I have, but disabling that one didn't change anything - still getting a constant 6% CPU usage. I'm on Dell XPS 7590, with Intel i9, so 6% is quite a lot (that would explain the battery drain)



  • Can you restart f.lux after disabling Hue? We rely on the Windows UPnP API for Hue, and it may still be running.



  • I did what you've asked for - after disabling Hue integration I've restarted the app with no change. I've restarted the entire PC with no change. Still getting a strange CPU usage.



  • @herf - I've got a second laptop as well that I didn't disconnect from the power source for a long time (hence I didn't notice the battery drain), it's a ThinkPad P15s with i7, Windows 11 as well, and it's the same thing - I get constant 12% CPU usage. Therefore it leads me to the conclusion that it's not an isolated issue to my Dell laptop or a specific Windows installation.

    The same driver info:

    Intel Corporation 27.20.100.9749: Intel(R) UHD Graphics (20210624)
    NVIDIA 30.0.14.7141: NVIDIA Quadro P520 (20210712)

    Unlimited gamma ramp=1, Internal ramp=0
    Monitor 1 on Intel(R) UHD Graphics
    Has VCGT profile=0, Gamma Ramp works=1
    Monitor 2 on Intel(R) UHD Graphics
    Has VCGT profile=0, Gamma Ramp works=1

    Windows Build: 22000.176



  • Thanks - we are getting an extra disk so we can boot it soon.

    All my "test machines" are apparently too old to boot Win 11...



  • Okay so I am on 22000.184 (newer) with extremely low CPU usage....same Intel driver version - but no NVIDIA. So that leaves several possibilities:

    1. it's already fixed in .184
    2. it's nvidia-related
    3. it's multiple monitor related

    If you can triage, it would be great: update to .184, and try unplugging one monitor. Otherwise we should suspect the NVIDIA/hybrid?



  • Hi,

    • The original issue (the one that inspired me to write this post) occurred during usage of the unplugged laptop (single screen)
    • I've updated the Windows build to the newest one, no change. The CPU usage is still on the same level (currently 8% ish on the P15s)
    • I've unplugged the screens, without any change in the CPU behavior
    • I've defaulted for now to the native Windows "night light" and it's working fine, with no higher CPU usage

    Therefore it looks like:

    • It's not Windows build related
    • It's not multiple monitors related

    I do wonder if there's a way to disable the Nvidia graphic card in the BIOS of my XPS - couldn't find it.



  • Hey @herf - so what do we do now? :) I really miss my f.lux Hue integration :( Do you think you can get access to a similar laptop that I have?

    Not sure where you're from, but in the worst case scenario you can probably buy something over the internet, and return it if a store has 2 week return policy or something. Thinking about the options.



  • Can you run a "performance test" from f.lux options? Curious if it shows up here.



    • After the test popup shows "Average: 59.8 FPS. Worst=31.3 FPS. Missed 60hz: 0%, Missed 30hz 0%"
    • During the test the CPU usage of flux.exe went up from 6% to 8%
    • What is really strange for me, is that even after selecting "disable until sunrise" the CPU usage is still at a 6% level

    What's there under the hood, the C++ or C#? Maybe there's some different runtime being delivered together with windows 11?



  • Well it is working on my Intel Xe fine, so hmm. We are C++ (old-school win32) under the hood.

    If you can run process explorer, there is a view of "Threads" for each process. Will move to email....

    https://docs.microsoft.com/en-us/sysinternals/downloads/process-explorer



  • @herf - before we'll dig deeper, I've done something crazy, just reinstalled the app. For now looks like the CPU usage issue is gone on both of the laptops (after reinstallation and restart).

    o_O

    I'll be observing the situation for the next 2 days, and I'll let you know.

    Current machines were updated from Windows 10 to Windows 11, with f.lux being already installed on the Win 10. Maybe there's something that is causing troubles related to the update (the same issue occurred on 2 different machines).


Log in to reply