Issues with Gamma and F.lux



  • Windows 7
    GTX 970 Video Card, latest drivers

    I saw a few other posts on this forum about this but no good solutions yet. I've been using f.lux for years and love it so I hope this can get resolved. I switched from an AMD card to a Nvidia card and I immediently noticed that my screen was looking a bit washed out (I did not have this problem on the old video card). I tried adjusting the gamma, brightness, and contrast settings but they would revert 1-2 seconds after making them. I did some process of elimination testing and figured f.lux was the issue. What I've found out so far:

    -I can only adjust color settings when f.lux is completly exited, disabling it won't work
    -As soon as I restart f.lux any color changes I have made (either in Windows or the Nvidia control panel) are immediently reverted and the screen becomes whitewashed again.

    Any suggestions on how to correct this?

    Thanks!

    Edit: I fixed it! editing in the fix here for searches in the future. Note: I'm on Win7 but I believe this should work for Vista and 10 as well.

    If you go to \Windows\System32\spool\drivers\color there are a bunch of default color configurations. The two you need to worry about are the .icm files (there many be additional color profiles in there as well from other calibrations. I moved them all to a backup location). I assume they are named the same for everyone, but mine were named "sRGB Color Space Profile.icm" and "RSWOP.icm". Edit: I've since learned these files are for printing, I don't know why moving them worked for me but if you remove them and your print jobs get messed up this could be the cause. These are the files that f.lux reads from as far as I can tell, which is why importing or creating new profiles doesn't work, these are the files that need to be changed.

    I created another folder in that folder, \color\backup, and moved these two files there. Now these are core Windows files so buyer beware (I recommend backing them up instead of deleting them), but as far as I can tell there are no negative effects. In order to do this you have to change the file permissions, they are owned by "TrustedInstaller".

    -Right click -> Properties -> Security -> Advanced -> Owner -> Edit -> set it to yourself.
    -Under the Security tab click Edit, you should now have permissions to change these other permissions. Click on Administrators and give them modify and write access.
    -Apply, you can now move the files safely to the backup location.

    With these profiles gone, f.lux can't read from them anymore. To make sure that f.lux and Windows are using the color profile you want do this:

    -Copy the .icm profile you want to use to this folder, either one you have downloaded or created via Windows color calibration. If you calibrated your monitors earlier there should already be that calibration file in this directory.
    -Right click on the desktop -> Screen Resolution -> Right click on any monitor -> Properties -> Color Management -> Color Management -> Advanced -> Change System Defaults
    -In the Devices tab make sure there are no other profiles click Add -> Browse and find the color profile you moved to the \color directory.
    -Set this profile as default for all monitors (you can have different calibrations for different monitors if you like)
    -Close that window and go to the Devices tab in the other Color Management window and make sure the profile you want is the only one there and is set to default.
    -Close everything out and start f.lux. With only one color profile to read from it selects that and keeps all your settings!



  • Yeah, I have this issue as well, it's not f.lux, it's Nvidia. I don't know WTF the deal is with the color range. Before, you could at least change it from RGB to YCB444 or whatever it's called, and that helped a bit. The problem is that even when I use the tweaks available online to force the RGB color range to full, things still seem a bit faded looking.

    I've tried this but when I use the program, even when I set it to limited, reboot, and then go back again, and set it to full, I do not notice a difference. You can try it, but maybe you should complain to Nvidia, look at the post date!

    As a workaround, I set my monitor to use the Limited RGB which is called 16-235, which is a good name for it.



  • Hrm I'm not sure that is whats happening with me. When my computer boots up the colors are fine before the white washing happens, and if i disable f.lux the colors look fine and can be adjusted. Nvidia is certainly messing with something here and it might be on their end ultimaly but my problem sounds different than the one described. Thanks for the information though!



  • Don't know how you missed that, but the other two top forum entries are about the exact same problem. It isn't limited to Nvidia cards (happens to mewith a Radeon), and also not limited to a single OS version (although most reports seem to be for Win7 64-bit).
    Luckily because of another annoyance of flux (you can't set an install path and it installs itself into your appdata folder instead of somewhere in the programs folder) I had a very old version in my user files backup. It's so old it doesn't even show it's version anywhere (fildate is 2009), but at least it does not have that problem.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.