FIX for problems with the Windows 10 May update (1903/18362)

  • Problems with the Windows 10 May update (1903) are related to "Fast Startup"

    Build 18362.207 fixes this. Please update.

    f.lux was automatically working around this bug, however screenshots will be tinted, and some dimming features and fullscreen effects will not work.

  • After trying these steps, I'm still unable to properly use f.lux. I'm attaching pictures. You can see there's no tinted screenshot even with f.lux "active".

    f.lux v4.105

    1_1560379729411_Untitled.png 0_1560379729411_2.png

  • Are you running in HDR mode or using a 10-bit monitor?

  • @herf No, standard dynamic range 8-bit monitor.

  • Seems like the Disabling Fast Startup fixed it for me.

  • still, have this problem...

  • Just sign out user and sign in, no need to restart

  • @hallow I tried with no luck. Do you guys think it may have something to do with AMD Drives?

  • I can't use the "disable for fullscreen apps" since the may update.

    NVIDIA NVIDIA GeForce GTX 1070 (20190522)

    PnP-Monitor (Standard), 528 x 297mm, built 2017
    R=0.653320 0.334961
    G=0.323242 0.611328
    B=0.153320 0.061523
    W=0.313477 0.329102

    sRGB gamut: 93%, AdobeRGB gamut: 65%

    PnP-Monitor (Standard), 510 x 287mm, built 2013
    R=0.660156 0.330078
    G=0.294922 0.615234
    B=0.139648 0.049805
    W=0.313477 0.329102

    sRGB gamut: 100%, AdobeRGB gamut: 71%

    Windows Build: 18362.175

  • What I have figured, using @hallow's tip is that if I turn on the monitor after logging in, flux starts working.
    It works either when turning on the computer and when I sign out and then sign back in with the monitor turned off.

  • I've tried both disabling Fast Startup and rebooting after starting my laptop, and in neither case will it disable for certain apps. I can manually disable it for an hour and that's it.

  • hi,

    i'm on the latest updates (as of 27.06) - the ones that should have solve the issue.. - but it ain't gone. radeon vii + lg 34gk950f. only fix is turning on and off hdr to restore color profile. plus, hdr doesn't show any monitor color profile.

  • when i play cs go in fullcreen , the game run like it is in windowed mode, which is bad for performance

  • How does f.lux fix tinting?

    I think I may have missed a Windows 10 update as well (or maybe not?...)

    In any case I failed the stress test built in to f.lux.

    Thank you for the perfect software!


  • F.lux still isn't working. I disabled fast startup and nothing.
    Please advise on how to get this to work.
    my eyeballs are killing me!!!!

  • @gras68 post your driver info (f.lux options > driver info) here and we'll see what's up.

  • @gras68 said in FIX for problems with the Windows 10 May update (1903/18362):

    F.lux still isn't working. I disabled fast startup and nothing.
    Please advise on how to get this to work.
    my eyeballs are killing me!!!!

    I have the same issue! Just updated windows earlier today. Driver details are as follows:

  • @herf Updated windows earlier today - f.lux was working well before update. Fast Startup is disabled. Driver details are as follows:

  • @sm1286 thank you, basically all of the failures right now are "Vega 8" - I am not sure yet what is going on.

  • This is probably an issue with Windows Night Light. Nothing to do with graphics card or anything broken in your computer. After poking around, I did this:

    1. uninstall f.lux -- no change
    2. Discovered in Windows > System > Display -- Night Light set to OFF (which I had set so as not to conflict with f.lux).
    3. Changed Night Light to ON. Colors normalized to daylight (I did this around noon today).
    4. Clicked Night Light Settings and found this was at about 90% strength!!!
    5. So for some reason, after 1903 update Windows was using 90% strength Night Light for and in daylight! Hence the gross pink for orange and muddy-tern for both green and blue.
    6. Now my issue was, with Night Light reset to ON, I had true daylight color, presumably as long as daylight lasts. But what if I prefer f.lux to Windows Night Light? Will it go back to remaining stable if I set it back to OFF?
    7. Yes, it did. And so far, after reinstalling f.lux, they're playing nicely together again.
    8. If the issue pops up again I plan to check Night Light. If all else fails, set Night Light's make sure its "power" is no more than 50%, preferably zero.
      Hope this helps some.

  • @herf Hi, another Ryzen 3 2200G user here. Found this thread and can confirm f.lux has stopped working after the 1903 update. None of the "Effects and Extra colors" work except the Vignette setting that darkens the corners. If I can provide any other information please let me know, want to help find a solution to this as soon as possible, thanks!

  • @rorix Same issue with me, check my thread for some info maybe it can help

  • @abhimahant Here's what's worked for me after all this trying.

    1. Uninstalled the drives.
    2. Uninstalled display monitor from device manager.
    3. Restart graphics driver using custom resolution utility.
    4. Finally installed drivers again but with windows not amd.
    5. Although the version of my drivers is old now. But i will update my drivers and see what happens.
      I cant confirm if 2nd step is important or not, your wish I guess.

  • Thank you so much for the information you have provided.I do admire the effort and consider this as a great help.

  • Help! I've read through both of the threads regarding errors with the recent updates. This program has helped so much with my migraines - I Need it!
    I have uninstalled and reinstalled f.lux after each attempt. I have uninstalled and reinstalled my display adapters. I have disabled fast start up. Tried adjusting display properties.
    Here's my driver info:

    Advanced Micro Devices, Inc. 15.201.1151.1008: AMD Radeon HD 5450 (20151104)
    Intel Corporation Intel(R) HD Graphics (20151221)

    AOC e2252V , 477 x 268mm, built 2013
    R=0.647461 0.333984
    G=0.284180 0.607422
    B=0.151367 0.071289
    W=0.312500 0.329102

    sRGB gamut: 100%, AdobeRGB gamut: 69%

    Windows Build: 18362

  • @jh211707 these are older drivers - are you able to try updating them?

  • I have the same problem since updating my CPU to a Ryzen 3 3200g, also updating from windoiw 7 to 10, I hope a solution is found

    Advanced Micro Devices, Inc. 26.20.13001.25001: AMD Radeon (TM) Vega 8 Graphics (20190730)

    Generic PnP Monitor, 410 x 230mm, built 2009
       R = 0.648438 0.338867
       G = 0.291992 0.602539
       B = 0.142578 0.070313
       W = 0.313477 0.329102

    sRGB gamut: 93%, AdobeRGB gamut: 63%

    Windows Build: 18362

  • @herf I've been using the latest Adrenalin 19.7.5 beta drivers from July 30 to no avail. There are no newer drivers than that.

    Advanced Micro Devices, Inc. 26.20.13001.25001: AMD Radeon(TM) Vega 8 Graphics (20190730)

    HP 23xi IPS LED Backlit Monitor, 509 x 286mm, built 2014
    R=0.635742 0.333984
    G=0.308594 0.623047
    B=0.150391 0.067383
    W=0.313477 0.329102

    sRGB gamut: 100%, AdobeRGB gamut: 69%

    Windows Build: 18362

  • @herf In checking for updates, there are none. Updating is what caused my issue. If there is another way to do this, I don't know how other than to manually do it in the Device Manager, but I am new to this. What [drivers] do I need to choose to force an update?

  • @herf I attempted to manually update both display adapters, but both said they had the newest update available. Same with my monitors.

  • UPDATE: The newest windows update has a bug that disables f.lux and all programs like it, including the windows built in Night Light. I recovered to a previous version to wait it out until the bug is fixed.

  • @jh211707 we think this problem was fixed in 18362.207 and later, so the remaining issues are due to graphics drivers.

  • The issues with the Vega 8 persist on 18362.267

  • Hello

    We are having the exact same problem.

    We have been using F.Lux fine and testing this with a view to purchasing licencing for our organisation. We have a lot of users that would benefit from this using multiple screens. We use a multitude of different devices, graphics cards and drivers. I can tell you clearly that none of them matter as this has stopped working for all users since we patched to 1903. We have troubleshooted extensively so it is either Windows that has disabled it or something needs updating in your code and patching.

    Its disappointing that we have had to stop testing this and maybe hold off purchasing licences for our users because of this bug. Please could you investigate and fix it.


    We are all running Windows 10 1903 Build: 18362.267.

  • Not working for me as well. Since I updated the OS today. Going to try updating my drivers for NVIDIA.

  • I've tried everything suggested with no luck. Flux only seems to work on my laptop screen but not on either of my external monitors.


  • Our 4.106 beta should partially fix older DisplayLink adapters that were not changing at all.

  • @herf Thanks for the beta version. Flux is now working properly. I'd had the same problem last year (after installing some major Windows update), but installing newer drivers solved the issue, but not this time. Here's some info about my system (2400G):

    Advanced Micro Devices, Inc. 26.20.13001.25001: AMD Radeon(TM) RX Vega 11 Graphics (20190730)
    Windows Build: 18362.239

  • It finally works good for me after all this time(with latest update)
    First i did windows update and then i installed latest drivers from amd
    I have acer nitro 5 ryzen laptop btw.

  • @herf After the May Windows 10 update my flux would not work. I am not particularly computer savvy but I tried a few of the recommended fixes. I finally gave up and began to wear my computer glasses again. Yesterday I got a notification that updates were available. I have an option to wait until I shut down for the day. Sure enough when I went to shut down I got the choice to update and restart later. Low and behold I booted up my computer at 4 am (couldn't sleep) and my flux was working. It had to be the update that fixed it. It went into see what the update was and here it is. It was Update for Microsoft Windows KB4512508. Hope this helps some people.

  • 4.107 rolling out now to beta - is a bit more careful with multiple monitor setups, should fix most cases.

  • @herf The 4.107 beta broke it again for me :( Just like before, instead of red tint I get grayscale. I thought that maybe the latest driver from AMD may fix it. But instead atikmdag.sys was causing blue screens on login screen all the time and I ended up rolling back to previous driver in safe mode.

    How can I go back to 4.106 which works fine for me?

  • @phantom do you have two monitors on the same GPU? This is a bug we are working around in Windows right now. Does it work if you disable one?

  • @phantom can you also check if your GPU is running in 8-bit or 10-bit mode on the desktop?

  • @herf Yes, I'm using two monitors. I disabled them but nothing changes on either monitor. Both monitors are running in 8-bit mode.
    I've reinstalled flux and I'm back to 4.104 and can't update to beta version, even though the option in about menu is checked. I tried to check and uncheck the option, and to turn flux on/off multiple times but it doesn't seem to work this time.

  • @phantom I found a note online that older drivers are working, like

  • @herf I tried to install those but it turns out they don't support the 2x00G series. Anyway, I used the 'clean uninstall' option this time and after restart (on whichever GPU driver version Windows provides, I didn't check) flux was working fine, but second monitor was inactive. So I installed the 19.7.5 version again and second monitor and flux work but... then I checked the Driver info and it says: AMD Radeon(TM) RX Vega 11 Graphics (20180730). I guess that's the Windows build-in driver. I don't understand why, there were no errors during installation. I tried to open the AMD app and it says that 'Radeon Settings and versions do not match' and to try to update to the latest version. Well, no thanks. I'm staying on the current version, I don't need the AMD Settings app to work anyway.

  • I tried everything, reg fixes, reinstalling Flux, disabling fast startup, resetting color profiles under Color Management, making sure night light is off, reinstalling Intel graphics drivers, etc.

    Turns out, it was the stupid Lenovo Vantage app on my laptop that was causing the issue. You guys might wanna verify there are no apps controlling the brightness/colour.


  • @chaoscreater Thanks!
    Just found your solution! turned off Lenovo eyes saver and now my screen captures work great,
    but my eyes hurt!

  • @chaoscreater This solved the issue for me as well. I only created this account moments ago to say thanks.

Log in to reply