I'm about to lose my mind. F.lux not resetting colors or quitting task



  • I've been using F.lux for the past 3+ years and have never had any particular problems with it. I can usually right-click the icon, click Exit, and get my default color profile back. Today, I installed Firefox after running into problems with a particular website on Chrome, and now F.lux is driving me nuts because the color profile does not reset after I Exit. Now, I have to manually kill the process from the Task Manager and it still doesn't reset the monitor color profile to the default, which means the screen stays at the 2700k color temp I have it set to with F.lux. When I open F.lux again, it'll quickly reset the color temp to the default before reverting back to the 2700k temp all over again.
    I've tried messing with color settings, uninstalling, restarting, making sure a default Windows color profile is set, updating video drivers, EVERYTHING I can find from Google results about similar issues. I don't know what to do anymore and I'm hoping someone has something to offer. I have no idea why installing Firefox would create this issue, but that's the only thing I've done differently since this began. I right-click Exit F.lux multiple times a day before I play games. I would do a system restore if it wasn't for the fact that Windows was not creating restore points despite system restore being enabled on both hard drive partitions. Figures :| Please halp.


  • f.lux team

    Questions:

    • Are there any recent video driver upgrades (apart from Firefox?)
    • Does f.lux "disable for an hour" work?
    • Does exiting with an alternate color like 6400k do something better?


  • @herf

    • I updated my Nvidia video drivers, **but only after this issue began. Before that, I had updated a couple months ago with no issues
    • Yes, Disable for an hour, or until sunrise works fine
    • I tried that, changed day/night sliders to other things and Exiting had no change. Still keeps color temp, still refuses to kill process with right-click 'Exit'.

  • f.lux team

    Something in your system has read the f.lux profile and treated it as a "permanent" profile but it is not.

    Can you check in Control Panel > Color and see if there is a color profile there? If there is nothing there, one fix that works sometimes is to make one to override this behavior.

    If that doesn't work, does this problem come back after login/logout, or reboot?



  • @herf Unfortunately, trying multiple things with color profiles has no change. I've tried using a 'calibrated' profile which was set to default, set the original color profile which was always used to default, tried random color profiles, added multiple color profiles at once, tried f.lux safe mode, uninstalled/reinstalled f.lux (CCleaner to remove possible traces of F.lux before installing again), uninstalled Firefox, rebooted, and logged out. I'm at my wit's end.

    Thank you for your help, by the way.


  • f.lux team

    Do you happen to have any "igfx" processes running? On some laptops the Intel driver is doing this even though you have an NVIDIA GPU.



  • @herf None.


  • f.lux team

    NVIDIA Control Panel > Desktop Color Settings?

    Also which video driver version?



  • @herf Under "Choose how color is set" it's set to "Other applications control color settings". When I change it to "Use NVIDIA settings," my default colors come back. Then, I open F.lux and see if there's any change. None. Still sets to/keeps warm colors, still refuses to kill flux.exe from processes after right-click Exit.

    Driver version is 341.81

    Windows 7 Ultimate (64bit) Service pack 1


  • f.lux team

    Not a good sign if the flux.exe process doesn't exit - can you prevent it from running at startup?
    ("msconfig" can help)



  • @herf Yes, I use CCleaner to successfully prevent automatic startup.



    • So I'd like to share how I "fixed" my issue, if it's okay with the admins. I'll understand if this post is edited or deleted due to the mention of rival software. I also wanted to mention that Firefox has some sort of "color correction" integrated, which probably created the issue to begin with. I was unable to figure out a way to fix F.lux's process/color temp-sticking behavior.
      I'm now using a program called Redshift. It executes from a command line and is able to create the 2700k color temperature I was using with F.lux, after a minor registry key creation. I created 2 .bat files with the commands "redshift -O 2700" for my warm screen temp, the other with "redshift -O 6500" for resetting to the default screen temp, and have shortcuts for those in an easily accessible place.
      Thank you for working with me on the troubleshooting, @herf, and again I apologize if this is something you'd rather me not mention. Much love o/


  • I have been unable to reply until now. Here's what my proposed possible solution is:

    Toggle "Hardware Acceleration" in Firefox to the opposite setting of whatever it's set to right now and try f.lux again.



  • @TwoCables I did just that and immediately tried F.lux again. Even restarted, to no avail.
    Firefox has an about:config page where I searched for "color_management" and I played with the options several times while opening/closing f.lux to see if it would change anything. I used this page for reference about the options: http://ntown.at/2013/12/28/firefox-color-management/



  • I've been having same problem as OP. It only started happening very recently . Boot comp -> exit flux->kill task->open flux-> exit flux is what I have been needing to do. I have done nothing major to my configuration.

    I don't really like op's 'fix' though... perhaps someone else will figure it out as I'm just lost.


  • f.lux team

    This does sound like a video driver update has gone nutty. I don't expect it's a single application.

    Can someone post the version you're using and the GPU?

    Device Manager > Display Adapters > Properties > Driver tab



  • My GPU is an nvidia GeForce GT 120M and the driver version is 9.18.13.4181.


  • f.lux team

    Thanks - looks like this shipped about a month ago.

    In some cases you can rollback a driver, so if anyone can test to see if that helps, it would be great.
    http://www.nvidia.com/object/notebook_driver_instructions.html


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.