Why doesn't the SKIP button work on Update notifications?



  • Please fix this.. F.lux keeps nagging me to update and I do not want the new version. The nag screen has a Skip button, but when you click it, nothing happens. If you X out, it just pops up every time you resume your computer for sleep. Please add a "Don't update" button or something. These kind of strong-arm forced updates and nag screens just make me want to stop using F.lux and seek an alternative.


  • f.lux team

    I think you may be on v3, which is set to notify on every new v4 update - there have been several, as we've been trying to work around a Windows 10 update bug. It is indeed skipping every version, and then prompting for the next version.

    If you want to run v3 and never be prompted for updates, please use v3.17: https://justgetflux.com/flux-setup3.exe



  • Thank you, the new version is horrible. The UI makes no sense and there are annoying popups.



  • I have the same problem. I'm using 3.12 and after every reboot I get update notification to v4. I blocked f.lux in Windows firewall, but this not helped );
    I don't like new V4 version because I didn't work like V3 version.


  • f.lux team

    Two things:

    1. As we have said the old version is set to update to v4. You can download 3.17 (linked above) if you don't want it to.
    2. We have a "classic f.lux" mode in v4 which should work for everyone who likes v3.


  • @herf said in Why doesn't the SKIP button work on Update notifications?:

    It is indeed skipping every version, and then prompting for the next version.

    This is cool, didn't know that button actually worked. I'll update a machine in the house to v4 and turn on classic f.lux. The machine is not used much so the extra features are not needed there.