F.lux isn't working anymore (so does Night Shift)



  • Dear everyone,

    It's been several weeks now since I'm attempting to solve this problem, only I haven't found any solution. F.lux does not «work» anymore, as in the application promptly launches but, in terms of brightness and dimming, nothing happens. It's the same for Apple's built-in Night Shift although I never use it. I tried everything from system updates, full check and repair of my SSD drive and various color profiles, complete uninstall and reinstall of the F.lux app, SMC and PRAM resets — nothing has worked so far.

    Is anyone else currently experiencing this problem? I've read that some people had solved similar issues with a simple reboot, but my case seems more complicated. My computer is a 15 "MacBook Pro (Late 2013). My macOS version is 10.13.4 (17E202). The only thing I noticed during my many attempts to solve this is that F.lux color profile seems to be damaged (see screenshot attached). This doesn't explain why Night Shift doesn't work either. If anyone can help me, my poor eyes can't take it anymore!

    Thanks in advance,
    Dreamburger

    0_1527302099846_ColorSync_Flux.png



  • Anyone has been experiencing this lately? Any solution?



  • I have exactly the same issue. Both Night Shift and f.lux do not work any more and apparently the root cause are broken colour profiles. I tried everything - rebooting, clearing all caches, reseting PRAM and SMC. Nada... Nothing worked... :/

    Perhaps it's fixed in 10.13.5? Just released yesterday and haven't installed it yet.



  • @transgredi Unfortunately the latest macOS update didn't solve anything… on my computer at least.

    It would be greatly appreciated if anyone who has experienced this, or even someone from the F.lux team, could help us solve this matter. I don't believe two random people can be experiencing the exact same problem at the same time. There must be others stuck in the same situation. From what I've read, it's not the first time this happens.


  • f.lux team

    There is a "locked profile" issue reported in this thread, but we have not seen it here:
    https://forum.justgetflux.com/topic/4184/f-lux-not-supported-in-macos-high-sierra/13

    My impression of this bug is as follows: the machine is using a non-display profile (e.g., "sRGB profile") during upgrade, and 10.13 then seems to fail to load it, but also disallows removing or changing it, so the color system gets stuck with no profile.



  • @herf Indeed, my computer is locked on that sRGB IEC61966-2.1 profile and unfortunately it isn't possible to change it (as mentioned in that other thread).
    I'm surprised some people managed to fix this, while I don't, even after trying what's been brought up in terms of solution as well as numerous new updates from Apple.



  • Same here - I tried all advices on how to fix the issue and none of them worked :/ I'm stuck on that generic profile sRGB IEC61966-2.1.

    0_1528320327369_Screen Shot 2018-06-06 at 23.23.53.png



  • I ultimately fixed the issue by doing a simple installation of MacOS via the Disk Utility. Simply restart your computer by pressing Cmd+R and reinstall the system. A simple installation will not make your data disappear, and there's no need in making a clean install (i.e., from scratch). I would strongly advise to save all your files and/or make a copy of your drive first; especially if you aren't familiar with such practice. As a result, all my Color Profiles were reset and both F.lux and Night Shift are perfectly working now.



  • @dreamburger F.lux stopped working on my MacBook Air OS X 10.9.5 13 inch Early 2014 It cannot support any further system upgrades. (Why Apple made this so sure beats me.)
    Flux no longer "sticks" to the menubar. I cannot effect any changes in order to delete the application or any of its parts. Now I just want to yank it of my machine! I can't seem to accomplish any ot the tasks outlined for uninstalling this. In addition, I will have to just quit gathering any data for the Harvard research project. I'm sorry I ever began with this. None of the research people/addresses respond to my queries or reports.
    dneary


  • f.lux team

    @brooklyn I have a much older Air and it is running 10.13 already! Maybe check on that upgrade again?

    Does f.lux show up in activity monitor? It should be easy to quit and put in the trash there.