Flickers daily for a bit at 9pm sharp



  • Hi there,

    This is rather puzzling. But for at least the last weeks, every evening at 9pm, my screen's brightness jumps sharply back to bright-white... and then after flickering a bit, starts fading back again (more red, less blue).

    I have my current location set in flux and flux correctly starts adjusting the screen daily around sunset time (nowadays about 5pm).

    Running v4.55. Though I did just notice the option to join the beta and I checked that box.

    Thanks!



  • Mine does this as well, though it does it at any time after the sun sets (about 4:00pm here). The flashing blue light is really surprisingly painful. Did running beta solve the issue for you?

    (also running v4.55)



  • Can you try the beta to see if it helps?

    https://justgetflux.com/flux-setup4.exe



  • Alas, still the same issue :\



  • This has been happening to me as well! A few weeks ago f.lux started flickering at night and I would have to restart it to get it to stop. Recently I've noticed that this happens consistently at 9pm. I have f.lux set to update automatically; otherwise there's nothing on my computer that's changed recently. Any help would be appreciated (by me and my eyes!)



  • Same issue! Every day exactly at 9 pm. It's been happening for several days now. Is it so hard to believe that it takes so long to find a solution to this annoying bug! Plus it ruins the whole idea of having flux installed - who would sleep after looking at a blinking blue screen?



  • It sounds to me like your wake time is set to 6am and the transition to Bedtime Mode is somehow not working properly for you. If this is the case, then switch to Classic F.lux.



  • @TwoCables Thank you for your reply! I see a checkmark near "Classic f.lux" when I open Settings. So I guess I am already using a Classic f.lux.



  • @a12345 said in Flickers daily for a bit at 9pm sharp:

    @TwoCables Thank you for your reply! I see a checkmark near "Classic f.lux" when I open Settings. So I guess I am already using a Classic f.lux.

    Argh. lol Oh well. It was just a guess anyway.

    I don't have any more guesses. I had to try though. :)



  • This is almost always due to a conflict with some other program conflicting with f.lux, so it's unlikely that f.lux is causing the issue by itself.



  • Hmm. Strange. I can't think of any other program I'd be running that would be set to do something at 9pm sharp every day.

    Any ideas how I could potentially troubleshoot?



  • @herf It is most likely that f.lux is causing this issue because of the following facts:

    1 - we are all using different computers with a completely different set of software

    2 - this issue has started approximately the same time for all of us; it was around the time of your recent big update



  • @herf This started happening to me last week on the day that I did the big Windows 10 update. It occurs at 9pm, just after my eyes have gotten cozy for the evening. Always worked great previously. Please fix!



  • It sounds to me like it's the Night Light feature in Windows 10. Try to get rid of it.



  • @TwoCables Didn't even know that was a thing. Here's what the setting was reading: "Night light (off until 9:00 PM)" Switched it off, we'll see how it does. Thanks!



  • @flummoxed the 4.59 build should turn this feature off automatically: https://justgetflux.com/flux-setup4.exe



  • @herf Updated, thanks. (For others, turning off the Windows 10 Night Light feature did resolve the problem.)



  • Woo hoo! Thanks everyone! :)



  • This has been happening to me for months and I finally looked it up to see if there was a resolution.
    Like clockwork, every night at 9:00pm on the dot, f.lux would turn off and my screen would go to full white brightness for the entire minute until 9:01pm then it would go back to normal.

    It turns out that the Night Light option in Windows 10 was still turned on from before I downloaded f.lux months ago, and turning that feature off kept f.lux from turning off.



  • @kmann thx for sharing...this solved the issue for me....no more 21:00 flickering :) much appricated.



  • sorry i'm a little late but to anyone who sees this I fixed it by closing the nvidia program in the tray



  • @ionicterror85 said in Flickers daily for a bit at 9pm sharp:

    sorry i'm a little late but to anyone who sees this I fixed it by closing the nvidia program in the tray

    That's the NVIDIA Control Panel. You need that.

    The actual fix is, disable Microsoft's Night Light feature in Windows 10. The flickering is caused by a conflict between Night Light and f.lux. Turning off Night Light is the solution. Anything else that solves it is just "a Band-Aid solution", and is therefore incorrect.



  • Hello. My problem is that even after uninstalling f.lux, the night light kept flickering. What could I do to erase the f.lux modifications it did? I think it all started after installing f.lux and even after uninstalling it keeps flickering. What should I do? I dont want to use f.lux because the feature is different than the night light built in the OS i.e. f.lux gives me additional eyestrain. I have a probook 450 g7 and its visible that activating f.lux brings in additional dither which Im sensible to, in terms of eyestrain. I tested it with a high focus camera. Thanks.



  • I figured out how to do it manually within the monitor, with Custom RGB settings (please see below)

    I'm doing ok with two monitors, and these two settings: 2400K and 3400K

    For more details, please see my post titled: Flickering screen, again, with the latest version: f.lux (v4.118) . . . (08/04/20 I accidentally put this in the V3 forum)

    Research suggests that f.lux must talk directly to display hardware to work – no remote desktops

    I'm curious to see if you get good results also!


    2400 K #ff9d3f Standard incandescent lamps . . . HP E272q
    255,157,63
    (255,157,63)
    rgb(255,157,63)
    rgb(100%,62%,25%)


    3400 K #ffc184 HALOGEN . . . Per f.lux . . . HP 1755 . . . These settings work on the HP 1755, but aren't very orange on the HP E272q
    255,193,132
    (255,193,132)
    rgb(255,193,132)
    rgb(100%,76%,52%)



Log in to reply