Tinted screenshots, or fullscreen apps and games missing f.lux?

  • f.lux changes your screen colors using the built-in controls on your video card. But when they are not available, it uses the GPU. We prefer to use the built-in calibration controls, since they work better and do not affect screenshots.

    So if your screenshots are tinted or your games are not, consider these things:

    1. Do you have a USB-connected (DisplayLink) monitor? Then please consider updating your DisplayLink drivers and enabling a registry setting listed in this thread: http://www.displaylink.org/forum/showthread.php?p=82958#post82958

    2. Do your fullscreen movies or games not have f.lux effects applied? Then please consider using the "expand color range" menu from f.lux and rebooting the machine. The newer versions will prompt you to do this when f.lux starts (a few times), but a reboot is necessary to finish the process.

  • I don't have a USB-connected DisplayLink monitor. My screenshots are tinted. What are my options to resolve? I have a GTX 960 graphics card.

  • @Ryan-Bright I have the same GPU, my screenshots are not tinted? How are you generating screenshots? For me, pressing the printscreen key and CTRL + V into paint works well.

  • I have the same problem as @Ryan-Bright on my laptop. It doesn't make any difference which monitor I try to grab a screenshot from, if the DisplayLink adapter is plugged in everything turns dark orange. I've tried using the snipping tool, and also a regular print screen. Here are some comparisons with/without on my native laptop screen:



    I'm running f.lux version 4.55
    I'm running a (Dell 4-in-1 Adapter) which is the DisplayLink using drivers 8.4.3005.0
    I've got an nVidia GeForce GTX 960M graphics card using driver version

    I've already applied the EnableGammaRamp registry key set to true, restarted laptop and it didn't seem to make any difference.

  • This post is deleted!

  • I had the same problem awhile ago, i found it was the color profile of windows that was set wrong for me probably got stuck when i updated it in the wrong profile

    You can go into color management in the control panel and select sRGB IE C61966-2.1 mainly u need the one that says 2.1 at the end under the ICC list,For WIN 7 and earlier but that gets kinda annoying since i like to make sure its the right profile before i launch a game,
    You can download this program utility called ‘Display Profile' i found, its only 204kb its at the vary bottom of the article, it have no clue if it works on win 10 since i only use win 7 From PC monitors
    alt text
    Also on a side note some monitors may have there own display profile, i would check that one in comparison to the SRGB bla bla bla 2.1 if you have it, if not just double click the one with 2.1 at the end and it should go back to white at least for me it work.

  • Hello,

    I am still having the issue desribed above. I have already followed all the mentioned steps, including updating DisplayLink drivers, graphic card drivers and applying EnableGammRamp registry key. None of this worked. I have tried out all the screenshot tools available in the market -> the issue appears in all of them.

    Driver info:

    Are you working on a solution to this? Can we expect this in a new build?

    Best regards,

  • @cumuluss10 In Adjust Desktop Color Settings

    DO NOT let other applications control color settings.

    No more tinted screen caps.



  • @cumuluss10 I am having the same problem. It occurs across multiple different laptops. My current laptop has a Intel UHD 620 card in it. It's very annoying and I would love to find a solution (other than manually switching the color balance to 6500k, taking my screen shot and then switching it back).

  • @stevemidgley Also - note that even using Windows 10 native "screen snip" function results in heavily red-shifted screen shots. So I think this is definitely related to how Flux is handling screen tinting, since native Windows OS doesn't even know how to color correct the screen shots.

    Also note that I am using a Displaylink monitor (usb to DVI) as well as two other external monitors (one via direct HDMI, and one via a displayport to hdmi converter). The problem is the same with all the monitors.

  • Just thought I would throw in on this issue. I tried all of the troubleshooting steps to resolve this issue for my self.
    I have a three monitor extended display work station, and one monitor was attached with a USB-connected adapter that used the DisplayLink Driver.

    I updated the driver to my graphics card, updated the driver to Display link, changed the Reg Keys in accordance with the link provided in the OP. I also went ahead and followed every other suggestion I could find in the thread.

    My PC is Windows 10 Pro, and I was having the issue with the snipping tool catching the tint, and it was really frustrating.

    When I disabled F.lux and switched to windows nightlight, it didn't work at all on the monitor with the Displaylink adaptor, because it wasn't using the Intel graphic driver when connected, it was using the DisplayLink driver, and I couldn't find a way around it. (It's a work PC, so no NVIDIA like my home build.)

    In spite of it only being connected to one monitor, the snipping tool issue effected every monitor, not just the one with the DisplayLink connection. SO. I replaced my old DisplayLink USB adapter with a new Display Port to DVI adapter, and guess what, Every. Single. Problem. Is now fixed. Go ahead and just bin your adapters. It won't save you money, but it will save you so much time.

    Now both F.lux and Night light works for me perfectly fine on every monitor, and the snipping tool issue is completely resolved.

  • I recently update Windows from 1809 to 1903 and now when use snipping tool all the images are tinted, before the update all worked without any problem. I only use one monitor with DVI connector.


  • @darksapex which version of f.lux is this?

  • @herf Just updated to 4.102, but the problem appear from 4.84

  • Okay, this is the new WDDM 2.6 driver - I have it running on an HD Graphics 620 and this is not happening. So...

    Two more things:

    1. What color temperature was f.lux set to when this screenshot was made?
    2. If you go to "About your PC" in system settings, what is the exact "OS Build" (including the part after the decimal)?

  • @herf I'm using f.lux in classic mode or "classic f.lux"

    1. was 5500k sunlight
    2. 10.0.18362.53

  • @darksapex okay they just added a 18362.86 - no idea if this fixes it, but you might try it out.

  • @herf Okay, I tried it and everything went back to normal, it looks like it was a problem with the WDDM 2.6 driver or something related to it.

  • @herf Well, after a few days without restarting Windows(I only turn it off with hybrid hibernation "fast startup") the problem has reappeared.

    Using f.lux 4.103, Windows 10.0.18362.86 and the temperature from the pic is 4200k


  • Well basically this means Windows is saying that it doesn't support any color transforms, so we backoff to use the GPU. It should not do that, anyway.

    Is this happening after the machine is suspended or something like that? Does it go away if you restart f.lux (not the whole machine)?

  • @herf

    This happens after the computer is turned on, after I have turned it off using hybrid hibernation (fast startup, feature of windows 10).

    The same thing still happens after I have restarted f.lux.

  • Any conditions when it does not happen? Also does it happen with windows shift S?

  • @herf Still happens using "snip and sketch" app(windows + shift + S), I'll try to restart later

  • @herf After restart windows all works fine, but when I turn off the computer using hybrid hibernation the tinted screenshots appear again.

  • Getting the same issue after updating to Windows 10 1903, screenshots were fine before.
    fl.ux: 4.104
    OS: Windows 10 1903 (18362.145)
    Driver Info:

  • Am making a new thread here for 1903:


  • I have this issue.

    1. No
    2. They do, it's just my screenshots (i use ShareX)
      This only started on the 1903 Windows update/after I gave my PC a reset

    I'm using a Razer Blae Stealth 2017 13" using Intel UHD Graphics 620(r)
    I've tried fumbling with some settings, but nothing seems to work.

Log in to reply