Tinted screenshots, or fullscreen apps and games missing f.lux?


  • f.lux team

    f.lux changes your screen colors using the built-in controls on your video card. But when they are not available, it uses the GPU. We prefer to use the built-in calibration controls, since they work better and do not affect screenshots.

    So if your screenshots are tinted or your games are not, consider these things:

    1. Do you have a USB-connected (DisplayLink) monitor? Then please consider updating your DisplayLink drivers and enabling a registry setting listed in this thread: http://www.displaylink.org/forum/showthread.php?p=82958#post82958

    2. Do your fullscreen movies or games not have f.lux effects applied? Then please consider using the "expand color range" menu from f.lux and rebooting the machine. The newer versions will prompt you to do this when f.lux starts (a few times), but a reboot is necessary to finish the process.



  • I don't have a USB-connected DisplayLink monitor. My screenshots are tinted. What are my options to resolve? I have a GTX 960 graphics card.



  • @Ryan-Bright I have the same GPU, my screenshots are not tinted? How are you generating screenshots? For me, pressing the printscreen key and CTRL + V into paint works well.



  • I have the same problem as @Ryan-Bright on my laptop. It doesn't make any difference which monitor I try to grab a screenshot from, if the DisplayLink adapter is plugged in everything turns dark orange. I've tried using the snipping tool, and also a regular print screen. Here are some comparisons with/without on my native laptop screen:

    0_1516723696220_upload-fd1f176f-7ac6-43fd-ab4e-9ef83452ced7

    0_1516723832303_upload-9cb1412f-f2f2-4ee7-a473-0f90bb0f45cb

    I'm running f.lux version 4.55
    I'm running a (Dell 4-in-1 Adapter) which is the DisplayLink using drivers 8.4.3005.0
    I've got an nVidia GeForce GTX 960M graphics card using driver version 22.21.13.8477

    I've already applied the EnableGammaRamp registry key set to true, restarted laptop and it didn't seem to make any difference.



  • This post is deleted!


  • I had the same problem awhile ago, i found it was the color profile of windows that was set wrong for me probably got stuck when i updated it in the wrong profile

    You can go into color management in the control panel and select sRGB IE C61966-2.1 mainly u need the one that says 2.1 at the end under the ICC list,For WIN 7 and earlier but that gets kinda annoying since i like to make sure its the right profile before i launch a game,
    You can download this program utility called ‘Display Profile' i found, its only 204kb its at the vary bottom of the article, it have no clue if it works on win 10 since i only use win 7 From PC monitors
    https://pcmonitors.info/articles/using-icc-profiles-in-windows/
    alt text
    Also on a side note some monitors may have there own display profile, i would check that one in comparison to the SRGB bla bla bla 2.1 if you have it, if not just double click the one with 2.1 at the end and it should go back to white at least for me it work.



  • Hello,

    I am still having the issue desribed above. I have already followed all the mentioned steps, including updating DisplayLink drivers, graphic card drivers and applying EnableGammRamp registry key. None of this worked. I have tried out all the screenshot tools available in the market -> the issue appears in all of them.

    Driver info:
    0_1532698893665_335d8422-1ab0-4ddf-a4e4-75acbccab05a-obraz.png

    Are you working on a solution to this? Can we expect this in a new build?

    Best regards,
    Magdalena



  • @cumuluss10 In Adjust Desktop Color Settings
    chose USE NVIDIA SETTINGS---APPLY

    DO NOT let other applications control color settings.

    No more tinted screen caps.

    Yay



  • @jayto NVIDIA CONTROL PANEL



  • @cumuluss10 I am having the same problem. It occurs across multiple different laptops. My current laptop has a Intel UHD 620 card in it. It's very annoying and I would love to find a solution (other than manually switching the color balance to 6500k, taking my screen shot and then switching it back).



  • @stevemidgley Also - note that even using Windows 10 native "screen snip" function results in heavily red-shifted screen shots. So I think this is definitely related to how Flux is handling screen tinting, since native Windows OS doesn't even know how to color correct the screen shots.

    Also note that I am using a Displaylink monitor (usb to DVI) as well as two other external monitors (one via direct HDMI, and one via a displayport to hdmi converter). The problem is the same with all the monitors.



  • Just thought I would throw in on this issue. I tried all of the troubleshooting steps to resolve this issue for my self.
    I have a three monitor extended display work station, and one monitor was attached with a USB-connected adapter that used the DisplayLink Driver.

    I updated the driver to my graphics card, updated the driver to Display link, changed the Reg Keys in accordance with the link provided in the OP. I also went ahead and followed every other suggestion I could find in the thread.

    My PC is Windows 10 Pro, and I was having the issue with the snipping tool catching the tint, and it was really frustrating.

    When I disabled F.lux and switched to windows nightlight, it didn't work at all on the monitor with the Displaylink adaptor, because it wasn't using the Intel graphic driver when connected, it was using the DisplayLink driver, and I couldn't find a way around it. (It's a work PC, so no NVIDIA like my home build.)

    In spite of it only being connected to one monitor, the snipping tool issue effected every monitor, not just the one with the DisplayLink connection. SO. I replaced my old DisplayLink USB adapter with a new Display Port to DVI adapter, and guess what, Every. Single. Problem. Is now fixed. Go ahead and just bin your adapters. It won't save you money, but it will save you so much time.

    Now both F.lux and Night light works for me perfectly fine on every monitor, and the snipping tool issue is completely resolved.