F.lux Darkroom mode is red (+workaround)



  • Heyo,

    so i'm using F.lux now since a few days and suddenly the darkroom mode didnt work anymore properly, its way too red (looks like the colors are inverted).

    After googling around, looking for fixes - i couldn't find any. A few days later a friend got the issue aswell and pointed out it happened as soon as he restarted his computer, so he used his laptop and installed flux (without reboot) and tried the darkroom mode - it worked, after that, he restarted his laptop and guess what? Same issue happened - way too red - unusable.

    How we fixed it: Uninstall F.lux and clean the registry with CCleaner - restart the computer. Install F.lux and don't restart, as soon as you restart the machine something in the registry is getting changed to a point that it is making the colors inverted (?) and way too red.

    Atleast this 'workaround' works for me and a friend.

    Not sure how to fix it permanently tho



  • It is never safe to let any software "clean" the Registry because it can easily detect false positives and delete absolutely critical Registry keys thereby completely destroying your installation of Windows which would render your computer completely useless. If you're going to let software "clean" the Registry, then you need to be ABSOLUTELY CERTAIN that you go through the list of detected "problems" with a fine-toothed comb and only leave those items selected you are 100% sure are safe to delete.

    If you don't know what's safe to delete, then I would recommend not letting anything get deleted. The Registry should only be messed with by people who know what they're doing (no software should be blindly trusted - EVER). I have seen even CCleaner kill a perfectly good installation of Windows. So if your advice is to be followed, then it should be done so with extreme caution.

    This problem of Darkroom Mode washing everything out in pure red (so that you can't see anything) is a known problem for AMD GPUs. So far, no one has discovered a fix. I don't have an AMD GPU though.

    I apologize for coming off so strong, but this is very important. Most people who come to this forum are actually pretty computer-illiterate (this is not a cut-down on them, it's an observation), so it's best to just keep advice like this to a minimum or at least spell out the risks and how to avoid those risks if possible when you do give the advice. Too many people who come here would just blindly follow this advice, and if any false positives are detected on their computer, they will be deleted and then they will be screwed and it will be the f.lux forum's fault.



  • You can trust me, i know what im doing :)

    This problem of Darkroom Mode washing everything out in pure red (so that you can't see anything) is a known problem for AMD GPUs. So far, no one has discovered a fix. I don't have an AMD GPU though.

    Yeeeeeeah well, sorry to disappoint you on this but i'm a NVIDIA (GTX 1070) user, so is the PC of the friend who encounters the same issue.

    I apologize for coming off so strong

    Apologies accepted :)



  • So when you try to use Darkroom Mode, all you see is red? You don't see anything else?



  • @TwoCables said in F.lux Darkroom mode is red (+workaround):

    So when you try to use Darkroom Mode, all you see is red? You don't see anything else?

    sry for the late response.

    http://imgur.com/a/gcME6

    Made an imgur album. Picture with reboot, without reboot and no darkroom mode.

    Hard to tell on the phone picture tho, darkroom mode without restart is less bright and the colors arent that powerful (really good at night!)



  • Like I said, it's supposed to be red and black, and colors are supposed to be inverted. The name "Darkroom Mode" is named after the darkroom that photographers use when working with photo negatives that aren't sensitive to red light. The reason for the inverted colors is to whimsically simulate the photo negatives in the red light darkroom. That's why it's called "Darkroom Mode".

    Open some programs and whatnot (do your normal thing) and take a photo of that and show me. I want to see just how bad the red and black really is. It's hard to tell from only that wallpaper. From the little bit that I can see though, I think it's working as intended (red and black, colors inverted).



  • @xpectro08 The way darkroom mode is after a restart is the way it's supposed to be. That's why f.lux tells you to restart after you install it, as it needs to reboot before it can majorly change colors. If you want to achieve the same thing darkroom mode does before a restart, just turn your brightness down.


  • f.lux team

    Until the reboot we emulate the effect on the GPU, which is why it is working.

    There is apparently a bug in the way calibration settings are being handled in these new drivers. Right now, we don't have a way to detect that it's going wrong, so we can't automatically use the GPU version instead.

    We'll try to get one of these drivers in house to test - but this is almost certainly a driver bug.



  • Hello!
    So sorry to reply to an old topic, but I have this same issue and used the search function found this thread and @TwoCables wanted to see an image of the "Darkroom Mode" with some windows and stuff so I thought I'd post a couple in hopes of it possibly being helpful? Here are two images: https://imgur.com/a/bFJM4

    I love the idea with naming, photography darkrooms and stuff, it's just when this feature was first used on my system, it lowered the brightness in a way that isn't the norm? It's like it lowered the normal brightness, but also added a black layer with a huge opacity that made the layer transparent? I think that's what we're asking about? At least that's what I'm asking about. :p

    Don't get me wrong, this red and black thing is lovely, I use it from time to time, especially when I need to type stuff all night long, just curious to see where this goes if anything.

    Thank you!

    P.S. I don't know why I wrote this in a letter format lmao..

    EDIT: I looked through some more threads and it's apparently common. I want to apologize again, I didn't realize how common it was. Idk much, but if there's anything I can do to help, I would? Good luck guys. ♥ (Sorry again)


  • f.lux team

    That looks kind of like we intended.

    The previous Radeon bug would turn the screen all one color, which was considerably less good.



  • @TwistedRail, you are seeing the intended effect of Darkroom Mode. As Mike Herf said, the problem others experienced was, they couldn't see anything other than red. Literally, they only had 1 color in front of them. You're experiencing no malfunctions whatsoever.

    If I could find photos that have been posted on here before that show this problem, then I'd be happy to show them to you. As near as I can tell, the photo that xpectro08 posted is showing the intended effect (but it's a bad example to show the intended effect).



  • @herf @TwoCables I see. That's great actually! A little off topic, is there an effect for the thing I described though? Lower brightness + black layer overlay with 10% opacity? It feels like my F.lux wasn't working before and now it is but that bug was really nice. p:



  • @TwistedRail said in F.lux Darkroom mode is red (+workaround):

    @herf @TwoCables I see. That's great actually! A little off topic, is there an effect for the thing I described though? Lower brightness + black layer overlay with 10% opacity? It feels like my F.lux wasn't working before and now it is but that bug was really nice. p:

    You probably needed to restart your computer in order for f.lux to work properly. Otherwise, certain things like Darkroom Mode won't work at all and all you'll see is some kind of adjustment to the apparent brightness.

    F.lux can't adjust the brightness of a monitor's backlight; it only changes the black level. So, Alt+Page Down only adjusts the black level.

    10% opacity would be 90% transparent, and that would be awful. It would be very difficult to see anything. So did you mean to say 10% transparent? Even so, f.lux doesn't do that.

    Instead of using Darkroom Mode, try using Alt+Shift+Page Down to change the color temperature to 800K.



  • @TwoCables Hahah, my bad, speaking out of me butt with the numbers and stuff tbh. It's just that for some reason I can't change the brightness level on my PC/Monitor. Idk, something with Windows 10 doesn't sit well with me I don't like it.
    Although, for the longest time I thought the red/black effect of Darkroom was an error until I read this. Thank you so much for helping out! I now understand it's not an actual issue. (I thought it was an issue because when it first came out it provided some dark overlay, which was actually nice, but not intended)
    Thank you!

    P.S. Curious, do you know if there's a dark overlay option coming soon? O:



  • @TwistedRail said in F.lux Darkroom mode is red (+workaround):

    @TwoCables Hahah, my bad, speaking out of me butt with the numbers and stuff tbh. It's just that for some reason I can't change the brightness level on my PC/Monitor. Idk, something with Windows 10 doesn't sit well with me I don't like it.
    Although, for the longest time I thought the red/black effect of Darkroom was an error until I read this. Thank you so much for helping out! I now understand it's not an actual issue. (I thought it was an issue because when it first came out it provided some dark overlay, which was actually nice, but not intended)
    Thank you!

    P.S. Curious, do you know if there's a dark overlay option coming soon? O:

    I don't understand. What all have you done to attempt to change the brightness level? Is this a laptop? Or do you have normal computer that has an actual monitor? Either way, changing the brightness should be possible regardless of which operating system you have.

    I don't know what Michael and Lorna's plans are for the future of f.l.ux, so no, I don't know. I doubt it though because all you have to do is press Alt+Page Down to adjust f.lux's black level.

    Are you using your computer in total darkness? If so, then I do believe that's harmful to human eyes in the long run. I believe it's much better to always have lights on to balance the brightness between the ambient light and the light being emitted by the monitor, at least for general use. I like to turn my monitor's brightness all the way up when I'm watching movies or playing video games. It really makes for a more pleasing picture. For general use like just using Firefox, I keep my brightness balanced with my ambient light (and vice versa) as much as I can.



  • @TwoCables This is mainly a PC. I'm probably at fault for disabling auto updates on Win 10. I can't find brightness anywhere in control panel. I can, however, change brightness on my screen, it's just not the same though as it was with the initial Darkmode of F.lux. That was really nice. It's ok though, I'm sorry for being a bother Dx

    Please, if you may, forgive my ignorance? Is Michael and Lorna one of the people behind this project? I hope they do well, and you♥

    This isn't an issue any more now that I know what the functionality of Darkroom is. I sort of jumped the gun here, I apologize, but thank you very much for assisting me out. ♥♥



  • Windows Update has nothing to do with your ability to adjust your monitor's brightness. Your monitor's brightness is adjusted only by pressing the buttons on the monitor (or with a laptop, you press the dedicated brightness buttons). That's just how it's done. Windows Update isn't needed for that.

    Also, F.lux doesn't control the brightness of the backlight in your monitor either (when you press Alt+Page Down). F.lux just changes the black level, and, as you know, it also changes the color. The only way to actually adjust the backlight's brightness in your monitor is by using the monitor's onboard controls. Laptops have those controls right on the laptop itself and they do the same thing.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.