I can't use f.lux nor the Night Light Mode while playing games in fullscreen.



  • Hey,

    Yesterday I updated my Windows 10, It was the new Creator Update.
    Since then I can't use f.lux while playing games in fullscreen. I play League of Legends, Osu and the window mode is not really good for these games (so this isn't a solution for me). The new feature in Win 10 the "Night Light Mode" also doesn't work while playing games. But before the update everything worked? I just don't understand.



  • nobody wants to help me ;(
    nice forum



  • You only waited 23 hours. Please give it time. There only 2 people who are 'behind' f.lux, and there are only 2 frequent helpers on this site: me and Tungsten_smooth (we're just really big fans of f.lux). I saw your thread but I have absolutely no idea what the answer is. Rather than giving you a reply and making you come here to read "I don't know", I left it alone. I see now though I should have said something because you felt ignored. I apologize for that.



  • @TwoCables No I was just being angry. I'm sorry for that. Anyway I found another solution.
    I used f.lux safe mode all the time before I upgraded my Win 10 and it applied to all applications running in the background. So I thought it would do the same after the Upgrade. So after disabling "safe mode" it automatically changed the colors even Ingame Fullscreen!. But disabling safe mode decrease my FPS slightly and there is some Lags duo that. So the problem is the safe mode. It won't change the color for games. But this is better than nothing :)

    But I guess there is some "Application" or "Windows feature" that disable f.lux for games. I use the same application as before so it couldn't be that or it is the graphic driver. I use Intel HD 5500 maybe the latest driver doesn't support f.lux when some games running? Maybe it's also the new "Night Light Mode" interrupting f.lux in some way (even tho I disabled it, bc f.lux is better).



  • @itsThundeX You can try running your game / program in "windowed" or "borderless windowed" mode to run it on desktop colors. This usually doesn't affect performance much anymore.



  • Yeah, I dunno. This is definitely not the first time I have seen the Creator's Update causing display-related problems for someone. From person to person, it's never the same problem! So, it's not like we can say, "Well obviously this thing over here is the problem! So, just do this and it's fixed!" No. All I can tell so far is that the problem is the Creator's Update, but what the exact culprit is inside this update is, I have no idea. I don't even have Windows 10, yet this is really beginning to piss me off. I am remembering a time when we had the ability to avoid certain updates forever if we wanted to. This update is one of those updates I wish I could tell people to just uninstall and avoid.

    I think my good friend Tungsten_smooth may have the only solution available to you now, and it's never a guaranteed solution either. It's just, "try it and see if it works for you". Fortunately, the reason why it's never a guaranteed solution is completely unrelated to Windows 10. It's just the way it is in Windows. Period. lol



  • @Tungsten_smooth for these type of games "borderless windowed" is not really good. You have to use fullscreen! Now I disabled the safe mode in f.lux and it works! Everything is turning orange even in-game fullscreen! But the problem is that decreases my FPS. Before the update, I always used safe mode in f.lux and it worked perfectly fine for everything. But somehow now it doesn't anymore. strange..



  • @itsThundeX said in I can't use f.lux nor the Night Light Mode while playing games in fullscreen.:

    @Tungsten_smooth for these type of games "borderless windowed" is not really good. You have to use fullscreen! Now I disabled the safe mode in f.lux and it works! Everything is turning orange even in-game fullscreen! But the problem is that decreases my FPS. Before the update, I always used safe mode in f.lux and it worked perfectly fine for everything. But somehow now it doesn't anymore. strange..

    In the options, try changing the transition speed to "Very Fast: Gaming".



  • @TwoCables After the update, I had more than this f.lux issue. After fixing the other issues I had to deal with f.lux as the last problem. I couldn't really fix it, so that's why I was kinda angry at everything.



  • @itsThundeX said in I can't use f.lux nor the Night Light Mode while playing games in fullscreen.:

    @TwoCables After the update, I had more than this f.lux issue. After fixing the other issues I had to deal with f.lux as the last problem. I couldn't really fix it, so that's why I was kinda angry at everything.

    So are you saying that "Very Fast: Gaming" doesn't do anything good for you?



  • @TwoCables You mean transition speed "Fast (20s)? I already have it :)
    I don't find an option for gaming tho?



  • @itsThundeX said in I can't use f.lux nor the Night Light Mode while playing games in fullscreen.:

    @TwoCables You mean transition speed "Fast (20s)? I already have it :)
    I don't find an option for gaming tho?

    I incorrectly thought you had the f.lux beta. Give it a shot to see what happens. I think it would be best to uninstall f.lux first (and restart your computer) before installing the new beta.



  • @TwoCables Ok I tested it. It's like the other f.lux after disabling the safe mode. So there is still a very little performance "lag". I want to have the normal f.lux (not beta) in safe mode to change the colors automatically like before. But I guess I have to turn off "safe mode" if I'm playing games even tho it will slightly decrease my fps in game. By the way I will use the old f.lux again :) Thanks for your help!



  • I just exit f.lux completely when I'm about to play a game. I keep f.lux pinned to my Taskbar. So I guess if I were to recommend anything at all, then it would be this.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.