f.lux beta discussion



  • @disqQ said in f.lux beta discussion:

    @TwoCables said in f.lux beta discussion:

    ...so, like I said, this is a problem for everyone with the Creator's Update.

    I'm running f.lux 4.20 on Creator's Update and i don't have that issue.

    I'm relieved to know. What GPU do you have?



  • @TwoCables GTX 1070. One thing that i notice though, is, when and if i close f.lux i need to wait like 15/20 seconds if i want to open it again. If i close f.lux and launch it right after, nothing happens.



  • @disqQ said in f.lux beta discussion:

    @TwoCables GTX 1070. One thing that i notice though, is, when and if i close f.lux i need to wait like 15/20 seconds if i want to open it again. If i close f.lux and launch it right after, nothing happens.

    Oh, the executable is taking a long time to quit. Interesting. I had that problem early on with the Beta but it seemed he fixed it.



  • @herf i'm using Notebook, Win 10 Pro, a Radeon M430, a Core i5 Kaby Lake, i have reinstall all the default video graphics driver.



  • Hey, Alex again!

    Just another suggestion. It would be nice to have the option to disable the notifications, as when I constantly switch between apps it can get abit annoying.



  • I have flickering on/off issues on Windows 10 Creator's Update and f.lux 4.20.

    I'm using a dual-GPU laptop (intel integrated and nvidia 980m on 381.65).

    I think it might be limited to Chrome.



  • @lorna said in f.lux beta discussion:

    @dreadnaut ... The first release was set dimmer than we intended as we live in a house that's quite a lot darker than most at night, so we brightened it up.

    I keep my area very dim, I dim bulbs until they turn orange! Not yellow orange, or fire orange, but probably ember orange or close. I lost one of my light dimmers, but maybe it will turn up. I use an orange light for bathroom activities, and keep all the other lights very dim.



  • @TwoCables
    Hi. My mouse isn't being coloured. Any suggestions?



  • @tambre Do you have the latest (v4.20) release? If not, redownload, as it's live on the main website. There is an option in the settings called "software mouse cursor". I'm really not sure how this will affect the mouse, but I DO know it will render your mouse in software. This may cause the mouse to be invisible in some fullscreen applications and games, so you may not be able to use the setting permanently if this occurs, let us all know your experience (I don't reboot often).



  • So f.lux recognizes apps now, thats great.

    How about to take it further an define videoplayer apps to use the movie-mode automatically. I could tell it that if VLC is running to go into movie mode the same way to shut down if photoshop is running.



  • @cartel I very much agree with this. As the name says, AppData is for data (ie. configuration files and such), but not actual executables - that's what Program Files is for.



  • @tambre said in f.lux beta discussion:

    @TwoCables
    Hi. My mouse isn't being coloured. Any suggestions?

    Yeah, I have 3 different methods. Two of them do the exact same thing but the approach is different. One of the 3 is my favorite.

    1. Use Windows Magnifier. This one is my favorite because all you have to do is open it. You don't have to log out of Windows or Restart your computer. You just open it and minimize it (if you don't want it in the way). I give all credit to Tungsten_smooth for this one. If it opens magnified above 100%, then you just set it to 100% and you never have to set it again.
    2. In the new beta of f.lux, go into the f.lux menu and choose "Options (and Smart Lighting)..." and then enable "Software mouse cursor (fixes "white cursor" after a reboot)" Then, log out or Restart. It's your choice.
    3. Enable MouseTrails in the Registry. Enabling "Software mouse cursor" in step #2 above is actually exactly the same as what I'm about to tell you: go into the Registry and open this key: HKEY_CURRENT_USER\Control Panel\Mouse. In the right-hand pane, double-click "MouseTrails" and change the value to -1 or 99, whichever might work better for you for some reason. Then, log out or Restart. It's your choice. Both settings should have the same result. F.lux's "Software mouse cursor" sets this Registry subkey to '-1'.
      No matter what, i prefer using Windows Magnifier because all I have to do is open it and I'm done. I can even use the Ease of Access Center to make the Magnifier start with Windows.


  • @TwoCables said in f.lux beta discussion:

    Yeah, I have 3 different methods.

    I use a fourth: a set of black cursors, which are always the right temperature :-)



  • Is it possible to have an editable list of apps to disable flux for rather than having to have the app in the foreground when you select the menu option?

    Also anyway to auto disable on full screen apps? (Games),



  • @dreadnaut said in f.lux beta discussion:

    @TwoCables said in f.lux beta discussion:

    Yeah, I have 3 different methods.

    I use a fourth: a set of black cursors, which are always the right temperature :-)

    So, f.lux changes their color? I see that they have color.



  • @Tungsten_smooth That definitely works, but it seems induce some input lag and I don't really like the trails it adds. I'll probably stick to software mouse cursor for now.



  • @tambre said in f.lux beta discussion:

    @Tungsten_smooth That definitely works, but it seems induce some input lag and I don't really like the trails it adds. I'll probably stick to software mouse cursor for now.

    What adds trails? What did you do that added trails? Did you go into the Control Panel and enable Pointer Trails instead of going into the Registry?



  • @TwoCables

    1. Seems to introduce some minor input lag
    2. and 3: I don't quite like the mouse trails it introduces and it makes it feel like there is some input lag. I probably can bear with this for now.

    @dreadnaut Your solution seems quite interesting and might work. I'll probably try that.



  • @tambre said in f.lux beta discussion:

    @TwoCables

    1. Seems to introduce some minor input lag
    2. and 3: I don't quite like the mouse trails it introduces and it makes it feel like there is some input lag. I probably can bear with this for now.

    @dreadnaut Your solution seems quite interesting and might work. I'll probably try that.

    Those solutions should not add trails.

    For the record, the software mouse cursor option in f.lux is the Registry modification that I detailed, except you don't have to go into the Registry. So if the software mouse cursor option doesn't give you mouse trails, then you might be doing it wrong if you're doing it via the Registry. Did you type just "1" instead of "-1"? It must be negative 1. Or, just '99'.

    Even if using Magnifier adds some input lag, I don't really care because when I'm using f.lux, I'm not playing games because I'm trying to unwind, not get all wound up.


  • f.lux team

    Posted 4.21 update just now - lots and lots of new things.



  • @TwoCables I enabled the software mouse cursor. The trails aren't visible on my 120Hz monitor, but they are on my 60Hz monitor. Kinda similar to ghosting, but that doesn't happen with the software mose cursor disabled.



  • @tambre said in f.lux beta discussion:

    @TwoCables I enabled the software mouse cursor. The trails aren't visible on my 120Hz monitor, but they are on my 60Hz monitor. Kinda similar to ghosting, but that doesn't happen with the software mose cursor disabled.

    Try the "99" setting then. As I explained, sometimes '99' works better than '-1'. F.lux implements the '-1' setting.



  • @herf in v4.21 icon still reinstating itself in taskbar after reboots, have to open taskbar settings every time to send it back to the hidden area. Same with app notifications, keeps popping up after reboot even after disabling them.



  • @herf said in f.lux beta discussion:

    Posted 4.21 update just now - lots and lots of new things.

    I'm not getting the update automatically. Should I download and install?



  • I grabbed it and there's one thing I might not ever like. When I Alt+Page Down to dim, it says "dimming until sunrise". With my unusual lifestyle, I'm not so sure I'd like that because if I'm dimming and then sunset occurs, I'm going to be having to fake my location which is a bit of a nuisance. Of course, I've done it so many times now that I can do it in just a few short seconds.

    I'll be able to do some actual testing tomorrow. So far, transitions for disabling still seem pretty choppy.


  • f.lux team

    @TwoCables this has been the same for 4 years, only the notifier style changed



  • Wake up this morning and started my computer and was delighted to see temperature being a daylight, instead candle light. Looks like 4.21 version fixed the issue for me having to manually open f.lux panel, before it changes back to daylight after restart. :)


  • f.lux team

    Made a new thread to make it load faster (closing this one):
    https://forum.justgetflux.com/topic/3709/f-lux-beta-another-thread-for-4-21


Locked