Can I disable the daytime colour cast?



  • Hi, I really like the effects of f.lux at night. It surprised me but it really calms my eyes.

    However, I'm not so keen on the cast it gives to my computer during the daytime. It feels like there is a white mist over everything. I can tell this is f.lux because when I first start up my computer before f.lux fully loads in everything is slightly darker. The thing is, that even when I click to temporarily disable f.lux, or exit the program altogether, this white cast stays, which is a problem for me as I edit photographs on my computer (and also, I just prefer the way my screen looked before.)

    Is there a way to disable or edit this setting?



  • It's not a setting. For some reason, it's raising your Gamma (or perhaps you have a lower gamma setting than the default and f.lux is restoring the default for some reason). What do you have for a display adapter (GPU)?


  • f.lux team

    f.lux loads your system profile (Control Panel > Color Management).

    If you don't like your profile you should use a different one!

    (If you think we are loading it wrong please email it to justgetflux at gmail.com)



  • Hmm, my GPU is an AMD Radeon HD 7900. I seem to be using a colour profile from my monitor which is an LG.

    It definitely seems to be a gamma issue. I went into colour management to see if I could fiddle with the options, went through to calibrate, and the first step is gamma. Now it gives me a slider to adjust and it doesn't matter which way I adjust it, it just jumps straight back to the setting it was on, and which the calibration software is showing me is too high. This is with f.lux disabled for 1 hour, and when I tell the program to quit entirely and stop running.

    I was really curious about this so I decided to uninstall f.lux completely and see if the same thing happened. Restarted, went back in, and the gamma adjusts correctly.

    Kind of disappointing, to be honest, because I liked the night time effect but I won't be reinstalling unless there is a known fix for this.


  • f.lux team

    @foreversomeday We have information about this here in our FAQ:
    https://justgetflux.com/faq.html?q=calibrate+display

    The main issue is these manual controls are not making "permanent" profiles (.ICM files), and if they did everything would work fine.

    There is a utility linked in the FAQ which makes such a file, and it may work better for you.



  • But I didn't change the profile with the calibration tool. When I ran the calibration tool with f.lux running, it was showing me that the gamma was incorrect (and I was also noticing a lightness and lack of contrast in my screen when f.lux first started up.)

    When I ran the calibration tool after uninstalling and restarting, I didn't need to change any settings, because the settings it was showing me were already fine.

    The profile I have running is named after my graphics card + monitor name and ends in .ICM.

    (Thanks for the link - nothing came up when I searched!)


  • f.lux team

    Can you email us the ICM file? It is possible it is a strange one that we are loading wrong.

    justgetflux at gmail dot com

    Our ICM loader has a lot of testing and usually does this right (and frequently these days, the OS does not load the profile at all), but I want to make sure this is true.



  • @foreversomeday I know what you're describing--it's gamma settings related. I need to know your graphics hardware to assist you but will go ahead and say this is usually due to Nvidia Control Panel setting your display to 16-232, or "Limited" display color range. You'll probably want to go into the change resolution settings now--not the desktop color settings as obvious as that option may seem to contain this option, it no longer does.

    In this area, you'll want to check "output dynamic range" to be set to full, instead of limited. If this is already set as it should be, then you'll want to check your monitor's onscreen display menu for this option as well. Mine is listed under "Picture Advanced" / HDMI RGB PC Range.



  • @Tungsten_smooth said in Can I disable the daytime colour cast?:

    @foreversomeday I know what you're describing--it's gamma settings related. I need to know your graphics hardware to assist you but will go ahead and say this is usually due to Nvidia Control Panel setting your display to 16-232, or "Limited" display color range. You'll probably want to go into the change resolution settings now--not the desktop color settings as obvious as that option may seem to contain this option, it no longer does.

    In this area, you'll want to check "output dynamic range" to be set to full, instead of limited. If this is already set as it should be, then you'll want to check your monitor's onscreen display menu for this option as well. Mine is listed under "Picture Advanced" / HDMI RGB PC Range.

    He has the AMD HD 7900.

    https://forum.justgetflux.com/post/12740



  • @TwoCables I didn't see the other posts when I responded, should have checked. Ah well, I don't yet have an AMD card but I do know they took away brightness, contrast and color saturation options in recent driver releases. So I have no idea if the settings can be permanently set to decrease the gamma. I'll let herf take over this one until we find something else that I can help with.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.