How to prevent brightness/color transitions?



  • Hi, I would like f.lux to provide same colors/brightness around the clock. Is there a way to prevent it from becoming brighter in the morning?

    I have tried to set Daytime and At night settings to the same value, but still in the morning when I turn on PC it is very bright and I have to login squinting and use Alt-PgDn to bring settings to comfortable level.

    Thanks!



  • In the settings you can change the colour temperature for both day & night separately. Sounds like you just need to reduce the daytime colour down, assuming you want the brightness down all day. If you still want it to go brighter a bit later on in the day, you might have to play around with the location settings and choose a different city / town that doesn't get sunrise till later on perhaps.



  • Instead of using Alt+Page Down, just change your display's brightness. That way, it will always be at that brightness. It sounds to me like you have your display at 100% and you're using f.lux instead to change the brightness. F.lux's brightness control just changes the black level. You should change your display's brightness using its brightness controls because that will adjust the backlight's brightness.

    F.lux doesn't save your last Alt+Page Down brightness setting. It always resets back to full brightness the next time it's launched. So, it has nothing to do with it being morning. I take it you turn the computer on in the morning, leave it on all day, turn it off at night and then turn it on again in the morning? To see what I"m talking about: restart your computer right now. Seriously: I mean right this second. When you log back in to Windows, f.lux will be back to full brightness and you will have to press Alt+Page Down again. This is why you should just leave that alone and adjust your display's brightness using its brightness controls instead.

    Also, maybe you should turn the lights on in your room.



  • Thanks for quick feedback!

    1. I tried to set both day and night settings, please take a look at screenshot: alt text
      Are there any other settings I need to setup to prevent transition?

    2. In the eventing I put my computer to sleep, I do not power it down. When my PC wakes from the sleep during the day, it does not reset f.lux brightness level. Not sure why it should reset it overnight, maybe a bug?

    3. My monitors are at the lowest brightness settings available and lights in the room are on. But monitors are still too bright, even on minimum, so I have to use f.lux to dim them a little bit more.

    4. I'll try to play with timezone settings, might make f.lux become bright in the middle of the day, better than in the early morning.



  • It doesn't help that windows isn't activated. Did you forget or just running a dodgey copy?



  • @Brenning said in How to prevent brightness/color transitions?:

    It doesn't help that windows isn't activated. Did you forget or just running a dodgey copy?

    You don't have to activate Windows 10. The drawback is that mildly annoying message and lack of some minor UI settings.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.