Mouse is unaffected by f.lux



  • Not sure if this is for everyone since I've only just recently installed flux however my mouse remains at its default colour and brightness and is unaffected by f.lux



  • Yeah, this is due to the way Windows works. You have to force Windows to render the mouse cursor, and there are only 2 ways to do that:

    1. Enable mouse pointer trails in the Registry (instructions below toward the bottom). You won't see the trails, but the cursor will still be rendered which will make the cursor colored by f.lux.
    2. Open the Windows Magnifier and never close it.

    One problem with forcing the cursor to be rendered is, the mouse cursor can be completely invisible in some video games.

    There are good and bad things about both methods:

    With the Registry method, the change only takes effect when you log out of Windows and log back in (or if you just restart your computer). So if you play any video games where the mouse cursor is completely invisible with this method, then you have to first revert the Registry setting back to default and then log out or restart before you can play the game. Or, you can just carefully move your mouse around and try to imagine where the cursor is. If this isn't a problem (like, if you don't play any games or if you find the cursor is still visible in all of the ones you play), then this is definitely the best method.

    With the Magnifier method, you have to remember to open it every day. I think that can be annoying until it becomes an automatic habit. Once it's an automatic habit, then it's of course no longer a problem. I'm not sure if it can be made to start with Windows. I can try to figure that out if you wish. So far, all of my efforts have failed. I added it to the Startup folder in the Start menu, I added it to 3 different 'Run' registry keys and still nothing. Perhaps some third-party software is needed. I don't know. I tried everything though outside of finding some strange program to install to make it start with Windows.

    Here's how to make the change in the Registry to enable the pointer trails:

    1. Open Registry Editor. Perhaps the easiest way is, just open the Start menu and type "regedit". You'll see.
    2. Navigate to HKEY_CURRENT_USER\Control Panel\Mouse
    3. In the right-hand pane, double-click MouseTrails.
    4. Change the value to either 99 or -1. Both should do the same thing, but you can experiment to see if one works better than the other for some reason. On my computer, they're identical but still.
    5. Close Registry Editor
    6. Log out of Windows and log back in, or just restart.
    7. Test it.

    If you try to enable pointer trails in the Windows Mouse Control Panel, then you will find that even at the lowest setting you still see trails. Enabling it in the Registry like this is the only way to do this without actually getting any trails.



  • @TwoCables Go to Control Panel > accessiblity, or "ease of access" and you can select Magnifier or other programs like narrator to start with Windows.



  • @Tungsten_smooth said in Mouse is unaffected by f.lux:

    @TwoCables Go to Control Panel > accessiblity, or "ease of access" and you can select Magnifier or other programs like narrator to start with Windows.

    Oh that's why it won't allow it otherwise. Thank you.

    Tip: you don't have to go to Control Panel and then Accessibility to get to the Ease of Access Center. You can just open the Start menu and type "ease of access".


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.