Conflict with Lenovo Settings on Windows 10



  • So Lenovo has released a new Lenovo Settings UWP app for Thinkpad laptops solving compatibility issues against Windows 10. It comes with a new "Night Mode" feature which bahaves almost identically to f.lux except that it has only a night setting but not a day one. I've got used to how f.lux works and do not wish to switch to a new solution. So I left this feature disabled as by default. However, it seems to be stilling causing problem in the background, as represented by regularly making invalid f.lux and resulting in the screen going back to its default colour temparature.

    Uninstalling this app solves the problem, but it also offers the ability to control battery charging parameters (like when to begin and when to stop) which I've also got used to and proved nice. I've written a complaint to Lenovo but I shall think it more sensible if I would put on here as well.

    I'm running on a Thinkpad T460p, Windows 10 Home/1607, f.lux v3.12, the latest Lenovo Settings from Windows Store (cause there doesn't seem to be a version on the app page/in the app).

    Cheers ;-)



  • I experience the same flickering on my Lenovo IdeaPad 700-15ISK running the same Windows and f.lux versions. Uninstalling the app solves the problem for me as well, but I would need it.



  • I am experiencing the same effect. In fact I am writing this on an X220i that is flickering constantly. This is just typical of what Lenovo has become. They put out bloatware that isn't tested and doesn't work. Lenovo Settings may have some value, but the programs files Lenovo folder is a little over 9GB in size on my Windows 10 X220i. Only they know what most of the code is doing... My guess is that they don't know what causes this and won't get around to fixing it ever. It is just another mega chinese company that has it's own agenda.



  • Hi to all, I had the same issues with my lenovo y480, and the solution for me was to disable the following:

    Go to Setting - Battery, look for Battery Saver and uncheck "Turn battery saver on automatically if my battery falls below:"

    Seems that this causes the conflict with the lenovo settings. Once I disabled this, there is no more flickering



  • @jvaldiviezo
    That is interesting. But what I have to ask is what does the battery setting have to do with the display color temperature?



  • @proj964 honestly I don't know, but I'm glad this issue is not bothering me. And seems that the problem is related with Lenovo, but, I've not tested it with flux disabled.



  • @proj964 Well, the battery saver mode can dim the screen and it maybe lowers the number of colors displayed as well, so those settings may conflict somehow. However, for me disabling the automatic battery saver or screen dimming didn't help. :/

    EDIT: Turning off the above settings didn't solve the problems immediately, but I haven't noticed any flickering for a few hours now.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.