Screen switches back to daylight until my cursor goes over a clickable link in chrome



  • Pretty much the title. I can't figure out why, but any time my cursor switches to the hand/click symbol my screen goes into nighttime mode until I pull my cursor off of that link. I tried doing windows update, and reinstalling f.lux. No dice so far. any help would be appreciated. I have windows 10 on a lenovo ideapad y700.

    Edit: So it only happens when I'm in a web browser. The other applications on my computer work just fine. Might have something to do with me using chrome i'm not sure.



  • I've seen this problem posted on here before, but I don't remember if we solved it. Even so, there's a small and simple change we can make to the Registry that I think has a slight chance of being the solution.

    Basically, you navigate to this Registry key: HKEY_CURRENT_USER\Control Panel\Mouse

    In the right-hand pane, double-click "MouseTrails" and change the value to either '-1' or '99' (I don't know what the difference is really).

    After this, you log out of Windows and log back in. Or you can just restart the computer. Either way, Pointer Trails will be enabled after doing this, but it will be at such a minimum that you won't notice at all. Enabling Pointer Trails forces Windows to render the cursor which means this might solve the problem. Usually this fix is just for solving a problem where the mouse cursor doesn't get colored by f.lux.

    The only problem with this is that this causes the cursor to become invisible in some video games. For this reason, I have a fairly easy way to toggle this Registry value back and forth between '0' and '-1' or '99' with a simple .Reg file (well, two: one for turning the mouse trails on and one for turning them off). It just requires logging out and back into Windows each time.

    Again though, I'm not really sure this will work. I think it just has a slight chance of working, to be honest.



  • I went to the Control panel >hardware> mouse and switched on trails on the lowest setting. I won't know for sure if it works until tonight, but I switched the daytime to the night setting and it is working fine now. I'll edit this when it gets dark here. Thanks for the help.



  • @TwoCables Okay so with the mouse trail on, it is fine, but if cursor over the taskbar with chrome open it will go to daylight. Other than that it works great.



  • @Keizzer said in Screen switches back to daylight until my cursor goes over a clickable link in chrome:

    @TwoCables Okay so with the mouse trail on, it is fine, but if cursor over the taskbar with chrome open it will go to daylight. Other than that it works great.

    Oh god we just can't win! LOL

    This may be the best we can do. Another suggestion I expect others to make is to leave Windows Magnifier open, but I think that has exactly the same end result.

    I wonder though: can you toggle Chrome's hardware acceleration setting to see if it makes any difference?



  • @TwoCables Hey thanks, it works great now. Any idea why that would fix it? It works perfect after.



  • @Keizzer said in Screen switches back to daylight until my cursor goes over a clickable link in chrome:

    @TwoCables Hey thanks, it works great now. Any idea why that would fix it? It works perfect after.

    Basically, it forces Windows to render the mouse cursor graphically. I think. It's something along those lines.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.