Windows 10 Anniversary Flicker Fix



  • Hi everybody!

    I was just about to post a last-ditch panic post here to try to get f.lux working again. Since taking the most recent Win10 update (showing up as "Cumulative Update for Windows 10 Version 1607 for x64-based Systems (KB3176495)" in update history), f.lux was disengaging in all web browsers, especially Chrome 52, when not hovering over a link, then reengaging when I clicked a link. By uninstalling that update, it seems to have resolved the issue. Hope this helps somebody else!



  • Same exact problem with the same windows update here. Seems to auto-disable or flicker in browsers - I only used Chrome. Uninstalled one of my favorite programs for now.



  • Try uninstalling the update (Windows Update > Update History > Uninstall Updates)


  • f.lux team

    Downloading it now.


  • f.lux team

    Ok KB3176495 working here on the Surface Pro 3 - please post your hardware info?



  • Lenovo Yoga 700-14ISK. I think it might have something to do with the discrete graphics chip?


  • f.lux team

    @xanderer yes it would make sense. is it "fixing" the problem after a second or two, or just disabling the colors for one GPU entirely?



  • Lenovo Y700-15 here, with discrete graphics as well - GTX960M.



  • I'm not sure how to tell. Removing the update seemed to put everything back to normal functionality.


  • f.lux team

    Ok I meant: when the problem happened, did it seem to "fix itself" within a second or two, or was f.lux disabled for >5 seconds at a time?



  • Reinstalling now, but what I had was that f.lux was working when I didn't have a browser up. When the browser was up, moving the mouse over the browser window would disable f.lux.


  • f.lux team

    @badpanda ok it sounds like maybe the NVIDIA card is not accepting color profiles at all.



  • Having the mouse focused on a non-active element in the browser window disabled flux. When I hovered over a link or something in the menu, it kicked back in and remained on for about 3 seconds.


  • f.lux team

    Got it, will bug some people. :)



  • It was awful! Two agonising days of blue! The horrors! :D

    In all seriousness, I didn't realise how much I relied on f.lux until it was in and out.



  • Here is what is happening with me. It's instant. Moving the mouse over the browser window would disable for that window.

    sample
    (inserting image in post showed broken, so adding it as a link)


  • f.lux team

    thanks - this helps a lot!



  • That's identical to my issue.



  • The KB3176495 update is only showing up as a Security Update on my comp, Lenovo Yoga 700-14ISK. I uninstalled it, but it didn't fix the flicker. I can't see any other updates either. Does anyone have ideas as to what to do next?


  • f.lux team

    Can anyone post graphics driver info?
    Device Manager > Display Adapters > Drivers

    For both GPUs if possible...




  • f.lux team

    Interesting - the Intel drivers are a bit older - 3-4 releases since then. Might explain the issue.

    Following up with some people to figure it out.



  • I am having a flickering problem on an MSI GE70 2PE Apache Pro laptop with an NVIDIA GTX 860M at driver version 21.21.13.7254, an Intel HD Graphics 4600 at Driver version 20.19.15.4444 and an Asustek MB169B+ using DisplayLink at 8.0.478.0 - the problem goes away if I disconnect the DisplayLink (USB) screen. After updating the driver to 8.0.629.0 I am still having the problem - I have to disconnect the Asustek MB169B+ to stop f.lux continuously cycling from day to night and back.



  • I am having this same exact problem. It only occurs when chrome is fullscreen. I tried uninstalling Win10 updates but couldn't fix the problem. It's also not exclusive to flux - my asus eye care switcher is doing the same thing. It has to be something Chrome is doing, but I can't figure out how to fix it.



  • I am getting the same flicking as GrahamB with the DisplayLink connected as well. If i disconnect the usb Display link then there isn't a problem.
    Acer G9-791laptop with an NVIDIA GTX 980M at driver version 10.18.13.5900, an Intel HD Graphics 530 at Driver version 10.18.15.4279 second monitor with DisplayLink at 8.0.480.0


  • f.lux team

    If you're having trouble with DisplayLink please see this thread:

    https://forum.justgetflux.com/topic/2966/windows-10-displaylink-fix/2



  • The latest fix works - no more problems with DisplayLink.

    Thanks Guys



  • Can anyone try to enable Nvidia as default video card from BIOS and check back if flicker is fixed by this trick ? Thank you.



  • Hello guys, i come back with BIG News! I managed to fix this issue on my Lenovo y700.
    You have to go to Lenovo support page, select your device model and download the latest Intel HD VGA drivers. I had installed a version from 2015 and the latest was from 2016. Unpack the archive but do not run setup because it will fail.
    Now go to Device Manager, right-click on Intel HD and choose to upgrade drivers.
    Click: Browse My computer - Next - Let me pick from a list of device drivers on my computer - Click on Have Disk -> Browse and open the path where the drivers were unpacked (C:\drivers\Intel VGA Driver\Graphics) and select igdlh64.inf fro x64 OS or igdlh32.inf for X86 OS.
    After installation is completed reboot your computer once or twice.
    After the first reboot i had a problem with my desktop files missing but it might be due to other things i did to my system. If you encounter this issues just go to C:\windows\system32\config\systemprofile\ and create here a new folder called Desktop. Reboot and everything should be ok.

    PS: flux works great after this.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.